cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5665
Views
0
Helpful
10
Replies

Dual - ISP ( 2811 Router)

kri.chi.85
Level 1
Level 1

Dear Tech gurus,

My Devices:

     Will 2811 Router with 4 switch port module

Problems:

     How to do dual ISP configuration on this router.

Please help me out....

10 Replies 10

JohnTylerPearce
Level 7
Level 7

Can you tell us a little more about your setup?

Do you mean two links to the same ISP or one link each to different ISPs? I'm assuming you mean the latter.

Also, what kind o

Two Diiferent ISP (Two differnet Ethernet Connectons) terminated to 2811 Router.

Will a 2811 router support dual NAT ?  - Meaning as follows

ISP 1 Connected to Fast Ethernet 0/0

ISP 2 Connected to Fast Ethernet 0/1

LAN systems are connected  to a 4 port,  switch Port Module (Additional Module) on 2811 Router .

Configuration done by me:

Both Fast Ethernet interfaces was configured with proper IP's and working fine.

NAT was done twice for both the LINKS.

2 Default routes was configured.

Send me a Link to find the Configuration Guide.

Two Diiferent ISP (Two differnet Ethernet Connectons) terminated to 2811 Router.

Will a 2811 router support dual NAT ?  - Meaning as follows

ISP 1 Connected to Fast Ethernet 0/0

ISP 2 Connected to Fast Ethernet 0/1

LAN systems are connected  to a 4 port,  switch Port Module (Additional Module) on 2811 Router .

Configuration done by me:

Both Fast Ethernet interfaces was configured with proper IP's and working fine.

NAT was done twice for both the LINKS.

2 Default routes was configured.

Send me a Link to find the Configuration.

the above attached link says only failover.

Can you send me a attachment for Load Balancing on 2811 router

With Regards,

Chaitanya.G

Have a look at the below link and you will find the answers to your questions

https://supportforums.cisco.com/docs/DOC-8313

Hope this help

If helpful rate

Hi,

Here's something that I tested a while back (However this does not track any reachability using IP SLA, etc..):

! Default routes going to two different ISP's.

ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip route 0.0.0.0 0.0.0.0 192.168.1.1

! access to split your user traffic (Odd IP's going one wayand even going the other)

access-list 1 permit 192.168.3.0 0.0.0.254
access-list 2 permit 192.168.3.1 0.0.0.254
!

! Match the access list and the outgoing interface to ISP1 in the route-map.
route-map ISP1 permit 10
match ip address 1
match interface GigabitEthernet0/1
!

! Match the access list and the outgoing interface to ISP 2 in the route-map.
route-map ISP2 permit 10
match ip address 2
match interface FastEthernet0/0/0

! PAT configuration

ip nat inside source route-map ISP1 interface FastEthernet0/0/0 overload
ip nat inside source route-map ISP2 interface GigabitEthernet0/1 overload

HTH,

Amrik

That's pretty awesome Singh, I'm going to try that out in GN3.

Give it a go and try adding IP SLA tracking to it if it works.

The config above same as the link I provide tom you except without pbr and ip sla

If you don't want want to use pbr then just avoid pbr and apply the ip sla to the route to avoid blackholing the traffic in the case of one link went down

HTH

Review Cisco Networking for a $25 gift card