cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1916
Views
0
Helpful
5
Replies
Beginner

Dual ISP on 877 Router - Cable through FA0 & Onboard DSL

Hi, I am new to this forum, but have read so many posts here which have helped me greatly.

My issue is, At home I have a Cisco 877 router, I also have Optus Cable internet and Telstra Business Direct DSL. I have configured the ATM interface for the Telstra DSL connection through the onboard DSL interface. I have also configured Fast Ethernet port 0 as a vlan2 port, which is configured for use with the Optus Cable internet (this is connected through an Optus Netgear CG3000 router). The Nethgear has DHCP enabled (192.168.0.xxx range), as does my Cisco 877 (10.0.0.xxx range).

Firstly, the Telstra Business DSL is due to be connected tomorrow between 9am and 1pm, so it is not physically connected as yet.

From my laptop connected to fa3 and using Console connection, I can ping all of the 192.168.0.xxx addresses that exist, as well as my own laptop and a VoIP phone I have connected to fa2 (laptop is 10.0.0.100, VoIP phone is 10.0.0.101 both DHCP assigned, not MAC Reserved either).

I can use internet explorer on my laptop to connect to the Netgear router, but no other internet pages. I also cannot connect to my Fuji-Xerox printer at 192.168.0.20 through the web browser, yet I can ping it from the router.

I don't have a huge experience with Cisco as yet, and everything I have learnt has been basically self tought. I am looking into doing my CCNA, once I achieve enough funds

Now, what I am trying to achieve ideally is, to combine both the Cable and DSL services to in effect double my speed? if this isnt available, a load-balancing type of scenario would also be good. Both DSL plans have a 500gb download limit, but the reason I needed the Telstra DSL is the VoIP phones I am using won't connect through Optus (Optus have locked nearly everything out), and Optus will not give me a STATIC IP address with the Cable, whereas I have on on the Telstra DSL, I would like to Remote Desktop into my main PC eventually.

Can someone please help me, get this working...

The IOS on my router is:    C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(6)T7

The Optus Cable Modem IP is 192.168.0.1, the Cisco 877 router IP is 10.0.0.1

I hope that is enough info, to maybe get someone to help with my problem.. The current config (complete, with username & passwords ### out) is below: (Bear in mind there's probably many things thats not needed.

Once I get the router working, I will configure my 2960 switch and have all devices connected through this. All devices on my network do not need to stay in the 192 range, they can be 10.0.0.xxx. The DHCP could be disabled on the Netgear (Cable Modem) if that's required as well.

Thank you in advance, if you need any other info, please just ask, so I can provide it.

Adam.

-------------------------------------------------------------------------------

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname N3813163R
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
!
no aaa new-model
clock timezone aest 10
!
crypto pki trustpoint TP-self-signed-116689578
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-116689578
revocation-check none
rsakeypair TP-self-signed-116689578
!
!
crypto pki certificate chain TP-self-signed-116689578
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31313636 38393537 38301E17 0D313230 39323331 30343031
  365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3131 36363839
  35373830 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  B0B2DAAA 3EF5A2E4 851DF9FB 5AE9C77C 3DC5AFFE 31247130 6DAE14C3 2517D76A
  2C20C75D 7D8D1224 F7ABE68F 3D156AE3 EE7DAFF2 CFB4DB00 9A177BC5 8646607C
  FDBF5D3B E3FC64FD B2D5ED0B 065A5947 C88A4272 7C9362ED 54ABFAEF AD07EA40
  CE25D633 4EC2AFAC A310B8C6 821E5657 BF5F847D 5236D0F5 16F3671E 8151DC6F
  02030100 01A37930 77300F06 03551D13 0101FF04 05300301 01FF3024 0603551D
  11041D30 1B82194E 33383133 31363352 2E61646C 696B6164 612E636F 6D2E6175
  301F0603 551D2304 18301680 14E06C86 9EC5447F 41D3FC77 139F377D 9125BDD6
  88301D06 03551D0E 04160414 E06C869E C5447F41 D3FC7713 9F377D91 25BDD688
  300D0609 2A864886 F70D0101 04050003 8181000E CCFAAC10 C799BFD2 831A868E
  02523016 B18A71EF 148A5016 8A06FC18 24AA6335 A409BDA0 5753EB19 E99DEF3F
  76745F85 D0C51C20 B4BECE58 C214BA16 0B839891 FBE93055 7A087EB0 A8B559CB
  AED8C343 BDAD858F DFE04269 2122A57B B9465D24 B2DBDE22 51E10C32 15B05926
  09937F01 49578DEE 73344425 791FF088 77B28D
        quit
dot11 syslog
no ip source-route
ip dhcp excluded-address 10.0.0.1 10.0.0.99
ip dhcp excluded-address 10.0.0.151 10.0.0.254
!
ip dhcp pool DHCPPool1
   network 10.0.0.0 255.255.255.0
   default-router 10.0.0.1
   domain-name adlikada.com.au
   dns-server 139.130.4.4 203.50.2.71
   lease 8
!
!
ip cef
no ip domain lookup
ip domain name adlikada.com.au
ip name-server 139.130.4.4
ip name-server 203.50.2.71
!
!
!
!
username ########## privilege 15 password 0 ##########
!
!
!
archive
log config
  hidekeys
!
!
!
bridge irb
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
  dialer pool-member 1
  protocol ppp dialer
!
!
interface FastEthernet0
switchport access vlan 2
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description *** DATA LAN ***
no ip address
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1460
bridge-group 1
!
interface Vlan2
description *** OPTUS CABLE WAN ***
ip address dhcp
ip nat outside
ip virtual-reassembly
!
interface Dialer0
mtu 1492
ip address negotiated
no ip redirects
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ##########@direct.telstra.net
ppp chap password 0 ##########
ppp pap sent-username ##########@direct.telstra.net password 0 ##########
!
interface BVI1
ip address 10.0.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 Vlan2
no ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source list nat interface Vlan2 overload
!
ip access-list extended nat
permit ip 10.0.0.0 0.0.0.255 any
!
access-list 1 permit 10.0.0.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run

!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
login local
transport input telnet ssh
!
scheduler max-task-time 5000
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end

-------------------------------------------------------------------------------

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advisor

Dual ISP on 877 Router - Cable through FA0 & Onboard DSL

Hi,

no ip route 0.0.0.0 0.0.0.0 Vlan2

ip route 0.0.0.0 0.0.0.0 192.168.0.x   where .x is the last octet value of the IP address of Netgear

no ip nat inside source list 1 interface Dialer0 overload

no ip nat inside source list nat interface Vlan2 overload

no access-list 1

no ip access-list nat

access-list 199 permit 10.0.0.0 0.0.0.255 any

route-map ADSL

match ip address 199

match interface Dialer0

route-map CABLE

match ip address 199

match interface Vlan2

ip nat inside source route-map ADSL interface Dialer0 overload

ip nat inside source route-map CABLE interface Vlan2 overload

Try this and lets us know.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

5 REPLIES 5
Highlighted
Advisor

Dual ISP on 877 Router - Cable through FA0 & Onboard DSL

Hi,

no ip route 0.0.0.0 0.0.0.0 Vlan2

ip route 0.0.0.0 0.0.0.0 192.168.0.x   where .x is the last octet value of the IP address of Netgear

no ip nat inside source list 1 interface Dialer0 overload

no ip nat inside source list nat interface Vlan2 overload

no access-list 1

no ip access-list nat

access-list 199 permit 10.0.0.0 0.0.0.255 any

route-map ADSL

match ip address 199

match interface Dialer0

route-map CABLE

match ip address 199

match interface Vlan2

ip nat inside source route-map ADSL interface Dialer0 overload

ip nat inside source route-map CABLE interface Vlan2 overload

Try this and lets us know.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

Highlighted
Beginner

Dual ISP on 877 Router - Cable through FA0 & Onboard DSL

I entered all of the above, and it worked wonderfully..

I did have a problem initially finding the "no ip access-list nat" but found the entry under the extended nat configuration, so ince I entered that interface, I could do the NO statement.

Also, the access-list 199 permit 10.0.0.0 0.0.0.255 any wouldn't work, I did a google search and found that it should have been access-list 199 permit ip 10.0.0.0 0.0.0.255 any. Was this correct?

However, it works. I can use either subnet to view the other one, including websites and general web pages. I can ping all addresses, and it looks to be working as desired.

I do have one question though, How can I check what traffic is going through either ADSl or CABLE?

Thank you again for your help, it has been greatly appreciated

Adam.

Highlighted
Advisor

Dual ISP on 877 Router - Cable through FA0 & Onboard DSL

Hi,

yes I did some typos and I'm sorry for that but happy you found out the correct syntax anyway and that it is working.

So now you are doing load-sharing and it is the switching process which decides how to do it. As CEF is the default switching process, it load shares by src-dst IP so traffic with same srcIP and dstIP will take the same path.

Now  if you want to see traffic just enable netflow egress on each outgoing interface and send to a netflow collector.

If you want to force some traffic out one interface then you can use Policy Based Routing.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted
Beginner

Dual ISP on 877 Router - Cable through FA0 & Onboard DSL

I have tried to set up the netflow, and I think I have. I am just a little confused with how to read the data, and as I don't have a server located on this network I can't send the data anywhere easily.

So, I think the Load Sharing is working, I can see the activity lights on both the Cisco 877 (DSL) and my Netgear Cable Router flashing away madly. I just have no idea what is connected where.

I have disabled the Netgear Wireless and DHCP server, and have made the Cisco 877 the new DHCP server, and added a Wireless N Access Point (although cheap crappy one). I can see through the Console that all my devices have now connected to the Cisco and been given a 10.0.0.x address. So basically now the older 192.168.0.x address is purely for routing to the Cable Modem.

I've tried reserving a MAC address to a fixed IP address, and routing that Ip address directly to the DSL connection only, but didn't seem to have much luck in assigning the DHCP reservation (yet, I had it working 12 months ago when I did it last time). I need this due to a VoIP phone that will only work when routing through the ATM0 interface, as this is my main business line, I need to get this one working.

Is Netflow the only way I can see who is using which interface? I placed the ingress and egress flows on the FA4 and ATM0 interfaces, was this correct?

Lastly, I've been looking at possibly going to a Cisco 2821 Router (as I would like to implement Voice over the next 12 months) with ADSL and Cable WIC's as well as possibly the 16 or 24port Network Module (depending if I want to go with a seperate Gigabit POE switch), would this be an easier solution?

Thanks again

Adam.

Highlighted
Advisor

Dual ISP on 877 Router - Cable through FA0 & Onboard DSL

Hi,

Is Netflow the only way I can see who is using which interface? I placed  the ingress and egress flows on the FA4 and ATM0 interfaces, was this  correct?

It all depends on what you want to see exactly. it should be enabled on dialer0 and Vlan2 interfaces egress as you want to see the traffic leaving your router.

For dhcp reservation, post your config.

I would prefer a separate switch( like 3560 8 port) over the switching module. The problem is that it will surely cost you more to get  an adsl and cable wic on the 2800 if these exist.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
CreatePlease to create content
Content for Community-Ad