cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5179
Views
4
Helpful
3
Replies
Highlighted

End to End QoS on 2960, 2951 router and 4507 Switch

I'm a noob when it comes to QoS and I have been doing a good bit of reading and testing lately with QoS. Right now in our environment all of our PoE switches are 2960S switches, we also have all Cisco VoIP phones (7942, 7945s). So the 2960s connect via layer 2 to our 4507 switch. I have an interface coming off of the 4507 (no switchport) with an IP address assigned that connects to our MPLS router. I have been reading that mls qos trust qos on the 2960 ports isn't needed since they aren't trust ports so I have switched those over to mls qos trust dscp. ohh FYI, I am using the auto qos voip cisco-phone command on the 2960's and on the 4507. So here is an example of a switchport on the 2960:

interface GigabitEthernet1/0/4

switchport access vlan 240

switchport mode access

switchport voice vlan 720

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust device cisco-phone

mls qos trust dscp

auto qos voip cisco-phone

spanning-tree portfast

service-policy input AutoQoS-Police-CiscoPhone

Here is an example of the trunk on the 2960 connecting to the 4507. I matched CoS here since this is a trunk port? I may be completely off here.

interface GigabitEthernet1/0/49

description TRUNK BACK TO CORE

switchport trunk native vlan 5

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

service-policy input AutoQoS-Police-CiscoPhone

ip dhcp snooping trust

On my 4507, it is using this QoS policy.

class-map match-all AutoQos-VoIP-Control-Dscp26

match dscp af31

class-map match-all AutoQos-VoIP-Control-Dscp24

match dscp cs3

class-map match-all AutoQos-VoIP-Bearer-Cos

match cos 5

class-map match-all AutoQos-VoIP-Control-QosGroup24

match qos-group 24

class-map match-all AutoQos-VoIP-Control-QosGroup26

match qos-group 26

class-map match-all AutoQos-VoIP-Bearer-QosGroup

match qos-group 46

class-map match-all AutoQos-VoIP-Bearer-Dscp

match dscp ef

class-map match-all AutoQos-VoIP-Control-Cos

match cos 3

!

policy-map AutoQos-VoIP-Input-Cos-Policy

class AutoQos-VoIP-Bearer-Cos

set qos-group 46

class AutoQos-VoIP-Control-Cos

set qos-group 24

policy-map AutoQos-VoIP-Input-Dscp-Policy

class AutoQos-VoIP-Bearer-Dscp

set qos-group 46

class AutoQos-VoIP-Control-Dscp26

set qos-group 26

class AutoQos-VoIP-Control-Dscp24

set qos-group 24

policy-map AutoQos-VoIP-Output-Policy

class AutoQos-VoIP-Bearer-QosGroup

set dscp ef

set cos 5

priority

police cir percent 33

class AutoQos-VoIP-Control-QosGroup26

set dscp af31

set cos 3

bandwidth remaining percent 5

class AutoQos-VoIP-Control-QosGroup24

set dscp cs3

set cos 3

bandwidth remaining percent 5

class class-default

dbl

Here is the config from a switchport on the 4507 that trunks to the 2960 PoE switches.Again I am matching CoS here because of the Trunk.

interface GigabitEthernet1/9

description TRUNK TO 10PoESW-Z1

switchport trunk native vlan 5

switchport mode trunk

auto qos voip trust

service-policy input AutoQos-VoIP-Input-Cos-Policy

service-policy output AutoQos-VoIP-Output-Policy

ip dhcp snooping trust

Does this look right so far?

3 REPLIES 3
Highlighted
Cisco Employee

Hello Justin,

On the trunk links between the 2960 and the 4507, use auto qos voip trust and not auto qos voip cisco-phone. Also I don't see a trust statement on the g1/9 of the 4507.

Also make sure qos is enabled globally.

Cheers,

Fabienne

Highlighted

I went back through and double checked and all but a couple had the auto qos voip trust interface sub-command. Referring ot the gi 1/9 interface on the 4507, you said that you didn't see the trust command? Are you referring to the auto qos voip trust command? If so, that command is on the interface.

You also noted enabling qos globally on the devices, what command does that?

Highlighted

To enable qos globally on the 4500 (unless you are using sup6E/sup7E):

Switch(config)# qos 

http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst4500/12.2/50sg/configuration/guide/qos.html#wp1207227

Regarding the auto qos command, it should add a qos trust cos or dscp statement under the interface configuration but I do not see that.

http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst4500/12.2/50sg/configuration/guide/qos.html#wp1583082

To enable qos globally on the 2960, use the following command:

mls qos

http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst2960/software/release/12.2_55_se/configuration/guide/swqos.html#wp1058769

Cheers,

Fabienne

Content for Community-Ad