06-27-2016 08:06 AM - edited 03-08-2019 06:23 AM
How to understand why a large error / discard packets at the port?
Cisco 3650:
interface GigabitEthernet1/0/11
switchport mode trunk
logging event trunk-status
logging event spanning-tree
logging event status
channel-group 10 mode on
spanning-tree portfast
#sh int gi1/0/11
GigabitEthernet1/0/11 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 74a2.e604.dc0b (bia 74a2.e604.dc0b)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 17/255, rxload 27/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:05, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 2467174971
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 106682000 bits/sec, 12926 packets/sec
5 minute output rate 67463000 bits/sec, 13045 packets/sec
107462093550 packets input, 76077869418992 bytes, 0 no buffer
Received 339441301 broadcasts (339080654 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 339080654 multicast, 0 pause input
0 input packets with dribble condition detected
166101641755 packets output, 150601875113395 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
Cisco 3020:
interface GigabitEthernet0/17
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on
GigabitEthernet0/17 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 0019.e770.3191 (bia 0019.e770.3191)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 23/255, rxload 16/255
Encapsulation ARPA, loopback not set
Keepalive not set
Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:16, output 00:00:03, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 63641000 bits/sec, 11640 packets/sec
5 minute output rate 91760000 bits/sec, 11685 packets/sec
3014944888 packets input, 4102678929 bytes, 0 no buffer
Received 11829905 broadcasts (0 multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 11006140 multicast, 0 pause input
0 input packets with dribble condition detected
89217199 packets output, 2253604584 bytes, 0 underruns
0 output errors, 0 collisions, 3 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
Solved! Go to Solution.
06-27-2016 08:32 AM
Actually that's ok what you have above your drop rate is 0.0148 % per volume of traffic which is less than what Cisco states is an issue , there will be legitimate drops over time burst traffic , over utilization, buffers filled etc can cause it , but if you work out the volume of traffic gone through your port against the amount of drops seen its ok
You shouldn't have this on trunk config--- spanning-tree portfast
are there virtual machines on those blades
have you checked the rx and tx when these drops are occurring what's it sitting at if the drops are incrmeneting only when its really high
You can check if its burst traffic with wireshark
https://notalwaysthenetwork.com/2014/01/06/microburst-detection-with-wireshark/
06-27-2016 08:32 AM
Actually that's ok what you have above your drop rate is 0.0148 % per volume of traffic which is less than what Cisco states is an issue , there will be legitimate drops over time burst traffic , over utilization, buffers filled etc can cause it , but if you work out the volume of traffic gone through your port against the amount of drops seen its ok
You shouldn't have this on trunk config--- spanning-tree portfast
are there virtual machines on those blades
have you checked the rx and tx when these drops are occurring what's it sitting at if the drops are incrmeneting only when its really high
You can check if its burst traffic with wireshark
https://notalwaysthenetwork.com/2014/01/06/microburst-detection-with-wireshark/
06-27-2016 10:31 PM
Thank you,
Yes, there are many VMs. Between switches the portchannel (4 links). A lot of traffic. But traffic clogged only one link
06-28-2016 12:26 AM
If all your traffic is going down 1 link in the port-channel you could change the load balance distribution for the etherchannel to try and get it across all links as evenly as possible
example
port-channel load-balance src-dst-port
06-29-2016 09:44 PM
It's hard to choose a type of balancing.
I have:
1) BladeCenter with 16 blades and two Cisco 3020 switches. All blades have two internal ethernet ports (one at each switch).
2) Both Cisco 3020 are connected to core - Cisco 3650 stack, by etherchannel (4 links each).
What type of load balancing should I use?
Now I use:
1) VMware teaming: Route based on physical NIC load (without LAG group)
2) BC switched Cisco 3020: src-mac
3) Core: src-mac
06-30-2016 12:12 AM
This is what we have set same type of setup just back to 65s and it works fine you could test that see how that goes
#sh ver | i WS-CBS3020-HPQ
cisco WS-CBS3020-HPQ (PowerPC405) processor (revision J0) with 131072K bytes of memory.
Model number : WS-CBS3020-HPQ
* 1 24 WS-CBS3020-HPQ 15.0(2)SE6 CBS30X0-IPBASEK9-M
#sh run | i load-balance
port-channel load-balance src-dst-ip
#
06-30-2016 12:21 AM
Ok, I will change to src-dst-ip on Cisco 3020 and 3650
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide