cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

225117
Views
471
Helpful
89
Replies
Beginner

Hi,we had the same problem

Hi,

we had the same problem also after installing a new router, my colleague fixed by adding the following config line:

ip tftp source-interface interface_from_where_you_manage_router  (in our case it is a Loopback).

 

Regards,

Iris

Beginner

this is the best resolution

this is the best resolution to the issue. we were sourcing from the wrong interface.

your post helped me resolve the issue we were having with a new router install.

thank you.

Beginner

This solved my problem! 

This solved my problem! 

Beginner

Thanks a lot ! Tried to

Thanks a lot ! Tried to upgrade Catalyst 3560 ios, couldn't get it working due to this tftp timeout error. This suggestion worked like a charm. I connected switch directly to laptop. 

[Laptop, tftpd32 running] ----------------utp cable----------------[==SW==]

Added following;

ip tftp source-interface Vlan6                         

(Where vlan 6 is a SVI. I use this as Management interface )

And you should add login details if your ftp server requires so. 

Beginner

please try as follows telnet

please try as follows

 

telnet <tftp server IP> 69

if the status is opened, then we can trust the TFTP server, pls check...

Beginner

HiI have been having the same

Hi

I have been having the same problem with a second hand router: all of my other routers can load from and save to the ftp server; but with one of them I got the dreaded tftp time out!

After reading this and trying, and discounting, some of the suggestions I went back the running config and found that there was a line in there which was causing the problem:

ip tftp source-interface Loopback1

I just changed the interface as below:

(config)#ip tftp source-interface fa0/0

Now everything works fine!

 

Hope that helps someone :)

Cheers

Mick

Beginner

Bingo!  100€ and a washing

Bingo!  100€ and a washing machine to you, mickmcguinness.

Everyone,  run this to see what is gumming up the works

sh run | i tftp

Beginner

nice shoot!!!! I have the

nice shoot!!!! I have the problem with ISR 4331

Beginner

Hi,I had the same problem

Hi,

I had the same problem trying to upload a new software image to a 3750x switch via solarwinds tftp. Finally I found out, the problem was the checkpoint vpn software installed on my laptop. I had to remove it because even when the program was closed, there was still a sort of firewall active in the background.

cheers,

Marc
 

Highlighted
Beginner

Was this issue resolved ? If

Was this issue resolved ?

 

If yes, what did you do to resolve it, please share the steps that you made to resolve this problem. so that we can learn something out of this.

Beginner

I encountered this problem

I encountered this problem today. I have 3 routers (two 1841's and one 2801) and 3 switches (all 2950's) for my CCNA lab at home. I have them all connected to my cable internet router (dlink dgl-4500). I had to enter static routes on the dlink to get packets back to the cisco routers.

Two of my routers were each one hop away from the TFTP server (a raspberry pi). Those both connected fine. One of my routers was directly connected to the network with the raspberry pi and it was NOT connecting! It could ping the IP address just fine, but no TFTP. Disabled firewall -- still no joy.

In my case, I found that my hosts.allow file on the TFTP server box was only configured to allow the network with the cable router and no other networks. The routers that were one hop away used that allowed network to get back to the TFTP server (via static routes on the cable router), but the one router directly connected was on a network not listed in hosts.allow (and I have ALL:ALL in hosts.deny).

This is one case where ping will work but TFTP will fail, even with no firewall running. Wireshark did not help much either. I guess I won't be forgetting about hosts.allow next time.

I have encountered the same

I have encountered the same scenario. tried with multiple things but no luck at last we logged in to the computer with admin rights then started working.

I had a same scenario just an

I had a same scenario just an out of a box isr 4321 tftp is working no windows firewall on my laptop. I can ping the router from laptop and from router my laptop is reachable. I just enter the following command.

Router(config)#ip tftp source-interface gig0/0/0

where the int gig0/0/0 is where my laptop is directly connected.

Hope it will help you all

Have a good day :)

Beginner

Re: I had a same scenario just an

I was directly connected via a cross over cable to my ISR4331 and was having the same issue.  Adding ip tftp source-interface gig0/0/0 worked for me.  Thanks!

Beginner

Re: I had a same scenario just an

Same for me i had time outs and time outs on a ISR3121/K9 .. I forgot about this command but thanks for your post i solved it , i can TFTP again :) 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards