04-26-2020 11:43 AM
Hello,
I spotted a problem while creating network in Packet Tracer. I've connected 3650-24PS switch to ISR4321 router by two copper straight-through cables and then tried configuring EtherChannel on both devices. Setup is working fine until I save and reopen PT. Then Port-Channel 5 on switch has status of down, but router's one keeps being up. I don't know if I made some mistake during the configuration, but I found this discussion which faces same problem. I hope there is something I can do to make this working without changing the switches. I attach project file if someone finds it useful.
Switch configuration:
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SWA.2
!
!
!
!
!
!
!
no ip cef
ip routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Port-channel5
no switchport
ip address 192.168.3.78 255.255.255.252
!
interface Port-channel10
switchport trunk allowed vlan 50
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel20
switchport trunk allowed vlan 60
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel30
switchport trunk allowed vlan 70
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel40
switchport trunk allowed vlan 80
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/1
no switchport
no ip address
duplex auto
speed auto
!
interface GigabitEthernet1/0/2
no switchport
no ip address
duplex auto
speed auto
!
interface GigabitEthernet1/0/3
switchport trunk allowed vlan 50
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 10 mode desirable
!
interface GigabitEthernet1/0/4
switchport trunk allowed vlan 50
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 10 mode desirable
!
interface GigabitEthernet1/0/5
switchport trunk allowed vlan 60
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 20 mode desirable
!
interface GigabitEthernet1/0/6
switchport trunk allowed vlan 60
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 20 mode desirable
!
interface GigabitEthernet1/0/7
switchport trunk allowed vlan 70
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 30 mode desirable
!
interface GigabitEthernet1/0/8
switchport trunk allowed vlan 70
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 30 mode desirable
!
interface GigabitEthernet1/0/9
switchport trunk allowed vlan 80
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 40 mode desirable
!
interface GigabitEthernet1/0/10
switchport trunk allowed vlan 80
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 40 mode desirable
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan50
mac-address 0003.e403.7001
ip address 192.168.0.129 255.255.255.224
!
interface Vlan60
mac-address 0003.e403.7002
ip address 192.168.0.161 255.255.255.224
!
interface Vlan70
mac-address 0003.e403.7003
ip address 192.168.0.193 255.255.255.224
!
interface Vlan80
mac-address 0003.e403.7004
ip address 192.168.0.225 255.255.255.224
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.3.77
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
!
end
Router configuration:
!
version 15.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RTA.2
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Port-channel5
ip address 192.168.3.77 255.255.255.252
!
interface GigabitEthernet0/0/0
no ip address
channel-group 5
duplex auto
speed auto
!
interface GigabitEthernet0/0/1
no ip address
channel-group 5
duplex auto
speed auto
!
interface GigabitEthernet0/1/0
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/1
switchport access vlan 102
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/2
switchport access vlan 103
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/3
switchport mode access
switchport nonegotiate
!
interface Vlan1
no ip address
shutdown
!
interface Vlan102
mac-address 00d0.d3bb.2201
ip address 192.168.3.54 255.255.255.252
!
interface Vlan103
mac-address 00d0.d3bb.2202
ip address 192.168.3.58 255.255.255.252
!
router ospf 2
log-adjacency-changes
network 192.168.3.52 0.0.0.3 area 0
network 192.168.3.56 0.0.0.3 area 0
network 192.168.3.76 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Solved! Go to Solution.
04-27-2020 08:59 AM
Nevermind, fixed. Thanks for help.
04-27-2020 08:59 AM
Nevermind, fixed. Thanks for help.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide