cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

5532
Views
6
Helpful
3
Replies
Highlighted
Beginner

EtherChannel (LACP) Configuration - Catalyst 3750x

Greetings,

I have a couple questions for the group.

Q1) Should the port configuration options of each individual line of the etherchannel bundle also be reliazed on the logical port-channel interface? In the below example, should "spanning-tree portfast" and "spanning-tree bpduguard enable" be coded on the port-channel interface?

Q2) Are there any best practices, general rules, or nuances you can share regarding the configuration of etherchannels as it pertains to the above question? What about etherchannel trunks?

Thank You

========================

!

interface Port-channel3

description EtherChannel (LACP, 2-port) for Server1

switchport access vlan 999

switchport mode access

!

!

!

interface GigabitEthernet3/0/12

description Server1 NIC1

switchport access vlan 999

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

channel-group 3 mode active

!

!

interface GigabitEthernet4/0/12

description Server1 NIC2

switchport access vlan 999

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

channel-group 3 mode active

!

========================

.

3 REPLIES 3
Highlighted
Enthusiast

EtherChannel (LACP) Configuration - Catalyst 3750x

Hi,

When you configure an EtherChannel, configuration changes applied to the port-channel interface apply to all the physical ports assigned to the port-channel interface, and configuration changes applied to the physical port affect only the port where you apply the configuration.

Below you have a link with the configuration guidelines:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750x_3560x/software/release/12.2_55_se/configuration/guide/swethchl.html#wp1275881

Hope this helps.

Highlighted
Beginner

Re: EtherChannel (LACP) Configuration - Catalyst 3750x

Thank you Leo for the reply and link.

Reading through the documentation you linked, I discovered this:

"NOTE    After you configure an EtherChannel, configuration changes applied to the port-channel interface apply to all the physical ports assigned to the port-channel interface, and configuration changes applied to the physical port affect only the port where you apply the configuration."

This statement isnt quite clear to me. Does this mean that line-item configurations to the EtherChannel are propagated down to the individual ports? But line-item configuration changes made to indiviual ports will not propagate up the the EtherChannel?

So with the example I gave above, does Port-channel3 need to have explicit line-item configurations for "spanning-tree portfast" and "spanning-tree bpduguard enable"; and should it look like the following?

interface Port-channel3

description EtherChannel (LACP, 2-port) for Server1

switchport access vlan 999

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

.

Highlighted
VIP Mentor

Re: EtherChannel (LACP) Configuration - Catalyst 3750x

Hello

Yes you are correct in your example

L2/L3 etherchannel:

1) Apply the port-channel command to the designated interfaces - This will auto create the port-channel interface

2) apply the necessary interface commands to the port-channel - this will propagate to the physical interfaces.

3) Shutdown and restart the physical interfaces

If you change the physical interfaces after the port channel is created it will NOT propagate to the port channel

Res
Paul

Sent from Cisco Technical Support iPad App



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad