cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
805
Views
19
Helpful
9
Replies

etherchannel- stack 3750X

a.aitkaddour
Beginner
Beginner

I have two stacks 3750X on two different sites with two links L_2_L, and I want to configure the port channel to aggregate the two links.

Site A                                                                                                  Site B

3750X -A1 --------------------------------------(          )--------------------------------------- 3750X -B1

                                                      (  L-2-L )

3750X -A2 --------------------------------------(          )--------------------------------------- 3750X -B2

below the configuration that I have put the two stacks.

site A

interface Port-channel5

description Etherchannel group entre le stack 3750X-A et Switch Lan_2_Lan

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11,12,999

switchport mode trunk

switchport nonegotiate

speed 100

interface GigabitEthernet1/0/15

description la liaison LAN_2_LAN

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11,12,999

switchport mode trunk

switchport nonegotiate

speed 100

duplex full

channel-group 5 mode active

interface GigabitEthernet2/0/15

description la liaison LAN_2_LAN

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11,12,999

switchport mode trunk

switchport nonegotiate

speed 100

duplex full

channel-group 5 mode passive

Site B

interface Port-channel5

description Etherchannel group entre le stack 3750X-A et Switch Lan_2_Lan

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11,12,999

switchport mode trunk

switchport nonegotiate

speed 100

interface GigabitEthernet1/0/15

description la liaison LAN_2_LAN

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11,12,999

switchport mode trunk

switchport nonegotiate

speed 100

duplex full

channel-group 5 mode active

interface GigabitEthernet2/0/15

description la liaison LAN_2_LAN

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11,12,999

switchport mode trunk

switchport nonegotiate

speed 100

duplex full

channel-group 5 mode active

but the problem is only one link is Bundeled in channel group, see below


Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

5      Po5(SU)         LACP      Gi1/0/15(I) Gi2/0/15(P)

how can i resolv this problem?

Best regards


9 Replies 9

Fraydoon Razazi
Beginner
Beginner

On site A you have:

interface GigabitEthernet2/0/15

switchport nonegotiate

channel-group 5 mode passive

change the channel-group 5 mode active or remove the switchport nonegotiate

Hi,

I changed the config, but the problem persist.

Best regards

InayathUlla Sharieff
Cisco Employee
Cisco Employee

Hi ,

I just tested the similar configuration on my devices and it worked fine.

Please find below my configuration:

Sw1---F0/1 & f0/2---connected to Sw F0/1& f0/2

SW1

interface FastEthernet0/1

channel-group 5 mode active

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

channel-group 5 mode active

switchport trunk encapsulation dot1q

switchport mode trunk

interface Port-channel 5

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

SW2:

======

interface FastEthernet0/1

channel-group 5 mode active

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

!

interface FastEthernet0/2

channel-group 5 mode active

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

!

interface Port-channel 5

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

Outputs of show etherchannel summary:

==============================

Switch1 #show etherchannel summary

Flags:  D - down        P - in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+----------------------------------------------

5      Po5(SU)           LACP   Fa0/1(P) Fa0/2(P)

2)

Switch2#show etherchannel summary

Flags:  D - down        P - in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+----------------------------------------------

5      Po5(SU)           LACP   Fa0/1(P) Fa0/2(P)

HTH

Regards

Inayath

*Plz rate if this is helpfull.

Hi,

If still not working then do the following on both the devices:

1- Default the interfaces. ([config]# default int GigabitEthernet1/0/15 & 2/0/15)

2- shut the interface

3- configure the ports with your port configuration ( Make sure you have Channel-group Active -Active at both the side).

4-configure the port-channel on both the devices.

5- Re-enable the port @ both the ends.

This should work.

HTH

REgards

Inayath

Fraydoon Razazi
Beginner
Beginner

Actually it is not a good practice to use nonegotiate with LACP, (active active on both side) I would remove all the nonegotiate from all the interfaces including portchannel.

Thanks,

Fraydoon

Have u check Cisco Recomended Setting.  Please see this

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00806cb982.shtml

** Rate all Helpful Posts **

Jawad

a.aitkaddour
Beginner
Beginner

Hi All,

thank you for your answers.

I already applied the same comments that you have communicated to me and I followed the same documents that you mentioned.

and the problem persist.

to remind you, I used active mode for all interface on both sites. and I have two links L_2_L with optical fbre

I noticed that with the current setup I have the following result:

Site A                                                                                                  Site B

3750X -A1 --------------------------------------(          )--------------------------------------- 3750X -B1

                                                                     (  L-2-L )

3750X -A2 --------------------------------------(          )--------------------------------------- 3750X -B2

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

5      Po5(SU)         LACP      Gi1/0/15(I) Gi2/0/15(P)

but when I permute the two fiber links I get the following result:

Site A                                                                                                  Site B

3750X -A1 --------\              /------------(            )--------------------------------------- 3750X -B1

                               \-------- / ------\        (  L-2-L )

3750X -A2 -----------------/           \------(            )--------------------------------------- 3750X -B2

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

5      Po5(SU)         LACP      Gi1/0/15(P) Gi2/0/15(I)

as you see the status of interface changes when I change the location of links, it is possible that the problem was related a links L_2_L?

Best regards

Hi,

Yes there could be possiblity.

Kindly try changing the cable and sfp ports and test the same.

Regards

Inayath

Jayden Le
Beginner
Beginner

Hi,

I notice you have the Port channel on both site as active, is there a reason why you do this? Reason why i ask is because usually port channel mode should be either

     1. On - On

     2. Active-Passive

     3. Passive-Active

I would suggest you recreating the port channel and hard code both end as ON instead of using negotiation. I have a very similar setup and it works for me.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers