cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1989
Views
0
Helpful
5
Replies

GNS3 – Windows 10 (Host Cannot Communicate with IOS Router)

Ben Lavender
Beginner
Beginner

Here is one that’s been bugging me for ages, I’ve got a 2691 IOS router running in the latest version of GNS3 (1.4.6 as of today) and the latest version of W10 Pro. The router is bound to a cloud which is then connected to an interface on the host with full access to the LAN the host is on. Here is my problem, so I can ping all devices including the GW and receiving a response back from the IOS router except the host W10 machine that is running dynamips, and as well the host cannot ping the IOS router.



So here is what I’ve done:



Disable Windows Firewall.



Disabled A/V.



Posted on GNS3 Jungle with no reply for weeks (obviously something to do with W10 then).



Used a loopback adapter instead but no change (can’t even ping anything on the LAN then even with the loopback configured with the LAN IP specifics).



Re-installed GNS3.



Disabled TCP/UDP checksum offloading.



Ran a PCAP on the device, I’ve noticed that if I ping the IOS device then no reply is received and only requests are sent and if I then try ping from the IOS device I can see both request/reply but no notice on the IOS router. So the issue is it’s being dropped once sending from the host.

5 REPLIES 5

Carlos Villagran
Cisco Employee
Cisco Employee

Hi!

Are you using your wireless NIC at the same time? 

Can you post your   route print ouput from windows command line?

Best regards!

JC

Hi,

No I just have one realtek gigabit Ethernet card, here is the config from one simple router:

Host IP addr is 192.168.1.3/24


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname LAB-VRTR-01
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.airnet.org.uk
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username dude privilege 15 secret 5 $1$WDXM$ZZ828NdfK.ZwBdrr/FpI50
!
!
ip tcp synwait-time 5
ip ssh version 2
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.4 255.255.255.0
 duplex auto
 speed 100
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 login local
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 logging synchronous
 login local
 transport input ssh
!
!
end

Anyone think they may know the answer?

sirmcintyre
Beginner
Beginner

Are you running GNS3 from VMWARE with ubuntu?  I was able to do it using VMWARE with ubuntu and enabling NAT inside VMWARE.  Also I added a route add command inside of windows command prompt to add the network I was trying to reach.

Wasn't an IP routing issue, see here: https://www.gns3.com/qa/gns3-1-4-5-asa-cannot-ping-host

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: