cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
2095
Views
0
Helpful
2
Replies
thekid1970
Beginner

Help possible configuration issue on 6506 port-channel

Hello,

I've encountered some issues with a Cisco Cat 6506-E IOS connecting to a Cisco 6120 Fabric Interconnect. There is two portchannels consisting of 2 10GE ports in each of the PO connecting between each other.

The problem I'm having is that the interfaces one at a time are flapping through any given period. It goes down and within milliseconds it comes back up. Below is my config from the Cisco 6506 and the both 6120's.

From the Cisco 6506, the port channel and interface configurations are as below:

interface Port-channel113

description [-[ Port Channel to MgmtAMP 6120 ]-]

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,101-112,216,221,240,315,406,407,411,416,417

switchport trunk allowed vlan add 440-447

switchport mode trunk

mtu 9216

lacp fast-switchover

spanning-tree portfast edge trunk

!

interface Port-channel114

description [-[ Port Channel to MgmtAMP 6120 ]-]

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,101-112,216,221,240,315,406,407,411,416,417

switchport trunk allowed vlan add 440-447

switchport mode trunk

mtu 9216

lacp fast-switchover

spanning-tree portfast edge trunk

interface TenGigabitEthernet3/3

description [-[ Connection to u6120-d7-a port 1/18 ]-]

switchport

switchport trunk allowed vlan 1,101-112,216,221,240,315,406,407,411,416,417

switchport trunk allowed vlan add 440-447

switchport mode trunk

mtu 9216

logging event link-status

channel-protocol lacp

channel-group 113 mode active

lacp port-priority 10

lacp rate fast

!

interface TenGigabitEthernet3/4

description [-[ Connection to u6120-d7-b port 1/18 ]-]

switchport

switchport trunk allowed vlan 1,101-112,216,221,240,315,406,407,411,416,417

switchport trunk allowed vlan add 440-447

switchport mode trunk

mtu 9216

logging event link-status

channel-protocol lacp

channel-group 114 mode active

lacp port-priority 10

lacp rate fast

interface TenGigabitEthernet4/1

description [-[  Connection to u6120-d7-a port 1/17  ]-]

switchport

switchport trunk allowed vlan 1,101-112,216,221,240,315,406,407,411,416,417

switchport trunk allowed vlan add 440-447

switchport mode trunk

mtu 9216

logging event link-status

channel-protocol lacp

channel-group 114 mode active

lacp port-priority 10

lacp rate fast

!

interface TenGigabitEthernet4/2

description [-[  Connection to u6120-d7-b port 1/17  ]-]

switchport

switchport trunk allowed vlan 1,101-112,216,221,240,315,406,407,411,416,417

switchport trunk allowed vlan add 440-447

switchport mode trunk

mtu 9216

logging event link-status

channel-protocol lacp

channel-group 113 mode active

lacp port-priority 10

lacp rate fast

From the Cisco 6120-A, the port channel and interfaces configurations are as below:

interface port-channel113

  switchport mode trunk

  switchport trunk allowed vlan 1,101-112,216,240,315-316,321,328

  switchport trunk allowed vlan add 340-341,406-407,411,416-417,440-447

  pinning border

  speed 10000

interface Ethernet1/17
  switchport mode trunk
  switchport trunk allowed vlan 1,101-106,110-112
  pinning border
  channel-group 113 mode active
  no shutdown

interface Ethernet1/18
  switchport mode trunk
  switchport trunk allowed vlan 1,101-106,110-112
  pinning border
  channel-group 113 mode active
  no shutdown

From the Cisco 6120-B, the port channel and interfaces configurations are as below:

interface port-channel114

  switchport mode trunk

  switchport trunk allowed vlan 1,101-112,216,240,315-316,321,328

  switchport trunk allowed vlan add 340-341,406-407,411,416-417,440-447

  pinning border

  speed 10000

interface Ethernet1/17
  switchport mode trunk
  switchport trunk allowed vlan 1,101-106,110-112
  pinning border
  channel-group 114 mode active
  no shutdown

interface Ethernet1/18
  switchport mode trunk
  switchport trunk allowed vlan 1,101-106,110-112
  pinning border
  channel-group 114 mode active
  no shutdown

On the 6506 side, when I issue the "debug etherchannel", I see these errors popping out:

Jun 20 14:17:53.881: %LINEPROTO-SP-5-UPDOWN: Line protocol on Interface TenGigabitEthernet4/1, changed state to up

Jun 20 14:17:53.921: %LINEPROTO-SP-5-UPDOWN: Line protocol on Interface TenGigabitEthernet3/4, changed state to up

Jun 20 15:21:32.025: FEC: pagp_switch_init_and_copy_fecblock: port Te3/3

Jun 20 15:21:32.025: FEC: pagp_switch_init_and_copy_fecblock: port Te4/2

If anybody can help would appreciate it.

Thanks,

John Roberts

2 REPLIES 2
andrew.prince
Advocate

Chaitra Shree
Cisco Employee

Hi John,

Are there any logs like "%EC-SP-5-CANNOT_BUNDLE_LACP" under show log output ?

Have you observed any input or output drops on the port-channel or its members ?

Could you provide "show log" and "show etherchannel summary" output from the switch ?