cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
15168
Views
30
Helpful
24
Replies

Help with VLAN on packet tracer

card51short
Level 1
Level 1

Guys I have an assignment in one of my routing/switching classes and I just cant' figure it out. I've literally redone this 4 times and I can't figure it out.  I'm following all the instructions I can find to a T.  What am I doing wrong ?

 

I can ping PC2 and PC3 from the router and from each other but I can't ping PC1.  I have no idea why.  Is the default gateway for the switches wrong?  I don't get it.

 

I have attached a file with the assignment.   Please someone give me an idea of why I can't ping PC1.  (in this version, I haven't done the serial links yet - I know how to get that working - what I cant' figure out is pinging PC1!)

 

I'm sure you'll want some information from my routers and switches - just let me know what exactly you need!  Thanks

 

Thanks!!!

2 Accepted Solutions

Accepted Solutions

The issue you are experiencing is related to the native VLAN.

 

On interface FastEthernet0/24, add the following command;

#switchport trunk native vlan 70

 

 

The reason it is not working is because the switch's trunk port on FasEthernet0/24 is sending the PC1 traffic with a dot1q tag. The router receives the frame, but drops it because it expect VLAN 70 to be native (untagged), because you have configured the router's VLAN70 interface to be the native vlan.

 

Just tested this is packet tracer, can reproduced the issue and adding the native vlan to the trunk worked.

 

Hope that helps!

View solution in original post

On R1, you need the advertise the connected networks through EIGRP and you need to do the same on R3. Once the networks are advertised, each router will know how to get to each network.

To advertise the PC1 network, you can configure R1 in EIGRP configuration mode with the following command. #network 172.16.8.1 0.0.0.255

 

On R3, you can advertise the server network in EIGRP configuration mode with the following command. #network 172.16.9.129 0.0.0.0.63

View solution in original post

24 Replies 24

card51short
Level 1
Level 1

Here are my running configs :

 

R1:

 

Current configuration : 1041 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.10

description Sales

encapsulation dot1Q 10

ip address 172.16.9.1 255.255.255.128

!

interface FastEthernet0/0.20

description Support

encapsulation dot1Q 20

ip address 172.16.0.1 255.255.248.0

!

interface FastEthernet0/0.70

description Management

encapsulation dot1Q 70 native

ip address 172.16.8.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

no ip address

clock rate 2000000

shutdown

!

interface Serial0/0/1

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

ip flow-export version 9

!

!

!

no cdp run

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

SW1 :

Current configuration : 2336 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

!

spanning-tree mode pvst

!

interface FastEthernet0/1

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 70

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 70

switchport mode access

!

interface FastEthernet0/4

switchport access vlan 70

switchport mode access

!

interface FastEthernet0/5

switchport access vlan 70

switchport mode access

switchport port-security mac-address sticky

switchport port-security violation protect

!

interface FastEthernet0/6

switchport access vlan 70

switchport mode access

!

interface FastEthernet0/7

switchport access vlan 70

switchport mode access

!

interface FastEthernet0/8

switchport access vlan 70

switchport mode access

!

interface FastEthernet0/9

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/10

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/11

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/12

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/13

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/14

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/15

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/16

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/17

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/18

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/19

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/20

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/21

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/22

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/23

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/24

switchport mode trunk

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

ip default-gateway 172.16.8.1

!

!

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

login

!

!

!

end

 

 

SW2:

Current configuration : 2273 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

!

spanning-tree mode pvst

!

interface FastEthernet0/1

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/4

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/5

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/6

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/7

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/8

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/9

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/10

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/11

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/12

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/13

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/14

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/15

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/16

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/17

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/18

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/19

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/20

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/21

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/22

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/23

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/24

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

ip default-gateway 172.16.8.1

!

!

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

login

!

!

!

end

 

 

The issue you are experiencing is related to the native VLAN.

 

On interface FastEthernet0/24, add the following command;

#switchport trunk native vlan 70

 

 

The reason it is not working is because the switch's trunk port on FasEthernet0/24 is sending the PC1 traffic with a dot1q tag. The router receives the frame, but drops it because it expect VLAN 70 to be native (untagged), because you have configured the router's VLAN70 interface to be the native vlan.

 

Just tested this is packet tracer, can reproduced the issue and adding the native vlan to the trunk worked.

 

Hope that helps!

Thank you!  I knew I had to set a native VLAN on the switch but I couldn't find out how!

Hey so I set up the EIGRP on all the routers through the serial. They can all communicate with each other now.  They can all ping each other.  But PC4 (the server) still cannot ping PC1.  It says desitination host unreachable.  Why do you think that is so?

Without seeing the rest of the config I can't be sure as this could be due to a couple of reasons.

 

1. Make sure all interfaces are in up/up state.

2. Make sure PC4 and PC1 have the correct default gateway.

3. Make sure each router has a route with EIGRP to the PC4 and PC1 subnet in its routing table, verify using "show ip route".

 

Hope that helps!

 

 

 

 

 

1 and 2 are correct (PC4 should has the 172.16.9.129 default gateway)

 

as for 3 - i'm not sure exactly what it should show but the ISP router doesn't have the EIGRP in its routing tables.

 

Do you have any idea what I should do ?

 

ISP>enable

ISP#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

 

Gateway of last resort is not set

 

192.168.1.0/30 is subnetted, 2 subnets

C 192.168.1.0 is directly connected, Serial0/0/0

C 192.168.1.4 is directly connected, Serial0/0/1

 

ISP#show ip ei

ISP#show ip eigrp interface

IP-EIGRP interfaces for process 21

 

Xmit Queue Mean Pacing Time Multicast Pending

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Se0/0/1 1 0/0 1236 0/10 0 0

Se0/0/0 1 0/0 1236 0/10 0 0

ISP#show ip eigrp ne

ISP#show ip eigrp neighbors

IP-EIGRP neighbors for process 21

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 192.168.1.2 Se0/0/0 10 00:15:43 40 1000 0 3

1 192.168.1.6 Se0/0/1 14 00:15:43 40 1000 0 3

the ISP router can ping R1 and R3 but not PC4.

On R1, you need the advertise the connected networks through EIGRP and you need to do the same on R3. Once the networks are advertised, each router will know how to get to each network.

To advertise the PC1 network, you can configure R1 in EIGRP configuration mode with the following command. #network 172.16.8.1 0.0.0.255

 

On R3, you can advertise the server network in EIGRP configuration mode with the following command. #network 172.16.9.129 0.0.0.0.63

but R1 and R3 can already communicate.  Do I still need to do this? I already advertised the networks - I didn't use the wildcard mask though.

OK this worked!  But can you explain why?  Before, I just advertised the different router's serial interface network (192.168.1.0)

The reason it was not working is based around how Routers operate at layer 3. Once a packet is received, the router looks at the destination IP address field inside the packet. Once it has the destination IP address, it needs to check its routing table in order to determine where to send the packet. In your case, the routers do not know how to get to that network because a route to that network does not existing in their tables. When you advertise the network in EIGRP, you tell all of your EIGRP neighbors about that network and they install it in their routing table, so that next time they receive a packet, they know how to get there.

 

If you need a more detailed explanation, let me know.

that makes some sense. Why didn't I need to do it on ISP?

You don't need it on the ISP router because it is already EIGRP neighbors
with R1 and R3. R1 advertises the network and then tell's ISP router about
it, so all their networks and routes are all dynamically synced via EIGRP.

This is the same case for R3. It advertises the network and then tells it's
neighbors.

thanks so much - one last thing.  For the PPP with authentication should I use CHAP? It doesn't say which one to use and I heard CHAP was best for the default.  So I should just do encapsulation PPP then ppp authentication chap on the S0/0/0 line on R1 and then again on the S0/0/0 line for ISP?  That's it?

Review Cisco Networking products for a $25 gift card