10-27-2019 09:48 AM
Hello
Please
I have a local network with a router and three switches
I want to connect the three switches in the three router ports (each router port to a switch), in addition to that; do etherchannel between the switch and configure the DHCP in the router.
all this to see a larger network of flow and faster in the network lacal
thank you for sending me the proposals.
10-27-2019 11:30 AM
Hello,
how many Vlans do you have ? If you have more than three, and you cannot dedicate one switch to one Vlan exclusively, you have to use subinterfaces on the router.
Here is a basic, generic setup:
Router
ip dhcp-excluded address 192.168.10.1
ip dhcp-excluded address 192.168.20.1
ip dhcp-excluded address 192.168.30.1
!
ip dhcp pool VLAN10
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8 8.8.4.4
!
ip dhcp pool VLAN20
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 8.8.8.8 8.8.4.4
!
ip dhcp pool VLAN30
network 192.168.30.0 255.255.255.0
default-router 192.168.30.1
dns-server 8.8.8.8 8.8.4.4
!
interface GigabitEthernet0/0
description Management IP
ip address 10.10.10.1 255.255.255.0
!
interface GigabitEthernet0/0.10
encapsulation dot1q 10
ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet0/0.20
encapsulation dot1q 20
ip address 192.168.20.1 255.255.255.0
!
interface GigabitEthernet0/0.30
encapsulation dot1q 30
ip address 192.168.30.1 255.255.255.0
Switch 1
interface GigabitEthernet0/0
description Uplink to Router
switchport mode trunk
Access ports on all switches:
interface FastEthernet0/1
switchport mode access
switchport access vlan 10 (or whatever Vlan you want to assign to this port)
spanning-tree portfast
Port channels on all switches (choose two or more ports)
interface port-channel 5
!
interface range GigabitEthernet0/1 - 2
channel-group 1mode active
Management IP on Vlan 1 interfaces
interface Vlan1
ip address 10.10.10.2 255.255.255.0
!
ip default-gateway 10.10.10.1
10-27-2019 04:43 PM
Thank you
I did not make the vlan (leave vlan by default), because
I think I do not need the logical interface on router (subinterface) because there is physical router interface.
so I connect each of the switches to a physical router interface,
and to see a high debit in my local network, i want to set etherchannel between the switch.
I want to understand does it work? if yes
how to configure the DHCP of all my subnet on router.
and how to configure etherchannel between the switches
all of which the objective of having good connectivity between the PCs of my local network
see attached file
thank you
10-28-2019 12:25 AM
Hello,
if you just use Vlan1 (the default) you cannot connect each switch to a physical layer 3 (routed) port, as these ports require an IP address, and hence you cannot use the same subnet for the clienst on all three switches.
Which router model do you have ?
10-28-2019 02:27 PM
Thank you
I did not completely understand .....
if I do the 3 subnets by connecting each switch to a router port ... how to connect the three switches between them?
using etherchannel
thank you for sending me more details on that ..
and send me the right solution for my local network (with three switch and a router)
10-28-2019 08:31 AM
10-28-2019 02:18 PM
the three switch are bind to different router ports, i want to see is it possible to do etherchannel between the switch?
and how to configure DHCP in the router for the three subnets.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide