cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
698
Views
20
Helpful
13
Replies
mrmarie
Beginner

How to connect to links between Coreswitch and Nexus switch

Hello

I need to connect two links between the Coreswitch 6509 (2 Trunk port) and Nexus 3548 (2 Trunk port), Also there is 3 edge switches Cisco 2960 uplink to Nexus.

So what is the recommendation to avoid any looping, should I create port-channel, Spanning-tree ?

 

Appreciate your help 

 

Thanks

13 REPLIES 13
Giuseppe Larosa
Hall of Fame Master

Hello @mrmarie ,

yes a port-channel is recommended in your case.

The use of LACP is also a very good feature on C6509 side means channel-group X mode active on the member links.

 

on NX-OS should be similar

 

Hope to help

Giuseppe

 

Hello @Giuseppe Larosa 

 

Thank you for your reply

 

and any spanning tree configuration should I do?

 

Thanks

Hello @mrmarie ,

>> and any spanning tree configuration should I do?

No, because for STP a port-channel is a single logical link so no special configuration is needed. This is one of the advantages of bundles no member link is blocked by STP and it comes automatically with no special config.

 

if you have only one Nexus you will use a normal port channel on Nexus side also as noted by BB.

 

Hope to help

Giuseppe

 

Hi @Giuseppe Larosa 

 

Should I use command: Spanning Tree Root guard in interfaces ?

 

Thanks

Hello @mrmarie ,

if all devices are under your administration you shoud be able to increase bridge priority on devices that should never become root bridge for any STP instance ( if you are using PVST or Rapid PVST).

You might want to protect the root bridge choice on the core side you can use the spanning-tree root guard command.

 

Be very careful with this kind of commands giving them on the wrong devices can create a lot of issues.

Root guard in direction going away from root bridge is ok

Root guard  in direction going to the root bridge is not ok at all ! You can use loop guard in direction to the root bridge on edge device side.

 

Hope to help

Giuseppe

balaji.bandi
VIP Master

consider using Port-channel with LACP, and take where advantage use vPC on nexus.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Hello @balaji.bandi 

 

Thank you for your reply 

 

so should I configure channel-group from Core side and vPC from Nexus side?

 

Thanks

yes you can do nexus side vPC and Core side normal Port-channel should work. (this high level technically should work)

 

if your network have many interconnected back to nexus we need to know fuill network diagram.

 

we suggested only based on the information what provided here.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Hi @balaji.bandi 

 

Here is the diagram 

 

sw2.jpg

 

Thanks

Is this your final diagram have only 1 device at each level, then standard port-channel is good enough with LACP ( you do not need vPC)

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

MHM Cisco World
Collaborator

Cisco 6K Core SW 
Cisco NSK 3K Aggregate SW
Cisco Catalyst 2960 Access SW ?

are NSK is vPC or not ?

why not L2 between Core and Aggregate SW?

Georg Pauwen
VIP Expert

Hello,

 

on a side note, you might want to make sure that none of the 2960 switches accidentally become the root for any of your Vlans. You could set the 6509 as root primary and the Nexus as root secondary:

 

6509

spanning-tree vlan x root primary

 

Nexus

spanning-tree valn x root secondaty

paul driver
VIP Mentor

Hello
There are a couple of things you don’t mention

- is the Nexus are running vpc or it its a standalone switch(s)?
- What spanning-tree mode you are running

The following example would allow you connect two physical interfaces into a L2 EtherChannel from the cisco core into the nexus which is either running vpc or not, Also make sure the cisco core switch is indeed to STP root for the lan estate.

6509
default interface range x/x

interface range x/x
shut
channel-group 1 mode active


interface port-channel 1
description Nexus
switchport
switchport mode trunk
no shut


spanning-tree vlan 1-4094 priority 0
or
spanning-tree mst x priority 0


Nexus standalone switch 
feature lacp
default interface range x/x

interface range x/x
channel-group 1 mode active

interface port-channel 1
description 6509
switchport mode trunk
no shut

default interface range x/x
interface range x/x
channel-group 2 mode active

interface port-channel 2
description access-switch
switchport mode trunk
no shut

 

 

Nexus VPC

switchs 1 & 2

feature vpc
feature lacp


default interface Ethernetx/x
interface Ethernetx/x
channel-group 1 mode active


interface port-channel 1
description 6509
switchport mode trunk
vpc 1

no shut

default interface x/x
interface x/x
channel-group 2 mode active


interface port-channel 2
description access-switch
switchport mode trunk
no shut
vpc 2



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future