08-20-2019 09:16 AM
We have a Shoretel VOIP system and I want to ensure I have QOS properly in place on my 3850 and 2960 stacks. We want dscp 46 to have higher priority from what I understand. We basically did "auto qos voip trust" on all user ports, and "auto qos trust" on all inter-switch links. So our switchports look like this:
ON 3850 Switch Port:
interface GigabitEthernet1/0/2
description Phone and Data Port
switchport access vlan 15
switchport mode access
switchport voice vlan 112
storm-control broadcast level 20.00
spanning-tree portfast
service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
ON 2960 Port:
interface GigabitEthernet1/0/1
switchport access vlan 52
switchport mode access
switchport voice vlan 53
srr-queue bandwidth share 1 30 35 5
mls qos trust dscp
auto qos trust
spanning-tree portfast
spanning-tree bpduguard enable
So when I do a wireshark capture I do see dscp "EF" on the IP's for the phones but that just means to me that it is getting the EF not that the switch is prioritize the this traffic.
I thought by doing command on switch "sh policy-map interface G1/0/1"
I would maybe see some packets or bytes in the High priority level 1 section for the dscp 46
Service-policy input: AutoQos-4.0-Trust-Dscp-Input-Policy
Class-map: class-default (match-any)
7674878169 packets
Match: any
QoS Set
dscp dscp table AutoQos-4.0-Trust-Dscp-Table
Service-policy output: AutoQos-4.0-Output-Policy
queue stats for all priority classes:
Queueing
priority level 1
(total drops) 0
(bytes output) 5843480830
Class-map: AutoQos-4.0-Output-Priority-Queue (match-any)
0 packets
Match: dscp cs4 (32) cs5 (40) ef (46)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 5
0 packets, 0 bytes
5 minute rate 0 bps
Priority: 30% (30000 kbps), burst bytes 750000,
Priority Level: 1
Class-map: AutoQos-4.0-Output-Control-Mgmt-Queue (match-any)
0 packets
Match: dscp cs2 (16) cs3 (24) cs6 (48) cs7 (56)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 3
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
queue-limit dscp 16 percent 80
queue-limit dscp 24 percent 90
queue-limit dscp 48 percent 100
queue-limit dscp 56 percent 100
(total drops) 0
(bytes output) 9133976
bandwidth remaining 10%
queue-buffers ratio 10
Class-map: AutoQos-4.0-Output-Multimedia-Conf-Queue (match-any)
0 packets
Match: dscp af41 (34) af42 (36) af43 (38)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 4
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
(total drops) 0
(bytes output) 408
bandwidth remaining 10%
queue-buffers ratio 10
Class-map: AutoQos-4.0-Output-Trans-Data-Queue (match-any)
0 packets
Match: dscp af21 (18) af22 (20) af23 (22)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 2
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
(total drops) 0
(bytes output) 1316279639
bandwidth remaining 10%
queue-buffers ratio 10
Class-map: AutoQos-4.0-Output-Bulk-Data-Queue (match-any)
0 packets
Match: dscp af11 (10) af12 (12) af13 (14)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 1
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
(total drops) 191127
(bytes output) 2082174760
bandwidth remaining 4%
queue-buffers ratio 10
Class-map: AutoQos-4.0-Output-Scavenger-Queue (match-any)
0 packets
Match: dscp cs1 (8)
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
(total drops) 0
(bytes output) 15859425
bandwidth remaining 1%
queue-buffers ratio 10
Class-map: AutoQos-4.0-Output-Multimedia-Strm-Queue (match-any)
0 packets
Match: dscp af31 (26) af32 (28) af33 (30)
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
(total drops) 0
(bytes output) 44977301
bandwidth remaining 10%
queue-buffers ratio 10
Class-map: class-default (match-any)
0 packets
Match: any
Queueing
(total drops) 259597288
(bytes output) 9003377426003
bandwidth remaining 25%
queue-buffers ratio 25
Any help would be appreciated. Not sure if we need to do a specific policy map for Shoretel Phones or not. Also wondering if it is possible to do QOS on specific subnet range
08-23-2019 03:02 AM - edited 08-23-2019 07:46 AM
Hello David,
to see if there is a priority queue for EF marked traffic we need to look at the policy-map applied outbound.
>> service-policy output AutoQos-4.0-Output-Policy
However, the priority queue is empty ( to be verified see Edit2 section)
Class-map: AutoQos-4.0-Output-Priority-Queue (match-any)
0 packets
Match: dscp cs4 (32) cs5 (40) ef (46)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 5
0 packets, 0 bytes
5 minute rate 0 bps
Priority: 30% (30000 kbps), burst bytes 750000,
Generally speaking AutoQoS is thought to support Cisco IP phones using CDP or LLDP MED or third party IP phones using again CDP or LLDP MED.
Verify what your shoretel phones are doing to signal their existance to the switch ( LLDP MED, CDP or nothing ?)
If the phones are able to run LLDP MED and they are not running it you should enable it.
You may need to enable it also on the switches.
Start with this check on what the shoretel phones are doing and what they can do.
Depending on the results the autoQoS can be a good tool for you or you need to use a manual QoS configuration.
Note:
How have you seen the EF marking on packet capture ?
Have you done a local SPAN session with source port an access port connected to a Shoretel IP phone ?
Edit:
>> Also wondering if it is possible to do QOS on specific subnet range
With manual QoS configuration this is possible the class-map can invoke an extended ACL to define what traffic is on the class.
Edit2:
looking at the whole output we can see that for each class the packet counter is zero.
So there is an issue with packet counters.
There is a field bytes output not zero for each outbound class including the priority queue if my understanding is correct.
If so the switch may be doing the correct QoS tasks and the issue is limited to the packet counters.
See this section
>>queue stats for all priority classes:
Queueing
priority level 1
(total drops) 0
>>(bytes output) 5843480830
Hope to help
Giuseppe
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide