02-26-2017 02:49 AM - edited 03-08-2019 09:30 AM
Sir,
I have one internet line .In my network 8 VLANS . I have to provide internet for 5 VLANS .three vlans no need internet .8vlans are indifferent network .The core switch i am using cisco3850 and edge i am using cisco 2960 .Using this scenario can I configure NAT for my requirement .If it is possible please explain how to configure .
02-26-2017 04:51 AM
Hi
Not really sure if you can run a NAT on a Cisco 3850 but if it possible you could try executing the following commands to create a NAT (in this case PAT is a solution), the otherwise you need a router:
Core Switch
Step 1) Create the nat inside traffic, (Example: using 5 different vlans)
interface vlan 10
ip nat inside
interface vlan 20
ip nat inside
interface vlan 30
ip nat inside
interface vlan 40
ip nat inside
interface vlan 50
ip nat inside
Step 2) Create the nat outside
Examples, if you are using layer 3 interface or SVI (like above)
interface g1/1/1
description INTERNET-ISP
no switchport
ip add 140.a.a.2 255.255.255.252 <--- Example Public IP.
ip nat outside
no shutdown
or
interface vlan 100
ip nat inside
* It depends how you have configured your p2p with your ISP. This selection will be configured on the step 4.
Step 3) Create a list of the internal subnet to be translated:
ip access-list standard PRIVATE-NETS
permit 192.168.10.0 0.0.0.255
permit 192.168.20.0 0.0.0.255
permit 192.168.30.0 0.0.0.255
permit 192.168.40.0 0.0.0.255
permit 192.168.50.0 0.0.0.255
Step 4) Create a PAT
Sintaxis: ip nat inside source list <your ACL> interface <interface configured with public IP facing to your ISP> overload
ip nat inside source list PRIVATE-NETS interface g1/1/1 overload
Step 4) Create a default route pointing to the ISP next hop
conf t
ip routing
ip route 0.0.0.0 0.0.0.0 140.a.a.1 <--- Your Public IP
Step 5) Save the config
Write
In order to see if it is working you can execute the show ip nat translations command line to see the traffic being translated from the internal networks.
Hope it is useful
:-)
02-26-2017 07:40 AM
Sir,I have one internet line .In my network 8 VLANS . I have to provide internet for 5 VLANS .three vlans no need internet .8vlans are indifferent network .The core switch i am using cisco3850 and edge i am using cisco 2960 .Using this scenario can I configure NAT for my requirement .If it is possible please explain how to configure .
Hi,
Unfortunately the platform does not support NAT. So in nutshell NAT is not supported on the 3850.
You may required router or ASA to do the same.
Hope it Helps..
-GI
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide