cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1495
Views
0
Helpful
4
Replies
Highlighted
Beginner

How to use the HSRP address as the EIGRP source IP ?

Afternoon guys,

I have the following scenario.  I have a c4500 and a c6500 running HSRP:

C6500:

interface Vlan53
  ip address 10.4.35.36 255.255.255.248
  standby 53 ip 10.4.35.33
standby 53 priority 105
standby 53 preempt

router eigrp 10
  passive-interface default
no passive-interface Vlan53
network 10.0.0.0
neighbor 10.4.35.34 Vlan53        

Cisco 4500:

interface Vlan53
description 3rd Party Firewall - DCTPFW01- INSIDE
ip address 10.4.35.37 255.255.255.248
ip flow ingress
standby 53 ip 10.4.35.33

router eigrp 10
  passive-interface default
no passive-interface Vlan53
network 10.0.0.0
neighbor 10.4.35.34 Vlan53

There is also a ASA that is also communicating with these twi devices via EIGRP


Cisco 5540 ASA:

interface Port-channel44.53
vlan 53
nameif inside
security-level 100
ip address 10.4.35.34 255.255.255.248 standby 10.4.35.35

router eigrp 10
no auto-summary
neighbor 10.4.35.37 interface inside
neighbor 10.4.35.36 interface inside
neighbor 10.4.35.33 interface inside     << no nieghbourship is built via this IP
network 10.0.0.0 255.0.0.0
passive-interface default
no passive-interface inside

As you can see, I've had to put the 'real' ip addresses of both the c4500 and c6500 under the firewalls EIGRP process.  The switches use their 'real' ip addresses to talk to the firewall via EIGRP.

Is there a way so that the HSRP address is used instead?  I understand this might get complicated when implementing this on both switches as you only wsih one switch to be communicating at one time if using the HSRP address for EIGRP communication.

Thanks for any help.

Regards,

Jimmy

4 REPLIES 4
Advocate

Re: How to use the HSRP address as the EIGRP source IP ?

Have you tried statically configuring a /32 network statement of the IP you want to sue? just guessing.

Beginner

Re: How to use the HSRP address as the EIGRP source IP ?

Hi Andrew,

Do you mean the neighbour statement under 'router eigrp 10' ?

Advocate

Re: How to use the HSRP address as the EIGRP source IP ?

To be honest no - as I would have thought you would have tried that already?? My idea was to specifiy a /32 network statement so as an exmaple:-

router eigrp x

network 192.168.254.254 0.0.0.0 = specific IP address of the interface, not the HSRP address.

Beginner

Re: How to use the HSRP address as the EIGRP source IP ?

Ah right, okay, I'll try this in the morning and let you know!!

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards