cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
204
Views
0
Helpful
0
Replies
Highlighted
Beginner

HSRP Not Working

Sorry if this is a newbie question.

I have set up a lab in EVE-NG that has 3 vlans that have been configured using VTP. I connected 2 routers via router on a stick to my core switches so that I can have inter-vlan routing. The lab consists of 2 core switches connected via port-channel. 2 access switches are connected to each core switch, and 4 vpcs are connected to each access switch. 

 

My problem is HSRP. It is configured on both of my routers, and my routers can ping each other's subinterfaces. However, when I do a show standby br, both my routers think that they are the active, and standby says unknown. 

 

I have reviewed my configurations many times and have redid them, but the results were always the same.

 

Any ideas on what I'm doing wrong?

Thanks in advance for your help :)

 

 

 

Lab Screenshot: 

 

Capture60.PNG

 

Router1 Configurations: 

 

interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 2000
ip address 10.0.0.14 255.255.255.240
standby 10 ip 10.0.0.1
standby 10 priority 200
standby 10 preempt
!
interface FastEthernet0/0.2
encapsulation dot1Q 3000
ip address 192.168.0.14 255.255.255.240
standby 20 ip 192.168.0.1
standby 20 priority 200
standby 20 preempt
!
interface FastEthernet0/0.3
encapsulation dot1Q 4000
ip address 172.16.0.14 255.255.255.240
standby 30 ip 172.16.0.1
standby 30 priority 200
standby 30 preempt
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto

 

Router1 show standby: 

FastEthernet0/0.1 - Group 10
State is Active
2 state changes, last state change 00:36:14
Virtual IP address is 10.0.0.1
Active virtual MAC address is 0000.0c07.ac0a
Local virtual MAC address is 0000.0c07.ac0a (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.976 secs
Preemption enabled
Active router is local
Standby router is unknown
Priority 200 (configured 200)
Group name is "hsrp-Fa0/0.1-10" (default)
FastEthernet0/0.2 - Group 20
State is Active
2 state changes, last state change 00:36:14
Virtual IP address is 192.168.0.1
Active virtual MAC address is 0000.0c07.ac14
Local virtual MAC address is 0000.0c07.ac14 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.976 secs
Preemption enabled
Active router is local
Standby router is unknown
Priority 200 (configured 200)
Group name is "hsrp-Fa0/0.2-20" (default)
FastEthernet0/0.3 - Group 30
State is Active
2 state changes, last state change 00:36:16
Virtual IP address is 172.16.0.1
Active virtual MAC address is 0000.0c07.ac1e
Local virtual MAC address is 0000.0c07.ac1e (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.136 secs
Preemption enabled
Active router is local
Standby router is unknown
Priority 200 (configured 200)
Group name is "hsrp-Fa0/0.3-30" (default)

 

Router1 show standby br:

 

Interface Grp Pri P State Active Standby Virtual IP
Fa0/0.1 10 200 P Active local unknown 10.0.0.1
Fa0/0.2 20 200 P Active local unknown 192.168.0.1
Fa0/0.3 30 200 P Active local unknown 172.16.0.1

 

Router1 show ip int br: 

Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset up up
FastEthernet0/0.1 10.0.0.14 YES manual up up
FastEthernet0/0.2 192.168.0.14 YES manual up up
FastEthernet0/0.3 172.16.0.14 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
FastEthernet1/0 unassigned YES unset administratively down down

 

Router2 Configurations:

 

interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 2000
ip address 10.0.0.13 255.255.255.240
standby 10 ip 10.0.0.1
standby 10 priority 90
standby 10 preempt
!
interface FastEthernet0/0.2
encapsulation dot1Q 3000
ip address 192.168.0.13 255.255.255.240
standby 20 ip 192.168.0.1
standby 20 priority 90
standby 20 preempt
!
interface FastEthernet0/0.3
encapsulation dot1Q 4000
ip address 172.16.0.13 255.255.255.240
standby 30 ip 172.16.0.1
standby 30 priority 90
standby 30 preempt
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto

 

Router2 show standby:

FastEthernet0/0.1 - Group 10
State is Active
2 state changes, last state change 00:35:05
Virtual IP address is 10.0.0.1
Active virtual MAC address is 0000.0c07.ac0a
Local virtual MAC address is 0000.0c07.ac0a (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.756 secs
Preemption enabled
Active router is local
Standby router is unknown
Priority 90 (configured 90)
Group name is "hsrp-Fa0/0.1-10" (default)
FastEthernet0/0.2 - Group 20
State is Active
2 state changes, last state change 00:35:05
Virtual IP address is 192.168.0.1
Active virtual MAC address is 0000.0c07.ac14
Local virtual MAC address is 0000.0c07.ac14 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.756 secs
Preemption enabled
Active router is local
Standby router is unknown
Priority 90 (configured 90)
Group name is "hsrp-Fa0/0.2-20" (default)
FastEthernet0/0.3 - Group 30
State is Active
2 state changes, last state change 00:35:06
Virtual IP address is 172.16.0.1
Active virtual MAC address is 0000.0c07.ac1e
Local virtual MAC address is 0000.0c07.ac1e (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.368 secs
Preemption enabled
Active router is local
Standby router is unknown
Priority 90 (configured 90)
Group name is "hsrp-Fa0/0.3-30" (default)

 

Router2 show standby br: 

|
Interface Grp Pri P State Active Standby Virtual IP
Fa0/0.1 10 90 P Active local unknown 10.0.0.1
Fa0/0.2 20 90 P Active local unknown 192.168.0.1
Fa0/0.3 30 90 P Active local unknown 172.16.0.1

 

Router2 show ip int br: 

Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset up up
FastEthernet0/0.1 10.0.0.13 YES manual up up
FastEthernet0/0.2 192.168.0.13 YES manual up up
FastEthernet0/0.3 172.16.0.13 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
FastEthernet1/0 unassigned YES unset administratively down down

 

CoreSwitchA Configurations: 

 

interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
!
interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
channel-protocol lacp
channel-group 1 mode active
!
interface Ethernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
channel-protocol lacp
channel-group 1 mode active
!
interface Ethernet0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
!
interface Ethernet0/3
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
!
interface Ethernet1/0
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
!
interface Ethernet1/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
!
interface Ethernet1/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto

 

CoreSwitchB Configurations:

 

interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
!
interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
channel-protocol lacp
channel-group 1 mode active
!
interface Ethernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
channel-protocol lacp
channel-group 1 mode active
!
interface Ethernet0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
!
interface Ethernet0/3
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
!
interface Ethernet1/0
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
!
interface Ethernet1/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 99
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
!
interface Ethernet1/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2000,3000,4000
switchport mode trunk
duplex auto
!
interface Ethernet1/3
duplex auto

 

 

0 REPLIES 0
Content for Community-Ad