cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
715
Views
0
Helpful
3
Replies
epeng
Beginner

HSRP problem

Neep help on this strange issue. Two catalyst 6506 w/720 sup configured with hsrp on VLAN 23. However, "show standby vlan 23 all" shows two groups under hsrp 23. Where does group 1 coming from, and how to delete it? the Group 1 is doing nothing but generating the error message.

thanks for help.

----------------------

interface Vlan23
description ca/ccd standby
ip address x.x.x.252 255.255.254.0
no ip redirects
no ip unreachables
standby 23 ip x.x.x.254
standby 23 timers 3 9
standby 23 preempt
standby 23 authentication xxxxx
end


lan-r1#sh standby vlan 23 all
Vlan23 - Group 1
  State is Disabled (learnt)
  Virtual IP address is 192.168.53.254 (learnt) (wrong subnet for this interface)
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
  Preemption disabled
  Active router is 192.168.53.251, priority 110 (expires in 7.632 sec)
  Standby router is 192.168.53.252, priority 105 (expires in 8.736 sec)
  Priority 100 (default 100)
  Group name is "hsrp-Vl23-1" (default)
Vlan23 - Group 23
  State is Standby
    3 state changes, last state change 00:15:30
  Virtual IP address is x.x.x.254
  Active virtual MAC address is 0000.0c07.ac17
    Local virtual MAC address is 0000.0c07.ac17 (v1 default)
  Hello time 3 sec, hold time 9 sec
    Next hello sent in 2.256 secs
  Authentication text "tothemoo"
  Preemption enabled
  Active router is x.x.x.253, priority 150 (expires in 9.952 sec)
  Standby router is local
  Priority 100 (default 100)
  Group name is "hsrp-Vl23-23" (default)

3 REPLIES 3
rassoul.ghaznavi
Beginner

Hi,

Where is the other router config?

Is it the same?

You probably need to post the interface configurations as well.

Network Group

Hi,

another switch has the similar configuration except interface IP. The VLAN interface configurtion shows in my writing.

I use the following script using two different IP blocks. Notice that there are couple extra commands on one of the switches. Also notice that the /29 is just used for HSRP configuration while the other network is routed to the standby IP. Hopefully this helps.

IP block x.x.53.160/27 routed to x.x.58.0/29 using HSRP.

Distro01

vlan 90
name company
end

interface vlan 90
description company HSRP 1
ip address x.x.58.2 255.255.255.248
no ip redirects
standby 90 x.x.58.1
standby 90 timers 5 15
end

int fastethernet 6/6
description Company
switchport access vlan 90
switchport mode access
end

------------

Distro02

vlan 90
name company
end

interface vlan 90
description company HSRP 2
ip address x.x.58.3 255.255.255.248
no ip redirects
standby 90 timers 5 15
standby 90 priority 150
standby 90 preempt
end

int fastethernet 6/6
description Company
switchport access vlan 90
switchport mode access
end

On both distros:

ip route x.x.53.160 255.255.255.224 x.x.58.1
wr mem

Done.