09-09-2016 07:25 AM - edited 03-08-2019 07:22 AM
Hi Cisco Engineers,
I am facing with a big issue with routing redistribution between RIP to OSPF on a network. Network design as below
[[{"type":"media","fid":"1346381","view_mode":"preview","link_text":null,"attributes":{"alt":"OSPF to RIP Distribution issue","title":"OSPF to RIP Distribution issue","height":"505","width":"1203","class":"image-style-media-thumbnail media-element file-preview"}}]] Router Configuration as below:
! R1 !
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.10.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.4.2 255.255.255.0
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
redistribute rip metric 1 subnets
passive-interface FastEthernet0/1
network 1.1.1.0 0.0.0.255 area 0
network 10.10.1.0 0.0.0.255 area 0
!
router rip
version 2
redistribute ospf 1 metric 10
passive-interface FastEthernet0/0
network 10.0.0.0
no auto-summary
!
--------------------------------------------
! R2!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.10.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.2.1 255.255.255.0
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 10.10.1.0 0.0.0.255 area 0
network 10.10.2.0 0.0.0.255 area 0
!
-------------------------------
! R3 !
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 10.10.3.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.2.2 255.255.255.0
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
redistribute rip metric 10 subnets
passive-interface FastEthernet0/0
network 3.3.3.0 0.0.0.255 area 0
network 10.10.2.0 0.0.0.255 area 0
!
router rip
version 2
redistribute ospf 1 metric 1
passive-interface FastEthernet0/1
network 10.0.0.0
no auto-summary
!
------------------------------------------
! R4 !
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 10.10.3.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.4.1 255.255.255.0
duplex auto
speed auto
!
!
router rip
version 2
network 4.0.0.0
network 10.0.0.0
no auto-summary
!
---------------------------------
Problem :- I am not getting redundancy network. If redistribution is working from R1 to R4 and suddenly this link goes down and redistribution is not switch from router R3 to R4.
Please guide, Where is issue.
===================
Show ip route : output
R1#sho ip route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/11] via 10.10.1.2, 00:26:01, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/21] via 10.10.1.2, 00:26:01, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O E2 4.4.4.4 [110/10] via 10.10.1.2, 00:23:58, FastEthernet0/0
10.0.0.0/24 is subnetted, 4 subnets
C 10.10.1.0 is directly connected, FastEthernet0/0
O 10.10.2.0 [110/20] via 10.10.1.2, 00:26:03, FastEthernet0/0
O E2 10.10.3.0 [110/10] via 10.10.1.2, 00:24:43, FastEthernet0/0
O E2 10.10.4.0 [110/10] via 10.10.1.2, 00:24:00, FastEthernet0/0
R1#
=============================
R3#sho ip route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/21] via 10.10.2.1, 00:26:22, FastEthernet0/1
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/11] via 10.10.2.1, 00:26:22, FastEthernet0/1
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
4.0.0.0/32 is subnetted, 1 subnets
R 4.4.4.4 [120/1] via 10.10.3.2, 00:00:42, FastEthernet0/0
10.0.0.0/24 is subnetted, 4 subnets
O 10.10.1.0 [110/20] via 10.10.2.1, 00:26:23, FastEthernet0/1
C 10.10.2.0 is directly connected, FastEthernet0/1
C 10.10.3.0 is directly connected, FastEthernet0/0
R 10.10.4.0 [120/1] via 10.10.3.2, 00:00:44, FastEthernet0/0
R3#
R3#
Regards,
Deepak Kumar
---------------------------------------
09-09-2016 08:16 AM
Can you do the show ip route on R3 and see if you see the route to R1.
if not then you need a default route .
09-09-2016 08:22 AM
Please see:-
R1#sho ip route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/11] via 10.10.1.2, 00:26:01, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/21] via 10.10.1.2, 00:26:01, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O E2 4.4.4.4 [110/10] via 10.10.1.2, 00:23:58, FastEthernet0/0
10.0.0.0/24 is subnetted, 4 subnets
C 10.10.1.0 is directly connected, FastEthernet0/0
O 10.10.2.0 [110/20] via 10.10.1.2, 00:26:03, FastEthernet0/0
O E2 10.10.3.0 [110/10] via 10.10.1.2, 00:24:43, FastEthernet0/0
O E2 10.10.4.0 [110/10] via 10.10.1.2, 00:24:00, FastEthernet0/0
R1#
-------------------------
R3#sho ip route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/21] via 10.10.2.1, 00:26:22, FastEthernet0/1
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/11] via 10.10.2.1, 00:26:22, FastEthernet0/1
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
4.0.0.0/32 is subnetted, 1 subnets
R 4.4.4.4 [120/1] via 10.10.3.2, 00:00:42, FastEthernet0/0
10.0.0.0/24 is subnetted, 4 subnets
O 10.10.1.0 [110/20] via 10.10.2.1, 00:26:23, FastEthernet0/1
C 10.10.2.0 is directly connected, FastEthernet0/1
C 10.10.3.0 is directly connected, FastEthernet0/0
R 10.10.4.0 [120/1] via 10.10.3.2, 00:00:44, FastEthernet0/0
R3#
R3#
09-09-2016 09:02 AM
you are getting the routes via E2 but your redistribution is not set to redistribute the E2 routes.
use this command on R1.
router rip
version 2
redistribute ospf 1 match internal external 1 external 2
let me know if it works.
09-11-2016 02:01 AM
Thanks for your suggestion, but it is not working.
Regards,
Deepak Kumar
www.deepuverma.in
09-26-2016 05:32 AM
Anyone have solution ?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide