cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 
cancel
590
Views
0
Helpful
3
Replies

I am unable to ping to outside network.

OneZ12345
Level 1
Level 1

Hi guys eventually i configured Inter-VLAN using layer 3 switch but I seem to not be able to find the issue why my pcs is able to ping to the ISP router but not outside of the network (Internet). I am just a beginner and don't really know how to troubleshoot this issue. I did try to put Ip route address but it is still not able to send packets.

3 Replies 3

You need NAT

MHM

This is my ISP_router configuration: 
Current configuration : 1872 bytes
!
version 15.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ISP=Router
!
!
!
!
ip dhcp excluded-address 172.16.0.1 172.16.0.10
!
ip dhcp pool LAN
network 172.16.0.0 255.255.255.0
default-router 172.16.0.1
dns-server 202.21.1.11
domain-name SRWE.COM
!
!
!
no ip cef
ipv6 unicast-routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
ip domain-name customer.isp.net
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0/0
description ToInternet
ip address dhcp
ip nat outside
duplex auto
speed auto
ipv6 address 2001:DB9:0:2::2/64
!
interface GigabitEthernet0/0/1
description ToLan
ip address 172.16.0.1 255.255.255.0
ip nat inside
duplex auto
speed auto
ipv6 address 2001:DB8::1/64
!
interface GigabitEthernet0/0/1.10
encapsulation dot1Q 10
ip address 172.16.10.1 255.255.255.0
!
interface GigabitEthernet0/0/1.20
encapsulation dot1Q 20
ip address 172.16.20.1 255.255.255.0
!
interface GigabitEthernet0/0/1.30
encapsulation dot1Q 30
ip address 172.16.30.1 255.255.255.0
!
interface GigabitEthernet0/0/1.40
encapsulation dot1Q 40
ip address 172.16.40.1 255.255.255.0
!
interface GigabitEthernet0/0/1.50
encapsulation dot1Q 50
ip address 172.16.50.1 255.255.255.0
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source list TOINTERNET interface GigabitEthernet0/0/0 overload
ip classless
ip route 172.16.0.0 255.240.0.0 GigabitEthernet0/0/1
!
ip flow-export version 9
!
ipv6 route ::/0 2001:DB9:0:2::1
ipv6 route 2001:DB8::/32 2001:DB8::11
ipv6 route 2001:DB8::/32 2001:DB8::12
!
ip access-list standard TOINTERNET
deny any
permit 0.0.0.0 255.255.255.0
permit 172.16.0.0 0.15.255.255
!
!
!
!
!
line con 0
exec-timeout 0 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

This is my Layer 3 switch configuration: 

Building configuration...

 

Current configuration : 2618 bytes

!

version 16.3.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

ip dhcp pool VLAN10-DHCP

network 172.16.10.0 255.255.255.0

default-router 172.16.10.1

dns-server 202.21.1.11

ip dhcp pool VLAN20-DHCP

network 172.16.20.0 255.255.255.0

default-router 172.16.20.1

dns-server 202.21.1.11

ip dhcp pool VLAN30-DHCP

network 172.16.30.0 255.255.255.0

default-router 172.16.30.1

dns-server 202.21.1.11

ip dhcp pool VLAN40-DHCP

network 172.16.40.0 255.255.255.0

default-router 172.16.40.1

dns-server 202.21.1.11

ip dhcp pool VLAN50-DHCP

network 172.16.50.0 255.255.255.0

default-router 172.16.50.1

dns-server 202.21.1.11

!

!

!

ip cef

ip routing

!

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet1/0/1

switchport mode trunk

!

interface GigabitEthernet1/0/2

switchport trunk allowed vlan 10,20,30,40,50

switchport mode trunk

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

!

interface GigabitEthernet1/0/16

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

!

interface GigabitEthernet1/0/24

!

interface GigabitEthernet1/1/1

!

interface GigabitEthernet1/1/2

!

interface GigabitEthernet1/1/3

!

interface GigabitEthernet1/1/4

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

mac-address 00e0.f90a.1701

ip address 172.16.10.1 255.255.255.0

ip helper-address 172.16.0.1

!

interface Vlan20

mac-address 00e0.f90a.1702

ip address 172.16.20.1 255.255.255.0

ip helper-address 172.16.0.1

!

interface Vlan30

mac-address 00e0.f90a.1703

ip address 172.16.30.1 255.255.255.0

ip helper-address 172.16.0.1

!

interface Vlan40

mac-address 00e0.f90a.1704

ip address 172.16.40.1 255.255.255.0

ip helper-address 172.16.0.1

!

interface Vlan50

mac-address 00e0.f90a.1705

ip address 172.16.50.1 255.255.255.0

ip helper-address 172.16.0.1

!

ip classless

ip route 0.0.0.0 0.0.0.0 162.21.1.11

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

!

end

ip access-list standard TOINTERNET
deny any <- this need to remove 
permit 0.0.0.0 255.255.255.0 <- this also need to remove not need it
permit 172.16.0.0 0.15.255.255 <- keep this

MHM

Review Cisco Networking for a $25 gift card