cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
449
Views
0
Helpful
2
Replies

Implement ip verify source with Template

saxoflo07
Level 1
Level 1

Hello,

Currently I try to implement configuration with Template interface, but I have some trouble with "ip verify source" :

I want this on my interface :

interface GigabitEthernetX/X/X
switchport access vlan XXX
switchport mode access
switchport nonegotiate
switchport port-security maximum 3
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
switchport port-security
no logging event link-status
storm-control broadcast level 5.00
storm-control multicast level 5.00
storm-control unicast level 5.00
auto qos trust dscp
service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
ip verify source

but some commade don't work when I created a "Interface template" like:

 

auto qos trust dscp
ip verify source

I work with a Cisco 9200 version Cisco IOS XE Software, Version 16.11.01.

Anybody have any idea ? 

 

Best Regards,

2 Replies 2

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Saxoflo07,

you can try to use the old approach of  interface range instead to configure a group of physical ports in the same manner at once.

Later you can change the access vlan and description as needed.

 

Hope to help

Giuseppe

 

Yes I did that but I try to minimize the number of configuration line, I already did this :

 

template ACCESS_SECURITY_TEMPLATE
storm-control broadcast level 5.00
storm-control multicast level 5.00
storm-control unicast level 5.00
switchport nonegotiate
switchport port-security maximum 3
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
switchport port-security
service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
exit

template interface USER_VLXXX_TEMPLATE
description Port User
switchport access vlan XXX
switchport mode access
source template ACCESS_SECURITY_TEMPLATE
exit

interface Gi1/0/1
source template USER_VLXXX_TEMPLATE
ip verify source

I have many template, I use some with "ip verify source" and other without this command.

I only want to add one line per interface, anybody have an idea ?

 

Best Regards,

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card