cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5082
Views
0
Helpful
12
Replies
utawakevou
Participant

Input errors and CRC

I have 2  Cisco 3750 stacked and two ports from each switch configured for ether-channel (LACP) as inter switch link between the Cisco and an HP switch (with trunking - LACP configured as well). On switch 1 I have port 1/0/25 and 1/0/26 and switch two 2/0/25 and 2/0/26. I notice that one of the ports (2/0/25) in that port-channel group showing a lot of input errors and CRC and increments at 30 seconds. There is no error at all on the HP fiber interface. I have done following:

  • Change the fiber cable
  • Disconnect that port i.e unplug the fiber patch lead at the Cisco end and the HP end and I notice it that the errors shows up on one of the 3 interface connected. i.e when I remove the cable from port 2/0/25 the error shows up on interface 1/0/25 and If I disconnect 1/0/25 the error shows up on 2/0/26

So I assume it must be my layer 2 configuration or something that I have missed. Here is my configuration on the Cisco stacked 3750 and any help will be really apprecaited:

interface Port-channel1
description Uplink-HP4204vl
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate

interface GigabitEthernet1/0/25
description Uplink-HP4204vl
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active

interface GigabitEthernet1/0/26
description Uplink-HP4204vl
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active

interface GigabitEthernet2/0/25
description Uplink-HP4204vl
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active

interface GigabitEthernet2/0/26
description Uplink-HP4204vl
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active

12 REPLIES 12
Leo Laohoo
VIP Community Legend

Post the complete output to the command "sh interface Gi 2/0/25 cont".

GigabitEthernet2/0/25 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 68bd.ab5d.d319 (bia 68bd.ab5d.d319)
Description: Uplink-HP4204vl
MTU 9000 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 8/255
Encapsulation ARPA, loopback not set
Keepalive not set
Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseLX SFP
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:58, output hang never
Last clearing of "show interface" counters 1d18h
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 34977000 bits/sec, 4440 packets/sec
5 minute output rate 21000 bits/sec, 34 packets/sec
762935088 packets input, 1022066320206 bytes, 0 no buffer
Received 1028228 broadcasts (0 multicasts)
0 runts, 0 giants, 0 throttles
5116 input errors, 5116 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 280962 multicast, 0 pause input
0 input packets with dribble condition detected
38758126 packets output, 51608682087 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

Leo Laohoo
VIP Community Legend

Hmmmm ... The output is incomplete.  Can you please post the complete output to the command "sh controll e Gi 2/0/25".

Kindly paste the output in a text file and attach the file to your response.

Sorry I just did a show interface before. Here is the result for "sh interface Gi 2/0/25 cont"

#sh interface Gi 2/0/25 cont
GigabitEthernet2/0/25 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 68bd.ab5d.d319 (bia 68bd.ab5d.d319)
Description: Uplink-HP4204vl
MTU 9000 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 9/255
Encapsulation ARPA, loopback not set
Keepalive not set
Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseLX SFP
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:30, output hang never
Last clearing of "show interface" counters 1d20h
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 38952000 bits/sec, 5148 packets/sec
5 minute output rate 265000 bits/sec, 45 packets/sec
781344880 packets input, 1038592218276 bytes, 0 no buffer
Received 1073938 broadcasts (0 multicasts)
0 runts, 0 giants, 0 throttles
5273 input errors, 5273 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 301642 multicast, 0 pause input
0 input packets with dribble condition detected
38961274 packets output, 51690434996 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

Transmit GigabitEthernet2/0/25 Receive
400050820 Bytes 4065801379 Bytes
1575380911 Unicast frames 622757633 Unicast frames
88310020 Multicast frames 107030287 Multicast frames
73749537 Broadcast frames 227409547 Broadcast frames
0 Too old frames 2994025655 Unicast bytes
0 Deferred frames 3469563043 Multicast bytes
0 MTU exceeded frames 3715320023 Broadcast bytes
0 1 collision frames 0 Alignment errors
0 2 collision frames 798266 FCS errors
0 3 collision frames 0 Oversize frames
0 4 collision frames 111690848 Undersize frames
0 5 collision frames 0 Collision fragments
0 6 collision frames
0 7 collision frames 2545501959 Minimum size frames
0 8 collision frames 3053778266 65 to 127 byte frames
0 9 collision frames 2057969685 128 to 255 byte frames
0 10 collision frames 992085991 256 to 511 byte frames
0 11 collision frames 502432603 512 to 1023 byte frames
0 12 collision frames 396161821 1024 to 1518 byte frames
0 13 collision frames 0 Overrun frames
0 14 collision frames 0 Pause frames
0 15 collision frames
0 Excessive collisions 0 Symbol error frames
0 Late collisions 0 Invalid frames, too large
0 VLAN discard frames 0 Valid frames, too large
0 Excess defer frames 0 Invalid frames, too small
3108537147 64 byte frames 111690848 Valid frames, too small
3928599594 127 byte frames
1090988469 255 byte frames 0 Too old frames
509789108 511 byte frames 0 Valid oversize frames
266348160 1023 byte frames 0 System FCS error frames
1423112562 1518 byte frames 0 RxPortFifoFull drop frame
20 Too large frames
0 Good (1 coll) frames
0 Good (>1 coll) frames

Leo Laohoo
VIP Community Legend

798266 FCS errors

This is what I'm looking for.  No Alignment Errors.  No Symbol Error Frames.  No System FCS Error Frams.  

This is a Layer 1 issue.  I notice this is a fibre optic link.  Can I ask if you can replace the SFP module downstream?

Sure. Will try that out.  However I cant figure out why downstream switch interfaces doesn't show any errors at all. And if you read my initial post I said that when I isolate (unplug fiber patch lead from both switch corresponding ports) the affected interface the errors move to the other interfaces

Will keep you posted

Leo Laohoo
VIP Community Legend

Disconnect that port i.e unplug the fiber patch lead at the Cisco end and the HP end and I notice it that the errors shows up on one of the 3 interface connected. i.e when I remove the cable from port 2/0/25 the error shows up on interface 1/0/25 and If I disconnect 1/0/25 the error shows up on 2/0/26

  • What IOS version is the switch running on?

Cisco IOS Software, C3750 Software (C3750-IPSERVICES-M), Version 12.2(35)SE5, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Thu 19-Jul-07 19:15 by nachen
Image text-base: 0x00003000, data-base: 0x01280000

ROM: Bootstrap program is C3750 boot loader
BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.2(25r)SEE4, RELEASE SOFTWARE (fc1)

lot-core-sw1 uptime is 1 year, 10 weeks, 5 days, 21 hours, 37 minutes
System returned to ROM by power-on
System restarted at 11:54:52 FJT Mon Feb 22 2016
System image file is "flash:c3750-ipservices-mz.122-35.SE5/c3750-ipservices-mz.122-35.SE5.bin"

cisco WS-C3750G-24TS-1U (PowerPC405) processor (revision H0) with 118784K/12280K bytes of memory.
Processor board ID FOC1437Y1MC
Last reset from power-on
2 Virtual Ethernet interfaces
56 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : 68:BD:AB:5D:D1:80
Motherboard assembly number : 73-10219-09
Power supply part number : 341-0098-02
Motherboard serial number : FOC14373JXD
Power supply serial number : DCA143295P1
Model revision number : H0
Motherboard revision number : A0
Model number : WS-C3750G-24TS-E1U
System serial number : FOC1437Y1MC
Top Assembly Part Number : 800-27484-03
Top Assembly Revision Number : A0
Version ID : V05
CLEI Code Number : COMBL10BRA
Hardware Board Revision Number : 0x09


Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 28 WS-C3750G-24TS-1U 12.2(35)SE5 C3750-IPSERVICES-M
2 28 WS-C3750G-24TS-1U 12.2(35)SE5 C3750-IPSERVICES-M


Switch 02
---------
Switch Uptime : 1 year, 10 weeks, 5 days, 21 hours, 44 minutes
Base ethernet MAC Address : 68:BD:AB:5D:D3:00
Motherboard assembly number : 73-10219-09
Power supply part number : 341-0098-02
Motherboard serial number : FOC14373M94
Power supply serial number : AZS1432035S
Model revision number : H0
Motherboard revision number : A0
Model number : WS-C3750G-24TS-E1U
System serial number : FOC1437Y1ME
Top assembly part number : 800-27484-03
Top assembly revision number : A0
Version ID : V05
CLEI Code Number : COMBL10BRA

Configuration register is 0xF

Leo Laohoo
VIP Community Legend

I've got a funny feeling this is an IOS bug.

Hi Leo,

Changing the fiber module and the fiber cable but still seeing errors after clearing the counters on those interface. 

Leo Laohoo
VIP Community Legend

Changing the fiber module

Did you change the SFP of both sides or just one?

fiber cable

Is this patch cable a direct link or does it go to a FOBOT?

I just change the fiber module at the HP end as I don't have any spare for the Cisco end. Fiber cable is a direct link