cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3138
Views
5
Helpful
15
Replies

Inter-VLAN routing - Packet Tracer

Ckey
Level 1
Level 1

Hi all, 

I'm currently having issues with a project that involves 2 Cisco 2911 routers, 2 layer-3 3560 switches and a layer 2 2960 switch. The two layer 3 switches and the layer 2 switch are all channelled together. 

 

The issue I'm having is that I can get the servers, routers and layer 3 switches to ping each other but I cannot get my 2 PC's on vlan 110 and vlan 120 to ping each other. This is because DHCP is giving out a default gateway that hasn't been assigned yet via the specification that has been given to me. 

 

So my question is, how would I assign the two default gateway addresses 10.1.110.254 and 10.1.120.254 to the routers so that the PC's can ping each other? 

 

I've uploaded the packet tracer file to tinyupload for anybody to have a look at. If you would like the brief I have been given, I can also provide that too. 

 

http://s000.tinyupload.com/index.php?file_id=03202430797549793670

 

Many thanks,

CKey

1 Accepted Solution

Accepted Solutions

Hello,

 

the only way I can think of to make this work is by configuring HSRP:

 

DLSW1:

 

interface Vlan110
mac-address 0030.f2d2.0203
ip address 10.1.110.252 255.255.255.0
ipv6 address 2001:DB8:CAFE:110::D1/64
standby 110 ip 10.1.110.254

 

DLSW2

 

interface Vlan110
mac-address 0001.43ea.8203
ip address 10.1.110.253 255.255.255.0
ipv6 address 2001:DB8:CAFE:110::D2/64
standby 110 ip 10.1.110.254

 

If you set your PC-C to DHCP, it will get the below IP:

 

C:\>ipconfig

FastEthernet0 Connection:(default port)

Link-local IPv6 Address.........: FE80::290:21FF:FED5:587C
IP Address......................: 10.1.110.1
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 10.1.110.254

View solution in original post

15 Replies 15

EduardR
Level 1
Level 1

Hi,

 

Can you provide the subinterface configuration on the routers?  I think you just need to specify the ip address and mask to each subinterface and youre good to go.

I haven't created subinterfaces on the routers, do I have to that on the ports connected to the layer 3 switches? I thinks that's where I went wrong, I'll try and do that now, thanks.

Here are the configurations:

 

R1:

interface GigabitEthernet0/1.110

encapsulation dot1Q 110

ip address 10.1.110.254 255.255.255.0

 

R3:

interface GigabitEthernet0/1.120

encapsulation dot1Q 120

ip address 10.1.120.254 255.255.255.0

 

I added these and the hosts still couldn't ping each other :( I'm so confused.

Uhm, i think there is not a route from R1 to R3. How do you route the subnet from one router to another?

 

I would make route between R1 and R3 but the specification doesn't ask for that. I thought that R1 and R3 would be able to communicate between etherchannel 10 which runs between DLS1 and DLS2. Or they would communicate through R2 which is connected to both of them. 

 

 

Maybe they are able to communicate between themselves, but they are not routing the subnets for that link. 

 

PD: unfortunately i can't open your attached file here =(, and can't check the configuration, but i think you can test step by step this way:

  1. Check the connection between both routers are working (a ping from one to another, maybe).
  2. Check the subinterfaces are working ok (a ping from the hosts)
  3. Route the networks from one router to another, and check that from router1 you can ping router3 subinterface (VLAN 120) and vice versa.
  4. Check that form the VLAN 110 host you can ing VLAN120 subinterface.
  5. Check connectivity between hosts in both VLANs

I'll give all of that a go, thank you. It's starting to really confuse me now because all of my other devices can ping eachother but the PC's can't ping the routers or each other. Here is a picture for a bit of context.

Hello,

 

I don't know what your requirements are, but your PC in VLAN110 gets a DHCP assigned address which does not correspond to the nearest layer 3 interface for that VLAN. I have manually changed the IP addess to a static one, with the default gateway being 10.1.110.253. On the first layer 3 switch, the default router for the Office VLAN 120 in the pool does not correspond to the IP address of the VLAN 120 interface on that L3 switch. I have changed the IP address to 10.1.120.254, now your PC gets an IP address.

 

I have attached the revised topology (change the .jpg back to .pkt)...

Thanks for the reply. Unfortunately, I cannot open the file as it is incompatible with my version of packet tracer, I'll try updating it again. I also would have done what you said needed corrected, but my teacher insisted that .254 addresses were to be used as the assigned default gateways by the DHCP server. He said that I should assign those address to R1 and R3 which would then make it work. At this point, I'm really confused and frustrated as the way he wants the network setting up makes barely any sense to me in perspective to the Vlans.

Hello,

 

here are the working configs:

 

DLS1#sh run
Building configuration...

Current configuration : 3209 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname DLS1
!
ip dhcp excluded-address 10.1.120.251
ip dhcp excluded-address 10.1.120.254
ip dhcp excluded-address 10.1.200.251
ip dhcp excluded-address 10.1.200.254
ip dhcp excluded-address 10.1.110.251
ip dhcp excluded-address 10.1.110.254
!
ip dhcp pool Voice
network 10.1.200.0 255.255.255.0
default-router 10.1.200.254
dns-server 3.3.3.2
ip dhcp pool Office
network 10.1.120.0 255.255.255.0
default-router 10.1.120.254
dns-server 3.3.3.2
ip dhcp pool Guest
network 10.1.110.0 255.255.255.0
default-router 10.1.110.254
dns-server 3.3.3.2
!
ip routing
!
spanning-tree mode pvst
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel10
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 10 mode active
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 10 mode active
!
interface FastEthernet0/5
no switchport
ip address 10.1.2.1 255.255.255.252
duplex auto
speed auto
ipv6 address 2001:DB8:CAFE:20::D1/64
!
interface FastEthernet0/6
switchport access vlan 100
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
mac-address 0030.f2d2.0201
ip address 10.1.99.252 255.255.255.0
ipv6 address 2001:DB8:CAFE:99::D1/64
!
interface Vlan100
mac-address 0030.f2d2.0202
ip address 10.1.100.252 255.255.255.0
ipv6 address 2001:DB8:CAFE:100::D1/64
!
interface Vlan110
mac-address 0030.f2d2.0203
ip address 10.1.110.252 255.255.255.0
ipv6 address 2001:DB8:CAFE:110::D1/64
!
interface Vlan120
mac-address 0030.f2d2.0204
ip address 10.1.120.254 255.255.255.0
ipv6 address 2001:DB8:CAFE:120::D1/64
!
interface Vlan200
mac-address 0030.f2d2.0205
ip address 10.1.200.254 255.255.255.0
ipv6 address 2001:DB8:CAFE:200::D1/64
!
router eigrp 1
network 10.1.100.0 0.0.0.255
network 10.1.2.0 0.0.0.3
network 10.1.120.0 0.0.0.255
network 0.0.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
ntp server 10.1.202.1 key 0
ntp update-calendar
!
end

 

------------

 

DLS2#sh run
Building configuration...

Current configuration : 2701 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname DLS2
!
ip routing
!
spanning-tree mode pvst
!
interface Port-channel2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel10
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 10 mode active
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 10 mode active
!
interface FastEthernet0/5
no switchport
ip address 10.1.2.13 255.255.255.252
duplex auto
speed auto
ipv6 address 2001:DB8:CAFE:212::D2/64
!
interface FastEthernet0/6
switchport access vlan 110
switchport mode access
switchport nonegotiate
spanning-tree portfast
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
mac-address 0001.43ea.8201
ip address 10.1.99.253 255.255.255.0
ipv6 address 2001:DB8:CAFE:99::D2/64
!
interface Vlan100
mac-address 0001.43ea.8202
ip address 10.1.100.253 255.255.255.0
ipv6 address 2001:DB8:CAFE:100::D2/64
!
interface Vlan110
mac-address 0001.43ea.8203
ip address 10.1.110.253 255.255.255.0
ipv6 address 2001:DB8:CAFE:110::D2/64
!
interface Vlan120
mac-address 0001.43ea.8204
ip address 10.1.120.253 255.255.255.0
ipv6 address 2001:DB8:CAFE:120::D2/64
!
interface Vlan200
mac-address 0001.43ea.8205
ip address 10.1.200.253 255.255.255.0
ipv6 address 2001:DB8:CAFE:200::D2/64
!
router eigrp 1
network 10.1.2.12 0.0.0.3
network 10.1.110.0 0.0.0.255
network 10.1.120.0 0.0.0.255
network 0.0.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
ntp server 10.1.202.1 key 0
ntp update-calendar
!
end

 

------------

 

PC/C

 

C:\>ipconfig

FastEthernet0 Connection:(default port)

Link-local IPv6 Address.........: FE80::290:21FF:FED5:587C
IP Address......................: 10.1.110.1
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 10.1.110.253

 

On the switchports where the PCs are directly connected to, make sure to configure 'spanning-tree portfast'...

Alright thank you, any chance you would know how to get it working via DHCP for both PC's?

Hello,

 

the only way I can think of to make this work is by configuring HSRP:

 

DLSW1:

 

interface Vlan110
mac-address 0030.f2d2.0203
ip address 10.1.110.252 255.255.255.0
ipv6 address 2001:DB8:CAFE:110::D1/64
standby 110 ip 10.1.110.254

 

DLSW2

 

interface Vlan110
mac-address 0001.43ea.8203
ip address 10.1.110.253 255.255.255.0
ipv6 address 2001:DB8:CAFE:110::D2/64
standby 110 ip 10.1.110.254

 

If you set your PC-C to DHCP, it will get the below IP:

 

C:\>ipconfig

FastEthernet0 Connection:(default port)

Link-local IPv6 Address.........: FE80::290:21FF:FED5:587C
IP Address......................: 10.1.110.1
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 10.1.110.254

Alright thank you, I'm going to try and implement these changes and have them done by at least tomorrow evening and if it solves everything I'll mark it completed. Thank you for your help, might help me to stop pulling my hair out so much :P

Great news! I finally got PC-C to ping everything but PC-B now! I still can't get PC-B to ping the routers or PC-C though :?

Review Cisco Networking for a $25 gift card