11-05-2010 07:51 AM - edited 03-06-2019 01:54 PM
We have a new office set-up with a switch stack of Cisco 3750 switches containing a data vlan and a voice vlan.
While we wait for the new infrastructure to be completed (new circuits installed, cabling work, etc) we wanted to make use of an ADSL line in the office to give us temporary WAN connectivity (primarily to make remote config work on various servers etc easier).
So I connected a Cisco 877 ADSL router (with Advanced IP Services IOS) and established WAN connectivity to it from head office without issue.
However, I’m struggling to actually establish LAN connectivity between the switches and the router! (which is what i thought would be the easy part!)
On the 3750 switch stack, we have data VLAN 50 configured and Voice VLAN 55 created.
On the Cisco 877 router, I created VLANs 50 and 55 also.
The 3750 stack has a management address on the data VLAN. It has a default gateway pointing to the VLAN50 address of the 877 router.
I’ve configured port fa1/0/1 on the 3750 as a trunk port:
!
interface FastEthernet1/0/1
description *** Connection to Cisco 877 router Fa0 ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 50,55
switchport mode trunk
spanning-tree portfast trunk
!
I’ve configured port Fa0 on the 877 as a trunk port:
!
interface FastEthernet0
switchport mode trunk
end
!
I’ve connected a cable between the router and the switch but I just cannot establish connectivity (cannot ping router address from switch)
Any ideas what is wrong? I’m fairly sure it must be something simple I’m missing so just looking for some fresh input as my brain is starting to fade trying to think too much about it! (Good chance for someone to earn some easy points I hope!)
Thanks.
11-05-2010 07:58 AM
You need the layer 3 interfaces on the router. I'm going off the top of my head here for the config.
interface FastEthernet0/0.50
encapsulation dot1q 50
ip address 10.10.11.1 255.255.255.0
11-05-2010 08:04 AM
Yes, I've done similar to that in the past using different models of router. Trouble is I can't (or don't seem to be able to!) do that using the 877 router? It doesn't seem to support any syntax for subinterfaces to apply the config you've suggested?
However, I'm told that the Advanced IP services IOS we have running on it DOES support inter-vlan routing?
11-05-2010 08:11 AM
I do it at home and I logged in a took a look. I don't have sub-interfaces. I created a two vlans, then assigned a physical port to each vlan. You will then of course need two cables between the router and the switch.
interface FastEthernet0
switchport access vlan 50
no cdp enable
!
interface FastEthernet1
switchport access vlan 55
no cdp enable
interface Vlan50
description Production LAN
ip address 192.168.77.2 255.255.255.0
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1452
!
interface Vlan55
description DMZ
ip address 10.192.172.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1452
!
11-05-2010 08:20 AM
Ah, thanks, that kind of makes sense (I'm almost certain I tried that but maybe I made a slight error - was one of those rush jobs where you start making simple mistakes as you're trying to rush so much to get it working!)
I wonder if it will make any difference that one of the VLANs is for voice rather than data? (this is only a temporary solution anyway, as long as I can establish connectivity remotely to both VLANs I'll be happy!)
Don't know if I'll get the chance to try this this afternoon or whether it will have to wait till Monday (the office is a fair bit away so don't fancy another trip there today if I can get away with it!) but I will make sure I update (and reward you with your points) when I've checked it out.
Thanks for the help.
11-08-2010 02:56 AM
That is truly bizarre. I've come here fresh today and using (I think!) the exact same configs and set-up as on Friday, it now works perfectly!
i.e. I have port Fa0 on the Cisco 877 set-up as a trunk port:
!
interface FastEthernet0
switchport mode trunk
end
And I have port Fa1/0/1 on the Cisco 3750 set-up as a trunk port.
!
interface FastEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
end
So there wasn't actually any need to run 2 cables as you suggested. No idea what I must have been doing wrong on Friday, I must just have been doing a stupid typo or something when I was testing it out! Very strange!
However, i will award you full points anyway as your solution would also have helped and I was grateful for the fresh pair of eyes to look at things in any case! Thanks.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide