- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-25-2016 02:26 AM - edited 03-10-2019 01:08 PM
Hello,
I have a cisco router 2911 with configured subinterfaces to allow for Inter-VLAN routing. My goal is to setup bonding (bundle, port-channel) on GE0/0 and GE0/1 to allow for redundancy in case of cable failure.
Because i set the channel-group on both GE0/0 and GE0/1 i would assume these interfaces are now bundled.
I do however need the encapsulation dot1Q and have 10.10.10.1 as default GW at all times. So I cant set on GE0/1.10
ip address 10.10.10.4 255.255.255.0
% 10.10.10.4 overlaps with GigabitEthernet 0/0.10
So after reading up on port-channel and dot1Q you can actually do
interface port-channel 1.10
On some routers, but not the 2911
Is there any way for me to get this working using port-channel or any other methods?
Heres my configuration
interface Port-Channel 1
no ip address
!
interface GigabitEthernet 0/0
no ip address
channel-group 1
duplex auto
speed auto
!
interface GigabitEthernet 0/0.10
encapsulation dot1Q 10
ip address 10.10.10.4 255.255.255.0
standby version 2
standby 1 ip 10.10.10.1
standby 1 priority 20
standby 1 preempt
standby 1 track GigabitEthernet 0/2
!
interface GigabitEthernet 0/0.20
encapsulation dot1Q 20
ip address 10.10.20.4 255.255.255.0
standby version 2
standby 1 ip 10.10.20.1
standby 1 priority 20
standby 1 preempt
standby 1 track GigabitEthernet 0/2
!
interface GigabitEthernet 0/1
no ip address
channel-group 1
duplex auto
speed auto
!
interface GigabitEthernet 0/1.10
encapsulation dot1Q 10
# doesnt work
# ip address 10.10.10.4 255.255.255.0
# standby version 2
# standby 1 ip 10.10.10.1
# standby 1 priority 20
# standby 1 preempt
# standby 1 track GigabitEthernet 0/2
!
Solved! Go to Solution.
- Labels:
-
Other Switching
Accepted Solutions
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-25-2016 12:50 PM
I just tested this on a 2911 running 15.4(3)M4 and it worked perfectly. Config below.
When using port-channels layer 3 configuration should only be done on the "Port-Channel" interface. You must remove any layer 3 configuration from the physical interfaces, and there should be no sub-interfaces configured (on the physical interfaces).
interface Port-channel1.10
encapsulation dot1Q 10
ip address 10.10.10.4 255.255.255.0
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-25-2016 12:50 PM
I just tested this on a 2911 running 15.4(3)M4 and it worked perfectly. Config below.
When using port-channels layer 3 configuration should only be done on the "Port-Channel" interface. You must remove any layer 3 configuration from the physical interfaces, and there should be no sub-interfaces configured (on the physical interfaces).
interface Port-channel1.10
encapsulation dot1Q 10
ip address 10.10.10.4 255.255.255.0
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-25-2016 12:52 PM
ps. I guess it is possible this is a "licenced feature". The 2911 I tested this on has an AppX licence (used to be called a "data" licence). If you upgrade to 15.4(3)M4 and it doesn't work - that means you need the extra licence.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-26-2016 12:15 AM
Yes you are right!
Silly of me to try this in Packet Tracer before trying on the router itself.
Yes, interface port-channel1.10 worked without additional licenses.
Thank you
