cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1461
Views
5
Helpful
3
Replies
Highlighted
Beginner

Interface IP address assignment problem

Hi everybody,

I'd like to configure the same IP address on two different sub-interface on the same router (to use them in a different phases of my test) and enable OSPF process on both interface. I want to keep enable (no shutdown) one interface at the time, and than shut down the active interface and enable the other interface.

Following figure is an example

Capture.PNG

i want to keep up the fa0/0 interface, than shutdown fa0/0 and keep up fa0/1 interface. Starting from the condition of both fa0/0, fa0/0.100, fa0/1 and fa0/1.100 in shutdown state....when i configure no shut on fa0/0 the router display the following message "incorrect IP address assignment"

there is a way to resolve the problem? or i must configure no ip add on fa0/0.100 and than enable fa0/1?

Thanks a lot

Paolo

thanks Paolo

3 REPLIES 3
Highlighted
VIP Mentor

Hi

You cannot have the same IP address on 2 or + interfaces on the same router, unless you are using VRF on one of them or you are configuring BVI

 

Option 1) with VRF

 

ip vrf TEST

rd 1:1

 

interface fa0/0

ip address 172.16.1.1 255.255.255.0

no shutdown

 

interface fa0/1

ip vrf forwarding TEST

ip address 172.16.1.1 255.255.255.0

no shutdown

 

 

Option 2) BVI

 

bridge irb

 

default interface fa0/0

default interface fa0/1

 

interface fa0/0

bridge-group 100

no shutdown

 

interface fa0/1

bridge-group 100

no shutdown

 

interface BVI 100

ip address 172.16.1.1 255.255.255.0

no shutdown

 

bridge 100 protocol ieee

bridge 100 route ip

 

 

*The option 2 should resolve the inconvience.

 

Hope it is useful

:-)

 

 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Highlighted

Thanks a lot,

i was thinking that you can have only one active (up interface) same ip address on the same router, but has you said it create problems.

Your solution is nice but i will keep more simple proceding with deleting ip address and reassigning it to the other interface

Thanks

Paolo

Highlighted

Hi Paolo,

 

You are welcome 

 

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Content for Community-Ad