cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3443
Views
0
Helpful
3
Replies
Highlighted
Beginner

IOS XE and Port Channel QoS

Hello,

I have a 4510R-E chassis with SUP7-E running IOS XE version 3.01.01.SG.  I am unable to create a port-channel and apply auto-qos for VOIP.

If I configure auto-qos on the physical interfaces, I get this message when I try adding them to the port channel:

"The attached policymap is not suitable for member either due to non-queuing actions or due to type of classmap filters."

Auto-qos is not an available command in the port-channel interface configuration, but if I try adding the service policies that were created by auto-qos to the port channel manually, it lets me apply the input policy but on the output policy I get this message:

"A service-policy with queuing actions can be attached in output direction only on physical ports."

With the input policy applied to the port-channel interface, I tried addign the output policy to the  physical ports and I got this message:

"A service-policy with non-queuing actions should be attached to the port-channel associated with this physical port."

Is there a way to get the auot-qos policies applied to the port-channel properly?

Thanks,

Andy

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Contributor

IOS XE and Port Channel QoS

Hi,

I havent find a way yet. What you need to do is split your policy in two. Take anything related to queuing, put it into a policy and apply it to the physical port. Take the rest and apply it (in another policy) to the port-channel interface.

I have this issue on sup6 also, it's not IOS XE related. Just a annoying little "feature"

View solution in original post

3 REPLIES 3
Highlighted
Contributor

IOS XE and Port Channel QoS

Hi,

I havent find a way yet. What you need to do is split your policy in two. Take anything related to queuing, put it into a policy and apply it to the physical port. Take the rest and apply it (in another policy) to the port-channel interface.

I have this issue on sup6 also, it's not IOS XE related. Just a annoying little "feature"

View solution in original post

Highlighted
Beginner

IOS XE and Port Channel QoS

Thanks for the reply Dominic, that is what I ended up doing to make it work.  I just wish it would stay consistent.  I have an older 4507 chassis with Sup IV and you apply everything on the physical interfaces on that one, nothing to the port-channel interface.

Highlighted
Beginner

Re: IOS XE and Port Channel QoS

In the IOS-XE stream the proper fix for this is apparently due in July this year. Ive been unable to replicate the fix provided (applying tags etc through the physical interface vs port-channel ) ...

Are you sure this works as expected;

For example;

!

class-map match-any class_icmp

match protocol icmp

!

!        

policy-map policy_tag-icmp

class class_icmp

  set ip dscp ef

!

!

interface Port-channel1

ip address 192.168.1.11 255.255.255.0

!

!

interface GigabitEthernet0/0

no ip address

duplex full

speed 1000

media-type gbic

negotiation auto

channel-group 1

service-policy output policy_tag-icmp

!

!

Does not have the same effect as applying the "service-policy output policy_tag-icmp" to the port-channel

!

!

interface Port-channel1

ip address 192.168.1.11 255.255.255.0

service-policy output policy_tag-icmp

!

All of that being said; "QoS for Etherchannel Interfaces" - IOS-XE

http://www.cisco.com/en/US/docs/ios-xml/ios/qos_mqc/configuration/xe-3s/qos-eth-int.html

Content for Community-Ad