08-05-2014 10:20 AM - edited 03-07-2019 08:17 PM
Anyone that could help please do. This one has got me and my college stumped. We have a router on a stick cause its a 2620 with three vlans. Vlan 2 is a trunk out to our core network while 600 and 603 are local data and voice vlans. This config was working fine until there was a reboot of the router. Now when we turn on "debug ip dhcp packet" we see sporadic messages saying the router is forwarding the address, but nothing is seen in wireshark. Also we get a weird incomplete arp entry for the dhcp servers, even though you can traceroute and ping to them. I have verified with another router setup in this same manor that it doesn't not have the odd behavior with the incomplete arp entries and we see the correct bootp messages like expected in our wireshark. Here is a snippet of the config please assume that anything not shown is default. On the switch side the uplink port to the router and to our core are trunks with no pruning.
interface FastEthernet0/0
no ip address
no ip directed-broadcast
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 1
no ip directed-broadcast
shutdown
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 172.24.1.68 255.255.255.248
no ip directed-broadcast
no ip mroute-cache
!
interface FastEthernet0/0.600
encapsulation dot1Q 600
ip address 172.24.114.1 255.255.255.128
ip helper-address 172.24.255.9
ip helper-address 172.24.255.10
no ip directed-broadcast
!
interface FastEthernet0/0.603
encapsulation dot1Q 603
ip address 172.24.114.129 255.255.255.128
ip helper-address 172.24.255.9
ip helper-address 172.24.255.10
no ip directed-broadcast
!
interface FastEthernet0/0.4000
description This is a fake, unused vlan created to force vlan1 to non-native on both sides
encapsulation dot1Q 4000
no ip directed-broadcast
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.24.1.65
no ip http server
08-06-2014 04:11 AM
Hi,
Are you able to ping the dhcp server if you put a host in either of your vlans 600 or 603 with a static ip address in the range they should be in. This would prove the routing is sound.
Let us know the outcome of this.
cheers
Mike
08-11-2014 04:29 PM
Yes, that was the odd part, all layer routing was working completely fine no matter which subnet you where in you could always reach each server, since that server supplies DHCP for both subnets. The odd part though was the bootp packets not being forwarded. I hate to waste any more time for any one but we end up jsut putting a 3550 in place and everyhting is back up and wroking. Trying to get the 2621 back on site to see if we can get it to act the same, but we are afraid with a configuration chagne that something could get bumped and start working.
08-11-2014 05:17 PM
Chris,
Check your full router config for
!
no ip forward-protocol udp XXX
!
This is tied up with the ip helper-address command
that you apply to the interfaces
Regards
Alex
08-11-2014 05:54 PM
Saw that command on some other post for forwading DHCP, I checked our router before and didn't see that command applied.
08-14-2014 12:33 PM
When anyone describes a problem and says that it worked fine till there was a router reboot, I immediately wonder about the possibility that some config change had been made that got it to work, but the change was not saved to startup-config and when the router reboots the command is lost. Seems like it might be the case here.
I am interested in the comment about the incomplete entries in the arp table for the DHCP server. That indicates that the router was attempting to arp for the server addresses. But I do not see anything that indicates that the router should be doing arp for those addresses. If we could figure this out we might be close to seeing the problem and the solution.
Also I wonder about the statements about ping and trace to the server addresses. If the ping and trace was done from vlan 2 that would be one thing, but ping or trace from vlan 600 and 603 might be something quite different. But since the router has been replaced we will probably not be able to find the solution for this issue.
HTH
Rick
08-15-2014 10:10 AM
That was actually our first thought too, maybe someone change the config but didnt save it. But we have the configs saved on a nightly basis and didn't see any differences.
The incomplete ARP issue was where we were stuck too, because checking other networks that were hooked up the same, they didn't have the ARP issues.
We plan to setup this router in our lab facility to see if we can get the same result by just changing a few IPs address. I'll post our results when we get the cahnce to do so.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide