cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1094
Views
0
Helpful
9
Replies
Beginner

IP helper issue

I am trying to simulate DHCP with ip-helper address (Please refer to the attachment for the topology).

My vlan is 10.10.5.0/24. I have also created a routed port connected from my switch to router (10.10.10.0/30). I put ip helper-address 10.10.10.1  on vlan 1 svi. All configuration are as basic as it gets. DHCP pool is working if everything is on the same subnet.

However, when I'm requesting for ip address, R2 is not responding with saying that the request is coming from 10.10.10.0 network instead of 10.10.5.0. I will post the debug if needed, unfortunately my test laptop is at home.

From what I understand, it is supposed to forward the dhcp request comming from vlan, instead, it looks like my R2 thinks that the request is coming from my 10.10.10.2 (R1 routed interface). Do I need to add something in order to make this work? 

 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Cisco Employee

Hi Vince and Marius,Please

Hi Vince and Marius,

Please allow me to join. This is an interesting issue indeed.

Vince, can you please do a packet capture on the link between your R1 and R2 and post it here as a PCAP file? GNS3 should allow you to do it easily. Try to capture the DHCP communication as forwarded to your R2 and have it posted here if possible.

Best regards,
Peter

9 REPLIES 9

Hello,     Interesting

Hello,

     Interesting question.A debug or a running config should be nice.A simple question though,have you set the Vlan interface address?

Beginner

My vlan 1 is 10.10.10.1 and I

My vlan 1 is 10.10.10.1 and I have an ospf running. I can ping my routers without any issues.

I'll post the debug tomorrow

Beginner

Hey there, sorry if it took a

Hey there, sorry if it took a while for me to reply. Here's the log that I am getting:

*Mar  1 00:09:56.263: DHCPD: Sending notification of DISCOVER:
*Mar  1 00:09:56.263:   DHCPD: htype 1 chaddr c403.1674.0000
*Mar  1 00:09:56.263:   DHCPD: remote id 020a00000a0a0a0100000000
*Mar  1 00:09:56.263:   DHCPD: circuit id 00000000
*Mar  1 00:09:56.263: DHCPD: Seeing if there is an internally specified pool class:
*Mar  1 00:09:56.263:   DHCPD: htype 1 chaddr c403.1674.0000
*Mar  1 00:09:56.263:   DHCPD: remote id 020a00000a0a0a0100000000
*Mar  1 00:09:56.263:   DHCPD: circuit id 00000000
*Mar  1 00:09:56.263: DHCPD: there is no address pool for 10.10.10.1.

 

 

Here's my router configuration from GNS3:

 

R1:


Current configuration : 1173 bytes
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname R1
boot-start-marker
boot-end-marker
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
no ip dhcp use vrf connected


ip dhcp excluded-address 10.10.5.1 10.10.5.100
ip dhcp pool LAN
   network 10.10.5.0 255.255.255.0
   default-router 10.10.5.1
   domain-name wr


no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3

archive
 log config
  hidekeys
ip tcp synwait-time 5
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.252
 speed 100
 full-duplex
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 10.10.10.0 0.0.0.3 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

 

R2:

Current configuration : 1443 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname ESW1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
 no switchport
 ip address 10.10.10.2 255.255.255.252
 speed 100

full-duplex
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 ip address 10.10.5.1 255.255.255.0
 ip helper-address 10.10.10.1
!
router ospf 1
 log-adjacency-changes
 network 10.10.5.0 0.0.0.255 area 66
 network 10.10.10.0 0.0.0.3 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!

line con 0
line aux 0
line vty 0 4
 login
!
end

 

 

I believe I may be missing something

 

 

Hall of Fame Cisco Employee

Hi Vince and Marius,Please

Hi Vince and Marius,

Please allow me to join. This is an interesting issue indeed.

Vince, can you please do a packet capture on the link between your R1 and R2 and post it here as a PCAP file? GNS3 should allow you to do it easily. Try to capture the DHCP communication as forwarded to your R2 and have it posted here if possible.

Best regards,
Peter

Beginner

hey there, I will try to do

hey there, I will try to do so tomorrow. It's a busy day today and I haven't got a spare time playing around with it. One thing I was able to do is set up a dhcp relay which work wonderfully though I really want to try to make ip helper work for my ccnp practice.

Highlighted

Hi,     Just a hunch but

Hi, 

    Just a hunch but doesn't the ip helper have to have the pool defined. 

I mean you have a DHCP pool defined locally but you set it to get it from an external DHCP server that doesn't even have the correct pool defined. 

Try to define the pool in the 10.10.10.1 router and tell me how it goes. 

Hope I understood the case correctly. 

Beginner

My 10.10.5.1 pool is define

My 10.10.5.1 pool is define on 10.10.10.1. Basically, I want my vlan to get my dhcp on my R1 router.

Beginner

I think my problem is more of

I think my problem is more of a GNS3 issue.

I tried to capture packets as what Peter has suggested, and it turns out that my request does not have any source ip. Instead of simulating a multilayer switch, I decided to split the switch and add another router in between. The IP helper worked. I'm attaching my packet captures and my new topology.

Finally, I tried my original topology on the good ol' packet tracer. It seem to work without any problem. Too bad I do not have any physical router to work on right now.

I'm concluding I'm doing something wrong with my GNS3 or my image. Thanks guys for the help.

Hall of Fame Cisco Employee

Hi Vince,Well that's

Hi Vince,

Well that's ridiculous - how could a DHCP Relay Agent forward a packet to a predefined DHCP server without inserting its own IP address into the source IP field and the giaddr field in the DHCP message body?

Would you please mind posting the full and complete configurations of all devices in the topology that does not work? I'd love to see what's causing this errant behavior.

Best regards,
Peter

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards