cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1726
Views
0
Helpful
11
Replies

IP Helper not working on multi router and multi subnet network

anthonycg95
Level 1
Level 1

I am working on configuring a multi router and subnet network at home and have created a packet tracer test (that is comparable) to try and see if I could recreate, I have the same issue.  At home I have an edgerouter that is connected to a C2811 to a 3560 switch.  I have essentially the same issue where devices do not pull DHCP addresses.  DHCP is configured on router 1 and my ip-helper is 192

 

In packet tracer I have three subnets:

192.168.1.0/24

192.168.2.0/24

192.168.120.0/24

 

The x.x.1.0 subnet is used for connection between the two routers and does not have DHCP.

The x.x.2.0 subnet is used for connection of fa0/1 on the second router and vlan1 on the attached switch and needs DHCP for that subnet.

The x.x.120.0 subnet is used on the gi0/2 and has DHCP, this LAN works fine and PCs attached this switch pull a DHCP address.

 

I have attached the packet tracer I have setup to recreate this problem.  I have static routes and the switch with the 192.168.2.2 address can see and ping all other subnets including the router with DHCP configured for that subnet.  If I set a static on a machine on that subnet I can see everything.  I seem to just be struggling to get DHCP working on the 192.168.2.0 subnet..  Is DHCP configured wrong or are the UDP packets not making it to the DHCP configured router?

 

Thank you for any help in advance.

11 Replies 11

anthonycg95
Level 1
Level 1

Switch Configuration is as follows:

swtich1#show run
Building configuration...

Current configuration : 1400 bytes
!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname swtich1
!
!
enable secret 5 $1$mERr$vTbHul1N28cEp8lkLqr0f/
enable password cadmin
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.2.2 255.255.255.0
ip helper-address 192.168.1.1
!
ip default-gateway 192.168.2.1
ip classless
ip default-network 192.168.2.0
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
password admin
login
!
!
!
!
end

Hello,

 

your switch1 has 'ip routing' enabled, why is that ? As mentioned, post the zipped .pkt and we can have a closer look.

The reason for ip routing being enabled is because, ideally, I want to split the 192.168.2.0 subnet into two /25s and use the lower half for data and upper for voice as I am trying to configure voip phones.  With the vlans only being on the switch and having assigned ips for both.  Probably keeping vlan1 as the default/data vlan and another for voice.  All while keeping the first router as the dhcp for both /25s.  Its just easier for this example to have one /24.

anthonycg95
Level 1
Level 1

Router 2 Config:

router2#show run
Building configuration...

Current configuration : 858 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname router2
!
!
!
enable secret 5 $1$mERr$vTbHul1N28cEp8lkLqr0f/
enable password cadmin
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router rip
network 192.168.2.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 192.168.120.0 255.255.255.0 192.168.1.1
ip route 192.168.1.0 255.255.255.0 192.168.1.1
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
password admin
login
!
!
!
end

anthonycg95
Level 1
Level 1

Router 1 Config:

router0#show run
Building configuration...

Current configuration : 1315 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname router0
!
!
!
enable secret 5 $1$mERr$vTbHul1N28cEp8lkLqr0f/
enable password cadmin
!
!
ip dhcp excluded-address 192.168.120.0 192.168.120.30
ip dhcp excluded-address 192.168.120.199 192.168.120.255
ip dhcp excluded-address 192.168.2.0 192.168.2.30
ip dhcp excluded-address 192.168.2.199 192.168.2.255
!
ip dhcp pool 120
network 192.168.120.0 255.255.255.0
default-router 192.168.120.1
dns-server 192.168.120.1
ip dhcp pool 2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.2
dns-server 192.168.1.1
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX15243705-
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 192.168.120.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router rip
!
ip classless
ip route 192.168.2.0 255.255.255.0 192.168.1.2
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
password admin
login
!
!
!
end

luis_cordova
VIP Alumni
VIP Alumni

Hi @anthonycg95,

 

The pkt file is not attached.

First you must compress it to be able to send it.

 

Regards

I get the error below when trying to attach as .7z or .zip format.

 

An Unexpected Error has occurred.
  • Your request failed. Please contact your system administrator and provide the date and time you received the error and this Exception ID: 5BD6497E.

    Click your browser's Back button to continue.

Hi @anthonycg9,

 

You can send the pkt to my mail:

lcordova@ciisa.cl

I will answer you in the community chat.

 

Regards

Hello,

 

if the ZIP doesn't work, use one of the free file sharing sites such as Dropbox or 4Shared and post the .pkt there...

 

https://www.technonutty.com/2018/01/free-file-sharing-sites.html

https://www.dropbox.com/s/b5p0ipz8by81cjv/Test.pkt?dl=0

Please see link for download of the pkt file.

Hello,

 

if you disable IP routing on MultilayerSwitch0 and configure the IP helper address on FastEthernet0/1 of Router2, the devices connected to the switch immediately get an IP address from Router1.

 

I think the reason is that Packet Tracer has a lot of bugs, and this seems to be one of them. It should work as you have designed it but it doesn't, which happens quite often, since Packet Tracer doesn't have full featured devices but rather subsets of commands which enable you to accomplish predefined tasks.

Review Cisco Networking for a $25 gift card