Hello everyone,
I faced with a strange problem. I'm trying to enable translations logging for NAT NVI, but it doesn't work at all.
The scheme is very simple: R1-R2-R3
Config R1:
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.252
router ospf 1
network 10.0.0.1 0.0.0.0 area 0
Config R2:
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip nat enable
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.252
ip nat enable
interface FastEthernet0/1
ip address 10.0.0.5 255.255.255.252
ip nat enable
router ospf 1
network 10.0.0.2 0.0.0.0 area 0
network 10.0.0.5 0.0.0.0 area 0
ip nat log translations syslog
ip nat pool 1 1.1.1.1 1.1.1.1 prefix-length 30
ip nat source list 110 pool 1 overload
!
access-list 110 permit icmp any any
Config R3:
interface FastEthernet0/0
ip address 10.0.0.6 255.255.255.252
router ospf 1
network 10.0.0.6 0.0.0.0 area 0
ip route 1.1.1.1 255.255.255.255 10.0.0.5
Ping from R1 to R3 is successful, and on R2 I see translations
R2#sh ip nat nvi translations
Pro Source global Source local Destin local Destin global
icmp 1.1.1.1:5 10.0.0.1:5 10.0.0.6:5 10.0.0.6:5
BUT! in logs appear such things:
%IPNAT-6-CREATED: icmp 0.0.0.0:0 0.0.0.0:0 0.0.0.0:0 0.0.0.0:0
%IPNAT-6-CREATED: icmp 0.0.0.0:0 0.0.0.0:0 0.0.0.0:0 0.0.0.0:0
And as a result I cannot see in history who exactly initiated a connection.
I tried different IOS images on different routers.
Current release is Cisco IOS Software, 7200 Software (C7200-ADVENTERPRISEK9-M), Version 15.2(4)M7
If I use ip nat inside/outside, then I see translations in syslog, but I have to use NAT NVI for different reasons.
Is it possible to make a router to show correct translations?