cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3590
Views
0
Helpful
2
Replies

ISR 4451-x Cross-Stack Etherchannel to Catalyst 3850 stackwise switch stack.

brian.ward
Level 1
Level 1

Greetings All,

 

 I wanted to ask for guidance in configuring a cross-stack etherchannel between an isr 4451-X via 1Gbps Fiber to 4 3850 switches in stackwise configuration.

 

I would prefer not to assign an IP address to my port channel.

 

Here's what I have, the port channel comes up on both sides but i'm unable to ping from the switches to the router.

 

 

Router connected to switches through (SM-X-6X1G):

interface Port-channel5
 description Fiber_Bundle_to_Core_3850_Switches
 mtu 9198
 no ip address
 no negotiation auto
 service instance 1 ethernet
  encapsulation dot1q 1
  rewrite ingress tag pop 1 symmetric
  snmp ifindex persist
  bridge-domain 1
 !
 service instance 100 ethernet
  description Vlan 100
  encapsulation dot1q 100
  rewrite ingress tag pop 1 symmetric
  snmp ifindex persist
  bridge-domain 100
 !
 service instance 200 ethernet
  encapsulation dot1q 200
  rewrite ingress tag pop 1 symmetric
  snmp ifindex persist
  bridge-domain 200

!

interface GigabitEthernet1/0/2
 description To_3850_SW1
 mtu 9198
 no ip address
 media-type sfp auto-failover
 negotiation auto
 channel-group 5 mode active
!
interface GigabitEthernet1/0/3
 description To_3850_SW2
 mtu 9198
 no ip address
 media-type sfp auto-failover
 negotiation auto
 channel-group 5 mode active
!
interface GigabitEthernet1/0/4
 description To_3850_SW3
 mtu 9198
 no ip address
 media-type sfp auto-failover
 negotiation auto
 channel-group 5 mode active
!
interface GigabitEthernet1/0/5
 description To_3850_SW4
 mtu 9198
 no ip address
 media-type sfp auto-failover
 negotiation auto
 channel-group 5 mode active

 

interface BDI1
 description Vlan 1 - L3
 ip address x.x.x.x 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip nat inside
 ip pim sparse-mode
 ip tcp adjust-mss 1360
 vlan-id dot1q 1
 !
 encapsulation dot1Q 1
!
interface BDI100
 description Vlan 100 - L3
 no ip address
 no ip redirects
 no ip proxy-arp
 ip nat inside
 ip pim sparse-mode
 ip tcp adjust-mss 1360
 vlan-id dot1q 100
 !
 encapsulation dot1Q 100
!
interface BDI200
 description Vlan 200 - L3
 ip address x.x.x.x 255.255.255.0
 ip nat inside
 vlan-id dot1q 200
 !
 encapsulation dot1Q 200

!

ip route x.x.x.x 255.255.255.0 BDI1
ip route x.x.x.x 255.255.255.0 BDI200

 

  Switch Config (connected through C3850-NM-4-10G)

 

interface Port-channel5
 description connection_from_3850_switches_to_4451x_router
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
 logging event trunk-status
 logging event bundle-status
 hold-queue 300 in


interface TenGigabitEthernet1/1/1
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
 channel-group 5 mode active

interface TenGigabitEthernet2/1/1
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
 channel-group 5 mode active

interface TenGigabitEthernet3/1/1
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
 channel-group 5 mode active

interface TenGigabitEthernet4/1/1
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
 channel-group 5 mode active

 

interface Vlan1
 ip address x.x.x.x 255.255.255.0
!
interface Vlan100
 no ip address
!
interface Vlan200
 ip address x.x.x.x 255.255.255.0

 

 

Show Router Ether-Channel:

Port-channel5 is up, line protocol is up
  Hardware is GEChannel, address is a023.9f74.7394 (bia a023.9f74.7394)
  Description: Fiber_Bundle_to_Core_3850_Switches
  MTU 9198 bytes, BW 4000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
    No. of active members in this channel: 4
        Member 0 : GigabitEthernet1/0/2 , Full-duplex, 1000Mb/s
        Member 1 : GigabitEthernet1/0/3 , Full-duplex, 1000Mb/s
        Member 2 : GigabitEthernet1/0/4 , Full-duplex, 1000Mb/s
        Member 3 : GigabitEthernet1/0/5 , Full-duplex, 1000Mb/s
    No. of PF_JUMBO supported members in this channel : 4

 

Show Switch Ether-Channel:

Port-channel5 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 70f3.5a10.e31d (bia 70f3.5a10.e31d)
  Description: connection_from_3850_switches_to_4451x_router
  MTU 9198 bytes, BW 4000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 24/255, rxload 12/255
  Encapsulation ARPA, loopback not set

 

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
5      Po5(SU)         LACP      Te1/1/1(P)  Te2/1/1(P)  Te3/1/1(P)
                                 Te4/1/1(P)

 

Cross-Stack EtherChannel Deployment.JPG

2 Replies 2

brian.ward
Level 1
Level 1

I have also tried this as just etherchannel on, rather than LACP with the same results.

 

The 3850's are supposed to add support for PAgP and LACP.

 

As soon as you turn on the ports (or connect the ports) the BDI interfaces on the router come up.

 

BDI1                     x.x.x.x             YES NVRAM  up                    up
BDI100                unassigned       YES unset     up                    up
BDI200                 x.x.x.x             YES NVRAM  up                    up
Port-channel5      unassigned      YES unset     up                    up

VLAN 1 is going to be native on the 3850 switch side unless you specifically tell the switch to tag it. On the router side it looks like you are tagging that VLAN. Is that you issue? What IPs are you trying to ping from? Do you have layer 3 routing turned on the switch module?