cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

547
Views
0
Helpful
2
Replies
Highlighted

Issue with Fiber maintenance - Port channel member failure causes impact

Hi all,

Thanks to you and this forum for the support I've received until now.

We have 3 different DCs seperate approx. by 30-60 KMs in the same country. All these DCs are active (No DR). the DCs are interconnected via Dark fiber link managed by our dark fiber provider. The connecivity is triangle fashioned like this:

DC1 -- (Port Channel of 2*1 gig link with fixed cost stp config) -- DC2 and

DC1 -- (Port Channel of 2*1 gig link with fixed cost stp config) -- DC3 and

DC2 -- (Port Channel of 1*1 gig link with fixed higher cost stp config) -- DC3 -- redundant path

The port chanel link (between 1*1Gig port) between DC2 and 3 being used  only wen the conection between DC2 and 1 or DC3 and 1 fails.

We ave also implemented fixed stp cost (spanning method : PVST) as below to avoid STP cost recalculation when ONE AMONG the 1 Gig link of primary fiber fails.

Indivual member config:

interface GigabitEthernet1/0/12

description DC3_01-Primary-Port gig2/1/3

switchport trunk encapsulation dot1q

switchport trunk native vlan 28

switchport mode trunk

channel-group 11 mode active

Port chanel config :

interface Port-channel<Omitted>

description ****DC1 to DC2 Port Channel*****

switchport trunk encapsulation dot1q

switchport trunk native vlan <Omitted>

switchport mode trunk

spanning-tree cost 3

interface Port-channel<Omitted>

description ****DC1 to DC3 Port Channel*****

switchport trunk encapsulation dot1q

switchport trunk native vlan <Omitted>

switchport mode trunk

spanning-tree cost 3  (From DC1, both port channels are primary and hence STP cost of 3 has been set. At DC2 and DC3, one link will be having more cost than the other 1Gig link).

Now, whenever the dark fiber provider performs a maintenace activity on the interdc fibers, where he plugs out link 1 plugs it back and does the same for link 2, we face network interruption EVEN THOUGH ATLEAST ONE LINK OF ETHERCHANNEL IS ACTIVE DURING THE MAINTENANCE WITH FIXED STP COST SETTING. Why do we have this issue?

Thanks,

Bala

2 REPLIES 2
VIP Expert

Issue with Fiber maintenance - Port channel member failure cause

Hi,

What device is the root bridge?

By default, the cost for a Gig link is 4.  When you are using 2 Gig ports in an Etherchannel the cumulative cost should now be 2. When you loose a link from the Portchannel between DC1 and DC2 or DC1 and DC3, what is the cost?

The cost for Gig link between DC3 and DC2 by default should be 4.

HTH

Re: Issue with Fiber maintenance - Port channel member failure c

Hi Reza,

Thanks for the response.

STP cost at DC1 Switch - For the link to DC2 (Primary) = 3

                                      For the link to DC3 (Primary) = 3

STP cost at DC2 Switch - For the link to DC1 (Primary) = 3

                                      For the link to DC3 (Secondary) = 4

STP cost at DC3 Switch - For the link to DC1 (Primary) = 4

                                      For the link to DC2 (Secondary) = 5

Root Bridge : DC1.

I have also attached the diagram to explain the connectivity and the cost setup.

Thansk,

Bala.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards