cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4656
Views
0
Helpful
5
Replies
Beginner

LACP over dot1q Tunnel with 4506-E and IOS 15

Hi,

i'm desperately trying to get LACP working over a dot1q Tunnel.

The "Service Provider" Switches are two 4506-E Switches with SUP7-E connected via a 10G Link, running on

cat4500e-universalk9.SPA.03.03.00.SG.151-1.SG

sample config:

dot1q tag vlan native

interface GigabitEthernet3/1

switchport access vlan 2001

switchport mode dot1q-tunnel

mtu 1504

l2protocol-tunnel cdp

l2protocol-tunnel stp

no cdp enable

spanning-tree portfast

end

interface TenGigabitEthernet1/1

switchport trunk native vlan 2000

switchport trunk allowed vlan 2000-2047

switchport mode trunk

mtu 1508

end

All command 12.x reference guides indicate that there used to be a  "l2protocol-tunnel point-to-point lacp/pagp"  command.

Did it get removed in the 15.x Versions?

The only way i can get the Port channel to work, is by enabling LACP without negotiation which i really want to avoid!

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

LACP over dot1q Tunnel with 4506-E and IOS 15

Hi,

for the link to work you need a CCO enabled user. Sorry for not mentioning.

About the lacp tunneling as I wrote it is not and won't be supported by your platform  this is why you don't see the cli.

I am not sure that on previous sw you had the command as it was not supported either (and by the way the command is not documented on previous IOS releases either for cat4k).

Regards,

Riccardo

View solution in original post

5 REPLIES 5
Highlighted
Cisco Employee

LACP over dot1q Tunnel with 4506-E and IOS 15

Hi there,

what are you trying to achieve, to TUNNEL lacp packets in a dot1q tunnel or to bundle 2 or more tunnel ports together?

It is not very clear as you might seem to mix the 2 things.

The command "l2protocol-tunnel point-to-point lacp/pagp" instructs the dot1q port to tunnel lacp/pagp in the dot1q tunnel (and send it to the remote end of the dot12q tunnel). However this feature is NOT available on Cat4k with Sup7-E (altough it might be available on lower end switches and softwares).

By the way PAgP, LACP dot1q tunnelling is not even in the short term roadmap for this platform.

But in the end of your post you mentioned that you got the PC to work disabling negotation, which seems to me something else, that is you are trying to bundle multiple switchport dot1q-tunnel ports together.

By the way this is supported as documented in the config guide, but it is not achieved using the tunnel command but the usual 'channel-group X mode ' command

http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst4500/12.2/15.02SG/configuration/guide/tunnel.html#wp1026630

"Port Aggregation Protocol (PAgP), Link Aggregation Control Protocol (LACP), and UniDirectional Link Detection (UDLD) are supported on 802.1Q tunnel ports."

If I misunderstood please clarify what you want to do.

regards,

Riccardo


Highlighted
Beginner

Re: LACP over dot1q Tunnel with 4506-E and IOS 15

Hi,

first of all, thanks for the fast reply!

I have two sites, interconnected with a 10G Link which terminates on my 4500 Switches.

On both Switches, i have a WS-X4648-RJ45-E Line card. The intention is to basically use these Ports like a Patch panel, reaching from one site to the other.

Gi 3/1 is a tunnel to the Gi3/1 interface on the other site using vlan 2001

Gi 3/2 is a tunnel to the Gi3/2 interface on the other site using vlan 2002

and so on...

|2960 (Po1)|===LACP===|4500|---10G---|4500|===LACP===|(Po1) 2960|

Now im trying to create a PC between two other Switches on each site, connected to my 4500 boxes.

CDP/STP are working just fine, only LACP negotiation fails.

Please note that the PC is supposed to terminate on the 2960 sample switches.

As far as i know using two port channels between 2960 and 4500 would be the wrong way.

As i said, im just confused because IOS 12.x versions seemed to have a l2protocol-tunnel point-to-point lacp/pagp command, whereas the 15.x versions dont seem to have it.

Also your link is giving me a 403 error

*edit

Exactly like in this:

http://blog.ipexpert.com/2010/07/12/etherchannel-over-dot1q-tunnels/

scenario

only that the point to point command is missing...

*edit2

seems like someone else was having the same Problems, just with PAgP

https://supportforums.cisco.com/thread/2155612

Highlighted
Cisco Employee

LACP over dot1q Tunnel with 4506-E and IOS 15

Hi,

for the link to work you need a CCO enabled user. Sorry for not mentioning.

About the lacp tunneling as I wrote it is not and won't be supported by your platform  this is why you don't see the cli.

I am not sure that on previous sw you had the command as it was not supported either (and by the way the command is not documented on previous IOS releases either for cat4k).

Regards,

Riccardo

View solution in original post

Highlighted

LACP over dot1q Tunnel with 4506-E and IOS 15

not sure if this will work on the 15.x ios, but you can alway try putting them on the same channel group. for instance:

interface GigabitEthernet3/1

switch trunk encap dot1q

switch mode trunk

switchport trunk allowed vlan 2000-2047

channel-group 1 active

channel-protocol lacp

interface TenGigabitEthernet1/1

switch trunk encap ot1q

switch mode trunk

switchport trunk allowed vlan 2000-2047

channel-group 1 mode active

or something of that nature...just something to play around with...

Highlighted
Enthusiast

LACP over dot1q Tunnel with 4506-E and IOS 15

Riccardo, thanks for the plain talk. It'd be nice if the documentation and/or release notes addressed this.

The "point-to-point" feature will be sorely missed. Aren't service providers upset? They've been known to encourage customers to use LACP end-to-end for redundancy and load-balancing over multiple Ethernet MAN connections.

Nexus platforms are also missing this capability.

-Craig

CreatePlease to create content
Content for Community-Ad