cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

452
Views
0
Helpful
4
Replies
Highlighted
Beginner

LAG not works with ESW Switch

Hi guys,

I'm trying to enable LAG between a 5508 WLC and a Small Business ESW switch. After trying it there is no logical connectivity between WLC and ESW.

I need to apply following commands to the switch using the GUI:

interface GigabitEthernet <interface id>

switchport

channel-group <id> mode on

interface port-channel <id>

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan <native vlan id>

switchport trunk allowed vlan <allowed vlans>

switchport mode trunk

Looking at the saved configuration file, it seems I don't have equivalent commands on the switch:

interface range ethernet g(1-2)

channel-group 1 mode auto

LAG requires the EtherChannel to be configured for the on mode on both the controller and the switch. I think this is causing issue. How can make sure it is on?

Attached is switch configuration file.And here is LAG guidline with the WLC:

http://www.cisco.com/en/US/docs/wireless/controller/7.0MR1/configuration/guide/cg_ports_interfaces.html#wp1295338

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Cisco Employee

Re: LAG not works with ESW Switch

Saman,

Once the EtherChannel is  configured as on at both  ends of the link, it  does not matter if the  switch is  configured for either Link  Aggregation Control Protocol  (LACP) or Cisco  proprietary Port  Aggregation Protocol (PAgP 

This is not entirely precise. An EtherChannel can be either LACP or PAgP or "on" but never in any combination of these modes. The "on" mode explicitly means "do not use LACP nor PAgP and bundle the ports unconditionally". If one end of the bundle was configured in LACP/PAgP mode and the other in the "on" mode, the LACP/PAgP side of the bundle would not come up because it would expect to negotiate with the opposite device which would never take place.

If the WLC does not support LACP then the "on" mode on both ends is the only choice of course. I am glad to see you got it running.

Shoudn't I see them for interface port-channel 1 too?


If the ESW command line behaves similarly to that of an IOS-based switch then yes, you definitely should. In fact, according to your example, you have created a LAG but you are still configuring only the physical interfaces. That is not correct. After bundling a set of physical ports under a LAG, they shall be identically configured even before bundling them, and after the Port-channel interface is created, all subsequent configuration should be performed on this interface instead of physical member ports. Try correcting your configuration in this sense.

Best regards,

Peter

View solution in original post

4 REPLIES 4
Hall of Fame Cisco Employee

LAG not works with ESW Switch

Hello,

To my best knowledge, the ESW supports only the LACP as the EtherChannel signalling protocol. The usable keywords are therefore only active, passive and on (note, however, that the on mode is without any signalling protocol, LACP or PAgP), i.e. channel-group 1 mode { active | passive | on }. The use of LACP is strongly recommended.

Is the channel-group command available at all? What are its possible options?

Best regards,

Peter

Beginner

Re: LAG not works with ESW Switch

Once the EtherChannel is  configured as on at both  ends of the link, it does not matter if the  switch is  configured for either Link Aggregation Control Protocol  (LACP) or Cisco  proprietary Port Aggregation Protocol (PAgP) because no  channel  negotiation is done between the controller and the switch.  Additionally,  LACP and PAgP are not supported on the controller.

By the way I just disabled LACP and now it shows up as what I want. Thanks.

But still there is no connectivity. Now I'm trying to verify VLAN setting. This is all I see:

interface port-channel 1

switchport mode trunk

For normal trunk ports I see my VLAN database and allowed VLAN like this:

interface range ethernet e24,g(3-4)

switchport mode trunk

exit

vlan database

vlan 10,15,20,25,30,35,40,45,50,55,100

exit

interface range ethernet e24,g(3-4)

switchport trunk allowed vlan add 10

.

.

.

switchport trunk allowed vlan add 100

Shoudn't I see them for interface port-channel 1 too?

Hall of Fame Cisco Employee

Re: LAG not works with ESW Switch

Saman,

Once the EtherChannel is  configured as on at both  ends of the link, it  does not matter if the  switch is  configured for either Link  Aggregation Control Protocol  (LACP) or Cisco  proprietary Port  Aggregation Protocol (PAgP 

This is not entirely precise. An EtherChannel can be either LACP or PAgP or "on" but never in any combination of these modes. The "on" mode explicitly means "do not use LACP nor PAgP and bundle the ports unconditionally". If one end of the bundle was configured in LACP/PAgP mode and the other in the "on" mode, the LACP/PAgP side of the bundle would not come up because it would expect to negotiate with the opposite device which would never take place.

If the WLC does not support LACP then the "on" mode on both ends is the only choice of course. I am glad to see you got it running.

Shoudn't I see them for interface port-channel 1 too?


If the ESW command line behaves similarly to that of an IOS-based switch then yes, you definitely should. In fact, according to your example, you have created a LAG but you are still configuring only the physical interfaces. That is not correct. After bundling a set of physical ports under a LAG, they shall be identically configured even before bundling them, and after the Port-channel interface is created, all subsequent configuration should be performed on this interface instead of physical member ports. Try correcting your configuration in this sense.

Best regards,

Peter

View solution in original post

Beginner

Re: LAG not works with ESW Switch

LAG is now up and running!

The funny thing is that the GUI makes everything complicated. It took me 3 hours to figure it out using GUI to enter 9 lines of commands which would take 1 minutes using CLI...

Thanks Peter, now I can enjoy my weekend!

CreatePlease to create content
Content for Community-Ad