12-10-2012 07:48 PM - edited 03-07-2019 10:31 AM
Hello,
On a 6500, two ports are connected as uplink to non-cisco device. We want to make the 6500 ports as etherchannel.
Currently the ports are in access mode being under a SVI vlan. below is the current configuration:-
int vlan 51
ip addr 1.1.1.1/30
int fa0/24
swit access vlan 51
int fa0/25
swit access vlan 51
How do we create an etherchannel for these ports in this scenario. The vlan 51 serves for routing between 6500 and upstream device.
Thanks in advance!
Solved! Go to Solution.
12-10-2012 08:25 PM
1. IP address can remain on Vlan 51 if you are using L2 Port-channel
int vlan 51
ip addr 1.1.1.1/30
2. But if you are looking for Pure Layer 3 ether-channel, no need of VLAN, you can put the config as below
interface Port-channel1
no switchport
IP address 1.1.1.1/30
interface fa 0/24
no switchport
channel-group 1 mode active
interface fa 0/25
no switchport
channel-group 1 mode active
Thanks
Raju
12-10-2012 08:07 PM
Hi
If you are planning to keep the IP Address is on VLAN, then the Port-channel will be L2 port-channel
You can configure LACP between the cisco and non-cisco device
Cisco side configuration should be like this
interface Port-channel1
switchport
switchport access vlan 51
interface fa 0/24
switchport
switchport access vlan 51
channel-group 1 mode active
interface fa 0/25
switchport
switchport access vlan 51
channel-group 1 mode active
Thanks
Raju
12-10-2012 08:15 PM
Thanks Raju.
I need the ip addressing as that is used for routing(next hop) between the devices. So in this case, will keeping the portchannel as layer2 be a better option?
12-10-2012 08:25 PM
1. IP address can remain on Vlan 51 if you are using L2 Port-channel
int vlan 51
ip addr 1.1.1.1/30
2. But if you are looking for Pure Layer 3 ether-channel, no need of VLAN, you can put the config as below
interface Port-channel1
no switchport
IP address 1.1.1.1/30
interface fa 0/24
no switchport
channel-group 1 mode active
interface fa 0/25
no switchport
channel-group 1 mode active
Thanks
Raju
12-10-2012 08:32 PM
Thanks again. I have 1.1.1.2/30 on the other side of the device.
Both ip's are used to route from either devices. In this case, is a L3 PO better or just let remain the ip's on vlan.
12-10-2012 08:35 PM
In that case you can go with L3 Port-channel
Thanks
Raju
12-10-2012 08:45 PM
Hi
Make sue that you configure other end device also for LACP
Thanks
Raju
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide