01-29-2016 06:38 PM - edited 03-08-2019 03:35 AM
Hi All,
I have build two Linux workstations and I am using CISCO layer 3 switch as a gateway. I have configured vlan 10 for gateway and assigned ip addresses to workstations including gateway but I when I ping gateway or Linux workstation to another Linux workstation I got an error host is unreachable.
Please advise or any suggestions.
Nomee.
Solved! Go to Solution.
01-31-2016 04:35 PM
Hi Nomee,
The config example below should work.
Check to see if you have something similar
3550#
!
vlan 10
name LINUX-WORKSTATIONS
!
ip routing
!
interface vlan 10
desrciption LINUX-WORKSTATIONS-VLAN
ip address 192.168.1.1 255.25.255.0
no shut
!
ip route 0.0.0.0 0.0.0.0 YOUR NEXT HOP IP ADD
!
interface fast 0/1
switchport host
switchport access vlan 10
desrciption LINUX-WORKSTATION #1
no shut
!
!
interface fast 0/2
switchport host
switchport access vlan 10
desrciption LINUX-WORKSTATION #2
no shut
!
end
Configure the work stations to
ip address 192.168.1.X (but NOT 1)
subnet mask 255.255.255.0
default gateway 192.168.1.1
Regards
Alex
01-31-2016 04:35 PM
Hi Nomee,
The config example below should work.
Check to see if you have something similar
3550#
!
vlan 10
name LINUX-WORKSTATIONS
!
ip routing
!
interface vlan 10
desrciption LINUX-WORKSTATIONS-VLAN
ip address 192.168.1.1 255.25.255.0
no shut
!
ip route 0.0.0.0 0.0.0.0 YOUR NEXT HOP IP ADD
!
interface fast 0/1
switchport host
switchport access vlan 10
desrciption LINUX-WORKSTATION #1
no shut
!
!
interface fast 0/2
switchport host
switchport access vlan 10
desrciption LINUX-WORKSTATION #2
no shut
!
end
Configure the work stations to
ip address 192.168.1.X (but NOT 1)
subnet mask 255.255.255.0
default gateway 192.168.1.1
Regards
Alex
02-02-2016 04:22 AM
Thank you so much for your response.
i am able to ping from Switch to Fast0/1 without any technical issue. However if i ping from Linux workstation i got an error Destination host unreachable? Even though I have checked all the settings including ifcfg-eth0, resolve.conf, /etc/hosts, gateway and iptables etc.
but still cannot ping from Linux workstation to switch.
Please advise.
Thanks,
Nomee.
02-02-2016 04:32 AM
Hi Nomee,
May be you could post your switch config etc
show run & show vlan
Regards
Alex
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide