cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

790
Views
0
Helpful
2
Replies
Beginner

Lost default configuration

Hi,

I have a Cisco 892 WLAN Router that was upgraded from IOS 12.x to IOS 15. I'm struggling getting the WLAN to work so I decided to reset the router to its default configuration.

With the config-register 0x2102 method, I ended up with a config that seems to be blank somehow; there is no IP assigned to the default network, no DHCP service running and so on. Using the reset button at the back of the router the router comes up with a config that is definitely not a default config.


I need to reset the router to its factory configuration. Any help would be greatly appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Cisco Employee

Re: Lost default configuration

Sebastian,

It is somewhat arguable what could be a "default" or a "factory" configuration of a Cisco router. Cisco routers, notably the ISR series, usually come preloaded with a certain configuration that contains an IP address, perhaps a DHCP server, and some very basic settings, usually created by the SDM or the CCP tools. However, that is not a "factory default", and once you erase that configuration, there is no automatized way to get it back - at least to my experience.

What we usually call by "factory default" is actually what you have described yourself as a "blank" configuration - no addresses, no DHCP server, basically everything deactivated and empty. This is what you get when you either erase the configuration file and reload the router, or you boot it using the 0x2142 configuration register value.

I personally recommend that you forget about trying to get back the preloaded configuration, and rather try to set up the most basic configuration on your device so that you can continue with configuring it using the SDM or CCP - if you are using those.

This is a simple configuration that would enable your router to accept connections from SDM/CCP:

hostname MyRouter

ip domain name home.test

!

service dhcp

!

username admin privilege 15 secret 4dm1n

!

ip http server

ip http secure-server

ip http authentication local

!

interface Vlan1

ip address 10.0.0.1 255.255.255.0

no shutdown

!

ip dhcp excluded-address 10.0.0.0 10.0.0.10

ip dhcp pool VLAN1

network 10.0.0.0 255.255.255.0

default-router 10.0.0.1

!

line con 0

login local

logging synchronous

!

line aux 0

login local

logging synchronous

!

line vty 0 15

login local

logging synchronous

!

end

This configuration can be pasted directly to your router into the global configuration mode. It will assign the IP address 10.0.0.1/24 to your router (its internal interface), start the DHCP service and allow HTTP/HTTPS access to the router. You can then connect your PC to the Fa0 interface on the router and you should be able to get an IP address automatically. Then use the SDM or CCP to proceed with the configuration - use the username "admin" and the password "4dm1n" to access the device.

Feel welcome to ask further!

Best regards,

Peter

View solution in original post

2 REPLIES 2
Hall of Fame Cisco Employee

Re: Lost default configuration

Sebastian,

It is somewhat arguable what could be a "default" or a "factory" configuration of a Cisco router. Cisco routers, notably the ISR series, usually come preloaded with a certain configuration that contains an IP address, perhaps a DHCP server, and some very basic settings, usually created by the SDM or the CCP tools. However, that is not a "factory default", and once you erase that configuration, there is no automatized way to get it back - at least to my experience.

What we usually call by "factory default" is actually what you have described yourself as a "blank" configuration - no addresses, no DHCP server, basically everything deactivated and empty. This is what you get when you either erase the configuration file and reload the router, or you boot it using the 0x2142 configuration register value.

I personally recommend that you forget about trying to get back the preloaded configuration, and rather try to set up the most basic configuration on your device so that you can continue with configuring it using the SDM or CCP - if you are using those.

This is a simple configuration that would enable your router to accept connections from SDM/CCP:

hostname MyRouter

ip domain name home.test

!

service dhcp

!

username admin privilege 15 secret 4dm1n

!

ip http server

ip http secure-server

ip http authentication local

!

interface Vlan1

ip address 10.0.0.1 255.255.255.0

no shutdown

!

ip dhcp excluded-address 10.0.0.0 10.0.0.10

ip dhcp pool VLAN1

network 10.0.0.0 255.255.255.0

default-router 10.0.0.1

!

line con 0

login local

logging synchronous

!

line aux 0

login local

logging synchronous

!

line vty 0 15

login local

logging synchronous

!

end

This configuration can be pasted directly to your router into the global configuration mode. It will assign the IP address 10.0.0.1/24 to your router (its internal interface), start the DHCP service and allow HTTP/HTTPS access to the router. You can then connect your PC to the Fa0 interface on the router and you should be able to get an IP address automatically. Then use the SDM or CCP to proceed with the configuration - use the username "admin" and the password "4dm1n" to access the device.

Feel welcome to ask further!

Best regards,

Peter

View solution in original post

Beginner

Re: Lost default configuration

Thank you! GREAT answer!

CreatePlease to create content
Content for Community-Ad