cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4255
Views
0
Helpful
2
Replies
Highlighted

mls qos cos override - Cat3560

Hi,

I've a question about QoS classification on Cat3560

From

"When QoS is enabled with the mls qos global configuration command and all other QoS settings are at their defaults, traffic is classified as best effort (the DSCP and CoS value is set to 0) without any policing. No policy maps are configured. The default port trust state on all ports is untrusted."

Now, when mls qos cos override is configured on a port, how is the switch behaviour ?

From documentation "All the incoming CoS values are assigned the default CoS value configured with this command"

However I believe the port state is "untrusted".....so which DSCP values are assigned to them ? Is used a cos-to-dscp map to derive the QoS label from the (overridden) CoS value also in this scenario ?

Thanks.

Everyone's tags (3)
2 REPLIES 2
Highlighted
VIP Expert

Re: mls qos cos override - Cat3560

Hi,

The state is trusted or override:

trusted:

interface GigabitEthernet1/0/2

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

mls qos trust cos

end

Switch(config-if)#do sh mls qo int gi1/0/2

GigabitEthernet1/0/2

trust state: trust cos

trust mode: trust cos

trust enabled flag: ena

COS override: dis

default COS: 0

DSCP Mutation Map: Default DSCP Mutation Map

Trust device: none

qos mode: port-based

Switch(config-if)#

override

interface GigabitEthernet1/0/2

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

mls qos cos override

end

Switch(config-if)#do sh mls qo int gi1/0/2

GigabitEthernet1/0/2

trust state: cos override

trust mode: cos override

trust enabled flag: ena

COS override: ena

default COS: 0

DSCP Mutation Map: Default DSCP Mutation Map

Trust device: none

qos mode: port-based

Switch(config-if)#

and I belive the DSCP is default in this case

HTH

Highlighted

Re: mls qos cos override - Cat3560

Thanks for answer...

(link missing in my previous post http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_20_se/configuration/guide/swqos.html#wp1196344 )

So basically what are you saying is that with mls qos cos override configured, port's trust state become "cos override" and the switch follows the "trust cos" logic ( i.e. cos-dscp map is used at classification stage to derive a QoS label etc...); so I guess for an incoming IP packet the DSCP value rewritten at egress is the value coming from cos-to-dscp map...(of course based on overridden cos value)

Do you think that is correct ?

CreatePlease to create content
Content for Community-Ad