cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1265
Views
0
Helpful
4
Replies
tony4336
Beginner

Multicast flood to mrouter port between two switch

Dear friends,

 

I have a flat L2 network, topology are as below:

Group of Crestron NVX streamer --> Switch A 2960X --> Core switch 2960X --> Switch B  2960X --> another group of Streamer

 

IGMP V2 are enable for all switch, IGMP snooping querier enable on Core switch, stream are working normally within their own switch (inside Switch A or B), however, all stream flood to the trunk link between Switch A/ B to Core Switch, but drop after arrived Core switch, seems the all multicast data forwarded to the Querier (mrouter) location, how to limited the multicast data only happen on onw switch but not forward to the querier?  

 


 

4 REPLIES 4
paul driver
VIP Mentor

Hello
Just to confirm , you don’t have ip M/C enabled and you wish to using MC between hosts within the SAME vlan over trunks vis the core switch?
If you have enabled igmp snooping querier already make sure the l3 interface of the vlan has an ip address and is enabled?

show ip igmp interface vlan x



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Hi Paul, 

Here are some of my setting related to Multicast

 

ip igmp snooping vlan 101 querier address 192.168.1.254
no ip igmp snooping vlan 1
ip igmp snooping vlan 101 immediate-leave
no ip igmp snooping vlan 100

 

interface GigabitEthernet1/0/48
switchport mode trunk
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/49
switchport mode trunk
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/50
no ip igmp snooping tcn flood
!
interface Vlan1
ip address 192.168.0.253 255.255.255.0
!
interface Vlan101
ip address 192.168.1.253 255.255.255.0
!

Switch#sh ip igmp snooping
Global IGMP Snooping configuration:
-------------------------------------------
IGMP snooping : Enabled
IGMPv3 snooping (minimal) : Enabled
Report suppression : Enabled
TCN solicit query : Disabled
TCN flood query count : 2
Robustness variable : 2
Last member query count : 2
Last member query interval : 1000

Vlan 1:
--------
IGMP snooping : Disabled
CAPWAP enabled : Disabled
IGMPv2 immediate leave : Disabled
Multicast router learning mode : pim-dvmrp
Robustness variable : 2
Last member query count : 2
Last member query interval : 1000
Vlan 100:
--------
IGMP snooping : Disabled
CAPWAP enabled : Disabled
IGMPv2 immediate leave : Disabled
Multicast router learning mode : pim-dvmrp
Robustness variable : 2
Last member query count : 2
Last member query interval : 1000
Vlan 101:
--------
IGMP snooping : Enabled
CAPWAP enabled : Disabled
IGMPv2 immediate leave : Enabled
Multicast router learning mode : pim-dvmrp
CGMP interoperability mode : IGMP_ONLY
Robustness variable : 2
Last member query count : 2
Last member query interval : 1000

 

Switch#sh ip igmp snooping mrouter
Vlan ports
---- -----
101 Gi1/0/48(dynamic)

 

Switch#sh ip igmp snooping querier
Vlan IP Address IGMP    Version      Port
-------------------------------------------------------------
101 192.168.1.254       v2              Gi1/0/48

 

Switch#sh ip igmp snooping groups
Vlan Group                    Type   Version Port List
-----------------------------------------------------------------------
101 224.0.1.129           igmp   v2        Gi1/0/1, Gi1/0/11, Gi1/0/48
101 239.9.0.0               igmp   v2        Gi1/0/11, Gi1/0/48
101 239.9.0.1               igmp   v2        Gi1/0/11, Gi1/0/48
101 239.255.255.250   igmp   v2        Gi1/0/1, Gi1/0/11, Gi1/0/48
101 239.255.255.255   igmp   v2        Gi1/0/1, Gi1/0/11, Gi1/0/48

 

*** All multicast fordwarded to Gi1/0/48 which dynamic set to mrouter port

 

This is the Core switch

no ip igmp snooping vlan 1 querier
ip igmp snooping vlan 101 querier address 192.168.1.254
no ip igmp snooping vlan 100 querier
no ip igmp snooping vlan 1
ip igmp snooping vlan 101 immediate-leave
no ip igmp snooping vlan 100

 

interface GigabitEthernet0/7
switchport mode trunk
no ip igmp snooping tcn flood
!
interface GigabitEthernet0/8
switchport mode trunk
no ip igmp snooping tcn flood
!
interface Vlan1
ip address 192.168.0.254 255.255.255.0
!
interface Vlan101
ip address 192.168.1.254 255.255.255.0

 

Switch#sh ip igmp snooping
Global IGMP Snooping configuration:
-------------------------------------------
IGMP snooping : Enabled
IGMPv3 snooping (minimal) : Enabled
Report suppression : Enabled
TCN solicit query : Disabled
TCN flood query count : 2
Robustness variable : 2
Last member query count : 2
Last member query interval : 1000

Vlan 1:
--------
IGMP snooping : Disabled
CAPWAP enabled : Disabled
IGMPv2 immediate leave : Disabled
Multicast router learning mode : pim-dvmrp
Robustness variable : 2
Last member query count : 2
Last member query interval : 1000
Vlan 100:
--------
IGMP snooping : Disabled
CAPWAP enabled : Disabled
IGMPv2 immediate leave : Disabled
Multicast router learning mode : pim-dvmrp
Robustness variable : 2
Last member query count : 2
Last member query interval : 1000
Vlan 101:
--------
IGMP snooping : Enabled
CAPWAP enabled : Disabled
IGMPv2 immediate leave : Enabled
Multicast router learning mode : pim-dvmrp
CGMP interoperability mode : IGMP_ONLY
Robustness variable : 2
Last member query count : 2
Last member query interval : 1000

 

Switch#sh ip igmp snooping querier
Vlan    IP Address           IGMP Version     Port
-------------------------------------------------------------
101    192.168.1.254     v2                      Switch

 

Switch#sh ip igmp snooping mrouter
Vlan   ports
----   -----
101   Switch

 

Switch#sh ip igmp snooping groups
Vlan       Group                     Type      Version         Port List
-----------------------------------------------------------------------
101        224.0.1.129           igmp      v2                 Gi0/7, Gi0/8
101        239.9.0.0               igmp      v2                 Gi0/7
101        239.9.0.1               igmp      v2                 Gi0/7
101        239.9.0.16             igmp      v2                 Gi0/8
101        239.9.0.17             igmp      v2                 Gi0/8
101        239.255.255.250   igmp      v2                 Gi0/7, Gi0/8
101        239.255.255.255   igmp      v2                 Gi0/7, Gi0/8

 

*** All the multicast from edge switch forward to the Core switch, but no receiver request for this stream, thus it dones't goes to Gi0/8 ( another set of same video encoder config

 

Do I miss any setting or I can apply some filter to block the multicast forward to the Core switch but still place the Querier in the Core switch?

 

Giuseppe Larosa
Hall of Fame Master

Hello @tony4336 ,

this is normal for IGMP snooping if a port is classified as mrouter port it will not be subject to IGMP snooping and all known multicast groups are flloded to it.

The port is classified as mrouter port if PIM messages or IGMP queries are received on it and this is what happens with IGMP querier on the core switch,

You would need PIM snooping that I'm afraid is not avaiable on your switch platforms to have a more intelligent managemt of traffic to mrouter ports.

 

Hope to help

Giuseppe

 

Hi Giuseppe,

 

I think you are right, so can I set some filter but still place the IGMP querier into the Core switch without forward all multicast to the mroute port?