cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1911
Views
5
Helpful
2
Replies

NEED HELP: PPPoE CONFIG FOR DUAL-STACK

MOMO
Level 1
Level 1

Hi,

 

I'm trying to simulate an ISP dual-stack PPPoE server to be able to connect multiple home routers as PPPoE clients. So far, the IPv4 seems to work, but the IPv6 is not.

 

My lab setup:

I'm using a Cisco 2600 router as the ISP dual-stack PPPoE server; its interface 0/0 is connected to a Cisco Catalyst 2950 switch just to provide ports for my Linksys home routers to connect to the PPPoE server.

 

My Problem:

1. Homes routers cannot establish PPP session for IPv6. Home routers' WAN interfaces cannot get global IPv6 addresses and no delegated prefixes for the LANs. Please note that IPv4 PPP session is working perfectly.

 

Cisco 2600 config:

hostname IPv6_ISP
!
!
ip dhcp pool DHCP_IPv4
  network 2.2.2.0 255.255.255.0
  default-router 2.2.2.1
  dns-server 8.8.8.8 8.8.4.4
!
ipv6 unicast-routing
!
ipv6 dhcp pool IPv6_DHCP
  prefix-delegation pool PD_Pool1
  dns-server 2001:4860:4860::8888
  dns-server 2001:4860:4860::8844
!

!

username MOMO password 123456789
!
bba-group pppoe PPPoE_LAB
  virtual-template 1
!
!
interface Loopback1
  description SIMULATION_PPPoE_DUALSTACK
  ip address 2.2.2.1 255.255.255.255

  ipv6 address 2001:DB8::1/64
  ipv6 enable
!
interface FastEthernet0/0
  description SIMULATION_PPPoE_DUALSTACK
  pppoe enable group PPPoE_LAB
!
interface Virtual-Template1
  ip unnumbered Loopback1
  ip mtu 1492
  ip tcp adjust-mss 1452 
  ipv6 enable

  ipv6 dhcp server IPv6_DHCP
  peer default ip address dhcp-pool DHCP_IPv4
  peer default ipv6 pool PD_Pool1
  keepalive 5
  ppp mtu adaptive
  ppp authentication chap
  ppp ipcp dns 8.8.8.8 8.8.4.4
!
!
ipv6 local pool PD_Pool1 2001:DB8:1100::/40 48
!
!

 

I really appreciate if you could help.

 

 

2 Replies 2

Hello,

 

below is a working sample config using physical interfaces on the clients. Try and check if you can get this to work:

 

PPPoE Server

 

hostname PPPoE_SERVER
!
ipv6 unicast-routing
ipv6 cef
!
ipv6 dhcp pool IPv6_DHCP
prefix-delegation pool dhcpv6-pool1
address prefix 2001:1::/64
!
bba-group pppoe BBA_IPv6
virtual-template 1
!
interface Loopback0
no ip address
ipv6 address 2001:6::1/64
ipv6 enable
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
media-type rj45
ipv6 address 2001:2::1/64
ipv6 enable
ipv6 nd managed-config-flag
ipv6 dhcp server IPv6_DHCP
pppoe enable group BBA_IPv6
!
interface Virtual-Template1
no ip address
peer default ipv6 pool dhcpv6-pool1
ipv6 unnumbered Loopback0
ipv6 enable
ipv6 nd managed-config-flag
ipv6 nd other-config-flag
ipv6 nd router-preference High
no ipv6 nd ra suppress
ipv6 dhcp server IPv6_DHCP
ppp authentication pap chap callin
!
ipv6 local pool dhcpv6-pool1 2001:5::/32 48

 

PPPoE Client

 

hostname PPPoE_CLIENT
!
ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address autoconfig default
ipv6 enable
ipv6 dhcp client pd PREFDEL rapid-commit

Hi Georg,

 

Thank you so much for helping me on this. I'm still testing the config you suggested. I hope you don't mind answering some questions that I have about your config.

 

1. What is the purpose of the address prefix command on your DHCP pool?

ipv6 dhcp pool IPv6_DHCP
prefix-delegation pool dhcpv6-pool1
address prefix 2001:1::/64

 

2. Your Interface Virtual-Template 1 is tied to Interface Loopback 0, why do you have to set up IPv6 address on Interface Gigabit 0/0?

interface Loopback0
no ip address
ipv6 address 2001:6::1/64
ipv6 enable
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
media-type rj45
ipv6 address 2001:2::1/64
ipv6 enable
ipv6 nd managed-config-flag
ipv6 dhcp server IPv6_DHCP
pppoe enable group BBA_IPv6

 

3. Following your config, what should be the address prefix of the PPPoE client's Interface Gigabit 0/0?

 

I really appreciate this Georg.