10-14-2017 03:51 PM - edited 03-08-2019 12:22 PM
Hello,
I am new to Packet Tracer and I cannot figure out an issue I have. I have a very basic network with a L3 switch. I have only two VLANs (Admin VLAN 100 & Public VLAN 200).
Admin VLAN 100 = 172.16.1.0/24
Public VLAN 200 = 192.168.1.0/24
VLAN 100 SVI = 172.16.1.254
VLAN 200 SVI = 192.168.1.254
Fast Ethernet on the DHCP server is statically set to 172.16.1.10
DHCP Default Gateway is set to the corresponding SVI of each scope.
IP helper-address on VLAN 200 is set to 172.16.1.10
On the switch FE0/1 is connected to the DHCP server and is switchport access vlan 100
FE0/23 is desktop client switchport access vlan 100 (with DHCP enabled on the client) *This client gets DHCP*
FE0/24 is desktop client switchport access vlan 200 (with DHCP enabled on the client) *This client does not*
DHCP server pools are both /24 masks with pools starting at:
172.16.1.100 (100 max users) - default gateway - 172.16.1.254
192.168.1.100 (100 max users) - default gateway - 192.168.1.254
I thought I have set them up correctly in the L3 switch, I have added two scopes to the DHCP server, however the only IPs getting handed out are from VLAN 100 which is the same VLAN as the DHCP's FE card.
I have used ip helper for VLAN 200, given the IP addresses to the SVIs, and enabled IP routing on the L3 switch.
Anyone mind showing me where I am messing this up? First time using a L3 switch. Thanks!
Switch>en
Switch#show run
Building configuration...
Current configuration : 1505 bytes
!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
switchport access vlan 100
switchport mode access
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
switchport access vlan 100
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
mac-address 00e0.b0b0.7c01
ip address 172.16.1.254 255.255.255.0
!
interface Vlan200
mac-address 00e0.b0b0.7c02
ip address 192.168.1.254 255.255.255.0
ip helper-address 172.16.1.10
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Switch#
Solved! Go to Solution.
10-15-2017 07:32 AM
Hello,
don't laugh when I tell you what the problem is in your config: your DHCP server does not have a default gateway configured. Add 172.16.1.254 in the Config tab (Settings)...
10-14-2017 04:25 PM - edited 10-14-2017 04:26 PM
Hello,
Just tested and worked for me using your switch configuration. See attached.
However, you need to create two DHCP scope. If VLAN 200 has IP address 192.168.1.X dont make sense the Client on Vlan 200 get IP address on the scope 172.16.1.X , right?
Also attached a pic of my dhcp server config.
-If I helped you somehow, please, rate it as useful.-
10-14-2017 05:17 PM
I'm even more confused! perhaps I am not versed on how to use the Packet Tracer/DHCP Server scopes?
This is a screenshot of mine, and I still cannot get the client to get an IP on VLAN 200 with this DHCP scope setup on FE0/24
Mine looks pretty close to yours, I just started the pool at x.x.x.100. Any ideas?
10-14-2017 05:34 PM
Try to put the host on Vlan 200 as static ip address, but dont put any address. Then click DHCP again.
If mine works, yours should work as well. I used the same switch config as yours.
10-14-2017 05:37 PM
No luck, still pulling a 169.x.x.x
10-14-2017 05:59 PM
10-14-2017 07:12 PM
With your file, I am now only getting a 192.168.1.1 address on PC1 and a 169.x.x.x on PC0.
Same issue but reversed VLANs. Something wrong with my packet tracer perhaps?
10-14-2017 07:30 PM
Maybe. Try to reinstall. Maybe another version.
But the config is pretty much ok.
-If I helped you somehow, please, rate it as useful.-
10-14-2017 07:46 PM
Thank you for being patient and helping me.
For what its worth I got frustrated and walked away from it. I came back to check your response later, and for whatever reason they are now working!
Something took a long time to function properly.
10-15-2017 01:05 AM
Hello,
out of curiosity I labbed your network in Packet Tracer version 7. Your problem could simply be related to the missing 'spanning-tree portfast' configuration on the access ports. In a 'real' network, without that command. the access ports would take more than 30 seconds to actually have traffic flowing, which usually would cause the DHCP request to time out.
interface FastEthernet0/23
switchport access vlan 100
switchport mode access
spanning-tree portfast
interface FastEthernet0/24
switchport access vlan 200
switchport mode access
spanning-tree portfast
10-15-2017 05:26 AM
Thank you, I am going to recreate another basic network today and I will use that command.
10-15-2017 06:17 AM
I tried portfast with the same config and I am still getting an issue with the one VLAN. This is blowing my mind, and I don't know why this is happening. When I use the Flavio's .pkz file it eventually worked.
I added the spanning-tree portfast commands to each of the access ports per your recommendation, however I am still unable to pull an IP on the 200 VLAN.
Here is my pkz file, if you have a moment could you review this and show me where the issue is?
The only differences I can see between my config and Flavio's (which eventually worked) was that he has a larger DHCP pool than mine.
PC6 the desktop is the culprit.
10-15-2017 06:22 AM
10-15-2017 06:37 AM
10-15-2017 07:08 AM
Same problem you have :(
Our Packet Tracer versions won't play with each other or open your file.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide