cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
765
Views
0
Helpful
4
Replies
jeffpalmer
Beginner

Network printers intermittently not visible or partially visible on the network.

I are experiencing issues where Macbooks are not able to find printers consistently.

We have a Linksys SRW2048 and a Linksys SRW224G4P connected together via their gigabit Ethernet uplink ports. We have a TimeWarner cable modem connected to a port on the SRW2048. There are no VLANs. We have 10 HP ProCurve 420 Wireless Access Points all connected to the SRW224G4P and are powered by PoE. The HP WAPs are all have the same settings and SSID and are configured to hand off from one to the other as a person moves around the building.

This is mostly a Mac shop (all laptops), but we have a few Windows 7 and 10 laptops as well. Most systems are on WiFi.

Internet access is flawless. All printers are on static IP addresses (simple 192.168.1.x network).

If on a Macbook I try to add a printer, not all of the printers list consistently. When opening the printer list, sometimes all the printers on the network are listed, sometimes only some are listed, sometimes none are listed.

We have one user with a wireless HP printer in his office. When they brought the printer in, I set it up (bonjour) and it worked fine. After several hours, they were unable to print. I deleted the printer from his system and tried to re-add it, but it would not list. I tried to add it via it's IP address, but I got a message the printer was not currently available. But if I opened Terminal on his system, I could ping the printer! I used a PC laptop and tried to ping the printer. It would ping fine, but if I stopped and waited a moment, maybe the printer would respond, maybe not. What I mean by that is that if I pinged the printer, it would continue pinging no problem. If I stopped the ping, it would ether not work at all or consistently reply to the ping (it wouldn't drop packets during a string a pings).

I had another user down the hall. They tried to connect to a Sharp business printer (wired in on the other switch) via their Macbook. I couldn't find it on the network, it was unavailable when I tried to add it via IP, and I could not ping it. If I turned off their WiFi and wired their laptop in, they could see the printer just fine! Others in the same room trying to connect to the same printer would sometimes print and sometimes not.

Even more confusing, some are able to print consistently once they were connected to the printer. Even if the printer list didn't show everything, they had no problems printing to the installed printer, be it via bonjour or IP; WiFi or Ethernet.

Since there is WiFi coverage overlap, I cannot be certain if both the printer and the user (in the first case) were on the same physical AP or not, but all APs are together on the same switch. But they should either see each other or not. I shouldn't see them appearing and disappearing. And I certainly shouldn't be unable to connect to the printer, either by bonjour or IP, but be able to ping it.

Again, all the switches and APs are at their proper firmware levels (in the case of the APs, the same firmware level). All the APs are on a single switch together. All the APs are configured exactly the same (right down to the SSID and password, security, etc), and same firmware levels. No one is having any issues with internet connectivity.

It's as if some people are being intermittently blocked randomly.

I've tried resetting all the APs to factory and reconfiguring them one by one. I've factory reset the SRW224G4P and only configured a static IP to access the web interface. I've done the same with the SRW2048 (with this one, the firmware was one rev back, so I updated it, but had to do it via the console because the browser will not completely load the web interface, but that's a different, and apparently known issue). It doesn't matter if the firewall on the Mac is on or off.

Yes, I know the equipment is a bit on the old side, but it came with the building and I have been told to work with what I have. And since internet access is working flawlessly, regardless of whether they are on WiFi or Ethernet (and regardless if the Ethernet is connected to either switch), packets appear to be moving around as they should.

I'm out of ideas on where to look next.

Help!

4 REPLIES 4
Krash Mole
Beginner

Hi,

I would to find out if all APs are interconnected to each other or connected physically to the Switch ?

If they interconnected via Wireless signal, they have to be in repeater mode to be more efficient, and if they all connected physically to a device, are they managed properly so that they can all use the Same SSID and password. Coz if they have been manually set up separately with same SSID and password, they will be a lot conflict; you have to check ranges and channels to avoid them to overlap each other. Check if there is not IP address conflict in your network.

Regards.

The HP ProCurve 420 AP are designed to have the same SSID and password to hand off to one another so you can roam from AP to AP without disconnection (The internal logs show hand-offs from one AP to the next). They are all connected to the same physical switch - SRW224G4P (since they get their power from that switch's PoE). All of the APs have their own static IP address.

I neglected to mention there is also one Apple Airport as well. It has a different SSID/password. It's actually connected to the other switch (SRW2048) and also was not passing DHCP requests.

HI,

can you please share config of SRW224G4P and  SRW2048.

And is your DHCP server a bare-metal or something else?

The DHCP service comes from the ARRIS modem supplied by TimeWarner. Not much to configure there other than the range of the dynamic IPs. The WiFi radios in the modem are disabled.

Both switches were reset to factory with the SRW224G4P given a static IP of 192.168.1.2 and the SRW2048 was given a static IP of 192.168.1.9. There are no VLANs configured.

Anything connected via Ethernet cable to ether switch has no issues with getting an IP address. Only WiFi devices are having intermittent issues with either getting a DHCP address or being able to see other devices on the network.