08-20-2013 03:24 AM - edited 03-07-2019 03:01 PM
Hi every one,
I'm having issue when trying to form LACP etherchannel links between N7k and server. Here's the setup:
SERVER eth0-------N7K-1 Eth102/1/9
SERVER eth1-------N7K-2 Eth102/1/9
Configuration:
N7K-1# sh run int eth102/1/9
interface Ethernet102/1/9
switchport
switchport access vlan 204
channel-group 321
no shutdown
N7K-1# sh run int po321
interface port-channel321
switchport
switchport access vlan 204
flowcontrol send on
vpc 321
N7K-2# sh run int eth102/1/9
interface Ethernet102/1/9
switchport
switchport access vlan 204
channel-group 321
no shutdown
N7K-2# sh run int po321
interface port-channel321
switchport
switchport access vlan 204
flowcontrol send on
vpc 321
vPC status
----------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
-- ---- ------ ----------- ------ ------------
321 Po321 up success success 204
Scenario 1-Etherchannel only without protocol
Both links are up, problem only happened when link to N7K-2 restart. If link to N7K-1 restart no problem.
Scenario 2-Etherchannel with LACP
Both physical links NOT up. Logs showing this:
2013 Aug 20 17:04:31 N7K-1 %ETHPORT-5-IF_DOWN_ADMIN_DOWN: Interface Ethernet102/1/9 is down (Administratively down)
2013 Aug 20 17:04:32 N7K-1 %ETHPORT-5-IF_ADMIN_UP: Interface Ethernet102/1/9 is admin up .
2013 Aug 20 17:04:35 N7K-1 %ETHPORT-5-SPEED: Interface Ethernet102/1/9, operational speed changed to 1 Gbps
2013 Aug 20 17:04:35 N7K-1 %ETHPORT-5-IF_DUPLEX: Interface Ethernet102/1/9, operational duplex mode changed to Full
2013 Aug 20 17:04:35 N7K-1 %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface Ethernet102/1/9, operational Receive Flow Control state changed to off
2013 Aug 20 17:04:35 N7K-1 %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface Ethernet102/1/9, operational Transmit Flow Control state changed to on
2013 Aug 20 17:04:35 N7K-1 %ETHPORT-5-SPEED: Interface port-channel321, operational speed changed to 1 Gbps
2013 Aug 20 17:04:35 N7K-1 %ETHPORT-5-IF_DUPLEX: Interface port-channel321, operational duplex mode changed to Full
2013 Aug 20 17:04:35 N7K-1 %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface port-channel321, operational Receive Flow Control state changed to off
2013 Aug 20 17:04:35 N7K-1 %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface port-channel321, operational Transmit Flow Control state changed to on
2013 Aug 20 17:04:55 N7K-1 %ETH_PORT_CHANNEL-5-PORT_SUSPENDED: Ethernet102/1/9: Ethernet102/1/9 is suspended
2013 Aug 20 17:05:13 N7K-1 %LACP-FEX102-5-LACP_SUSPEND_INDIVIDUAL: LACP port Ethernet102/1/9(0x1f650200) of port-channel port-channel321(0x16000140) not receiving any LACP BPDUs suspending (individual) port
Scenario 3-Etherchannel with LACP to single 3750 switch
All working fine, fail over success as expected.
N7k is using NX-OS 6.0(4)
Anyone facing this issue?
08-20-2013 03:38 AM
Note: configuration on nexus with lacp mode, channel-group 321 mode active
As for now, only static etherchannel is "usable"
Sent from Cisco Technical Support Android App
08-20-2013 05:06 AM
Hi,
How is the teaming configured on the server side? Is LACP enabled?
HTH,
Lei Tian
Sent from Cisco Technical Support iPhone App
08-20-2013 06:06 PM
Hi,
On the server side, bonding is configured with lacp (mode 4, 802.3ad). Test on the scenario 3 (LACP etherchannel to single 3750 switch) confirmed server is configured correctly. Is there any limitation on LACP in N2k?
08-28-2013 03:37 AM
Hi,
Does it work with LACP from cisco switch to FEX? You need enable bpdufilter on the switch port for that test. LACP from FEX to pair N7K is supported, but it could be a bug in 6.0 code. Please open a case with TAC to troubleshoot further.
HTH,
Lei Tian
08-28-2013 05:50 PM
Hi Lei Tian,
I'm working with TAC engineer now. Apparently N7K still not receiving any LACP BPDU even from switch (switch with bpdufilter enable). Will share for any findings.
09-25-2013 06:02 PM
Issues happened due to bug CSCty99763
02-26-2014 10:23 AM
Hi,
I had had this problem before.
Please, put the following command, if in your server side is using LACP:
interface Ethernet102/1/9
switchport
switchport access vlan 204
channel-group 321 mode active
no shutdown
N7K-1# sh run int po321
interface port-channel321
switchport
switchport access vlan 204
flowcontrol send on
vpc 321
N7K-2# sh run int eth102/1/9
interface Ethernet102/1/9
switchport
switchport access vlan 204
channel-group 321 mode active
no shutdown
N7K-2# sh run int po321
interface port-channel321
switchport
switchport access vlan 204
flowcontrol send on
vpc 321
02-26-2014 05:13 PM
Please refer to my 2nd post on Aug 20, 2013
Upgraded to 6.2(2) and solved the problem.
02-28-2014 09:08 AM
We are seeing some very similar issues. We are connecting an HP DL380 g8 server to a CISCO 2000 FEX which goes back to a NX 7000. When we connect through to a 5000 it works.
Even outside of LACP connection, a single connection port won't pass VLAN traffic for us either. VMs can not ping through.
VMware has given us a clean bill of health.
We have opened a TAC case with CISCO and he tech doesn't think our nxos version is affected 6.1[4].
We have tried the 'workaround' with no success.
We have also reviewed (admittedly not completely thoroough) 6.2 patch notes and not seen anything relavant.
CISCO is currently stumped.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide