cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
680
Views
0
Helpful
5
Replies

Nexus 9K Errror Messages

krechtorik
Beginner
Beginner

I have two Cisco 9K's configured in a VPC domain and using HSRP on my SVI's and I keep seeing this error on the VLANs:

 

2020 Aug 2 20:03:02 EST: %ARP-4-OWN_SRCMAC: arp [13964] Received packet with a local source MAC address (0462.73b0.3975) from 10.101.70.253 on Vlan70

 

Any suggestions on what could causing this?

 

Configs:

Primary Switch

vpc domain 100
peer-switch
role priority 1
peer-keepalive destination 10.101.255.253
peer-gateway
auto-recovery

 

interface mgmt0
vrf member management
ip address 10.101.255.254/24

interface Vlan70
no shutdown
no ip redirects
ip address 10.101.70.253/24
no ipv6 redirects
ip router eigrp 100
hsrp 1
preempt
priority 110
ip 10.101.70.254

:::::::::::::::::::::::::::::::::::::::::::::::::::::

 

Secondary Config

vpc domain 100
peer-switch
peer-keepalive destination 10.101.255.254
peer-gateway
auto-recovery

 

interface mgmt0
vrf member management
ip address 10.101.255.253/24

 

interface Vlan70
no shutdown
no ip redirects
ip address 10.101.70.252/24
no ipv6 redirects
ip router eigrp 100
hsrp 1
preempt
ip 10.101.70.254

5 Replies 5

Reza Sharifi
Hall of Fame Expert Hall of Fame Expert
Hall of Fame Expert

Is vPC peering correctly as I don't see an IP as the source.

peer-keepalive destination 10.101.255.253 source 10.101.255.254

Also, what is the output of "sh harp 1 details"

HTH

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

 Red : https://www.cisco.com/c/en/us/td/docs/switches/datacenter/sw/routing_messages/reference/7k_rout_mess_ref_book/7k_rout_mess_ref_2mess.html

 

Error Message     ARP-4-OWN_SRCMAC Format: Received packet with a local source MAC 
address (%s) from %s on %s 

Explanation    There may be a connected router sending packets with local MAC address.

            Recommended Action    Check all routers on the interface for a misconfiguration. 

 M.

 

krechtorik
Beginner
Beginner

The output appears that they are peering correctly:

 

Vlan70 - Group 1 (HSRP-V1) (IPv4)
Local state is Active, priority 110 (Cfged 110), may preempt
Forwarding threshold(for vPC), lower: 0 upper: 110
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.321000 sec(s)
Virtual IP address is 10.101.70.254 (Cfged)
Active router is local
Standby router is 10.101.70.252 , priority 100 expires in 0.450000 sec(s)
Authentication text "cisco"
Virtual mac address is 0000.0c07.ac01 (Default MAC)
2 state changes, last state change 5d02h
IP redundancy name is hsrp-Vlan70-1 (default)

----- Detailed information -----
State History
------------------------------------------------------------
Time Prev State State Event
------------------------------------------------------------
(29)-18:50:35 Standby Active Act Timer Expired.
(29)-18:50:27 Speak Standby Rx Hl from Lo Pri Sby.
(29)-18:50:24 Listen Speak Rx Hl from Lo Pri Sby
(29)-18:50:14 Initial Listen If Enabled-VIP.

 

sh vpc brief
Legend:
(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id : 100
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 27
Peer Gateway : Enabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Enabled, timer is off.(timeout = 240s)
Delay-restore status : Timer is off.(timeout = 30s)
Delay-restore SVI status : Timer is off.(timeout = 10s)

vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po1 up 1-255,300-301,318,400,500,800,997,999-1001

vPC status
----------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
-- ---- ------ ----------- ------ ------------
2 Po2 down* success success -

3 Po3 down* success success -

4 Po4 down* success success -

5 Po5 up success success 1-39,41-255
,300-301,31
8,400,500,8
00,997,999-
1001

Hello!

As others have suggested, this error message indicates that the Nexus is receiving a packet that has the same source MAC address as the VLAN 70 SVI. According to the error message, this packet is also sourced from the same IP address that is assigned to the VLAN 70 SVI. This could be indicative of a loop in the network, as the Nexus's own ARP packets might be looping back to the device.

To assist with troubleshooting this, we'll need the answers to a few questions:

  1. What specific model of Nexus device is experiencing this issue?
  2. What specific NX-OS software release are these Nexus devices running?
  3. Do you see these syslogs on both Nexus devices, or just one?
  4. How many VLANs appear to be affected by this issue?
  5. Are all of the affected VLANs vPC VLANs (meaning, they are not trunked across the vPC Peer-Link?)
  6. What other network devices connect to this VLAN? How are they connected to the Nexus devices?

Thank you!

-Christopher

The issue is corrected. Its actually not causing issues to the network but its a bug on the code.

 

By changing the logging level arp from a 6 to 3 fixed the messages from displaying. 

 

This was Cisco TAC recommendation. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers