cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2848
Views
10
Helpful
6
Replies

NO BPDU sent

Florin Barhala
Frequent Contributor
Frequent Contributor

Hi guys,

I was facing today a strange behavior on a 3560 running 12.2(35)SE5, basically it doesn't send BPDU out of the interface.

Here is the detailed output of spanning-tree and interface configuration.

show spanning-tree interface fa0/1 det

 Port 3 (FastEthernet0/1) of VLAN0001 is root forwarding 
   Port path cost 19, Port priority 128, Port Identifier 128.3.
   Designated root has priority 20481, address 2c54.2d02.e300
   Designated bridge has priority 20481, address 2c54.2d02.e300
   Designated port id is 128.30, designated path cost 0
   Timers: message age 15, forward delay 0, hold 0
   Number of transitions to forwarding state: 2
   Link type is point-to-point by default, Peer is STP
   Loop guard is enabled by default on the port
   BPDU: sent 7, received 10163

 Port 3 (FastEthernet0/1) of VLAN0008 is root forwarding 
   Port path cost 19, Port priority 128, Port Identifier 128.3.
   Designated root has priority 24584, address 2c54.2d02.b440
   Designated bridge has priority 24584, address 2c54.2d02.e300
   Designated port id is 128.30, designated path cost 4
   Timers: message age 16, forward delay 0, hold 0
   Number of transitions to forwarding state: 2
   Link type is point-to-point by default, Peer is STP
   Loop guard is enabled by default on the port
   BPDU: sent 7, received 10156

 Port 3 (FastEthernet0/1) of VLAN0010 is root forwarding 
   Port path cost 19, Port priority 128, Port Identifier 128.3.
   Designated root has priority 20490, address 2c54.2d02.e300
   Designated bridge has priority 20490, address 2c54.2d02.e300
   Designated port id is 128.30, designated path cost 0
   Timers: message age 16, forward delay 0, hold 0
   Number of transitions to forwarding state: 2
   Link type is point-to-point by default, Peer is STP
   Loop guard is enabled by default on the port
   BPDU: sent 6, received 10162

 

show spanning-tree summary 
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is enabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001                     0         0        0          1          1
VLAN0008                     0         0        0          2          2
VLAN0010                     0         0        0          1          1

 

show interfaces fa0/1 switchport 
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

!

interface FastEthernet0/1
 description --- Link to 4948-cr02 ---
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
end

 

The interface is connected to MediaConverter than a fiber connects this to the ISP switch. There runs a QinQ service that ends with another fiber and MC to my other switch, the one that is the root bridge 2c54.2d02.b440.

Here is the output from my other end switch:

 

show spanning-tree interface gi1/30 det
 Port 30 (GigabitEthernet1/30) of VLAN0001 is designated forwarding 
   Port path cost 19, Port priority 128, Port Identifier 128.30.
   Designated root has priority 20481, address 2c54.2d02.e300
   Designated bridge has priority 20481, address 2c54.2d02.e300
   Designated port id is 128.30, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 8965, received 0

 Port 30 (GigabitEthernet1/30) of VLAN0008 is designated forwarding 
   Port path cost 19, Port priority 128, Port Identifier 128.30.
   Designated root has priority 24584, address 2c54.2d02.b440
   Designated bridge has priority 24584, address 2c54.2d02.e300
   Designated port id is 128.30, designated path cost 4
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 8959, received 0

 Port 30 (GigabitEthernet1/30) of VLAN0010 is designated forwarding 
   Port path cost 19, Port priority 128, Port Identifier 128.30.
   Designated root has priority 20490, address 2c54.2d02.e300
   Designated bridge has priority 20490, address 2c54.2d02.e300
   Designated port id is 128.30, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 8965, received 0

!

interface GigabitEthernet1/30
 description --- Uplink to WG building  ---
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

If any importance, CDP seems to work fine on both ends along with VTP (which also works flawlessly).

Of notice that BPDU counters on 2nd switch differ as I reset today "the trouble switch". Any hint would be much appreciated.

 

Uptime on "the trouble switch" is 4 weeks now, but I scheduled a reboot this night. I also updated today STP mode from IEEE to rapid-pvst, and what it actually did: it sent those 7 BPDUs but nothing more.

1 Accepted Solution

Accepted Solutions

Hi,

I believe BPDUs are not sent out from the root port within RSTP.

I don't see them received on my root switch, at least.

So far I have not found any Cisco document stating that clearly, only this thread on the Cisco Learning Network says so:

https://learningnetwork.cisco.com/thread/9334

 

I'll keep researching.

 

Best regards,

Milan

 

 

View solution in original post

6 Replies 6

Florin Barhala
Frequent Contributor
Frequent Contributor

Meanwhile I updated both my switches to RSTP but no luck; I suspect the ISP has something to do with its QinQ service. Any hint if I am going to the right direction?

milan.kulik
Advocate
Advocate

Hi,

 

why do you think the switch should send BPDUs towards his root switch?

The switch sends BPDUs out from all his ports for some short time after reboot - as long as it believes to be a root (that's why you see that 7 BGDUs sent).

But when it receives a BPDU with better priority on some port, it accepts it as a BPDU from a root and stops sending his own BPDUs out from the port pointing to the root.

 

So I believe your switch behaviour might be correct?

 

Best regards,

Milan

 

 

Hello Milan,

From what I know RSTP uses BPDUs as hellos so one BPDU every 2s should be sent.

Any thought guys?

Hi,

I believe BPDUs are not sent out from the root port within RSTP.

I don't see them received on my root switch, at least.

So far I have not found any Cisco document stating that clearly, only this thread on the Cisco Learning Network says so:

https://learningnetwork.cisco.com/thread/9334

 

I'll keep researching.

 

Best regards,

Milan

 

 

learojas206
Beginner
Beginner

Could you resolved it? I am having the same issue, but i think that is a problem from the ISP

Hi,

I never noticed such a behavior before but actually it seems that no bpdu are sent out by root ports after STP convergence or at least STP counters do not log hello/keepalive bpdu .

 

Please note

show spanning-tree interface port-channel 10 detail

Port 1290 (Port-channel10) of VLAN0001 is root forwarding
-------CUT-----
Link type is point-to-point
BPDU: sent 5, received 3774143

 

Port 1290 (Port-channel10) of VLAN0010 is root forwarding
-------CUT-----
Link type is point-to-point
BPDU: sent 5, received 3774087

 

Port 1290 (Port-channel10) of VLAN0011 is root forwarding
-------CUT-----
BPDU: sent 4, received 3773500

 

Port 1290 (Port-channel10) of VLAN0012 is designated forwarding
-------CUT-----
BPDU: sent 3800344, received 0 (received are 0 because vlan 12 is not allowed on root switch port-channel downlink)

 

These are the counters from a switch running XE 03.08.08.E and directly connected to the root switch on which mirror counters are present

 

Regards

MM

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers