06-10-2011 08:52 AM - edited 03-07-2019 12:45 AM
Hi,
I have this scenario.
LAN -----> ISP1 (Primary Link)
------>ISP2 (Secondary Link)
I setup the object tracking so once the primary link fails, it fails over to the secondary link. Below is the configuration.
ip nat pool CWP-INTERNET-4M 186.x.x.x 186.x.x.x netmask 255.255.255.240
ip nat inside source route-map PRIMARY-LINK pool CWP-INTERNET-4M overload
ip nat pool MOV-INTERNET-1M 201.y.y.y 201.y.y.y netmask 255.255.255.240
ip nat inside source route-map SECONDARY-LINK pool MOV-INTERNET-1M overload
route-map PRIMARY-LINK permit 1
match ip address 100
set ip next-hop X.X.X.X
route-map SECONDARY-LINK permit 1
match ip address 120
set ip next-hop Y.Y.Y.Y
access-list 100 deny ip 192.168.91.0 0.0.0.255 10.0.0.0 0.255.255.255
access-list 100 permit ip host 10.20.16.15 any
access-list 100 permit ip host 10.20.16.23 any
access-list 100 permit ip host 10.0.92.150 any
access-list 100 permit ip 192.168.91.0 0.0.0.255 any
interface FastEthernet0/0
description *** PRIMARY LINK ***
ip address 186.x.x.x 255.255.255.240
no ip redirects
bandwidth 4096
full-duplex
speed 100
no keepalive
no cdp enable
!
int FastEthernet0/1
description *** SECONDARY LINK ***
ip address 201.y.y.y 255.255.255.240
no ip redirects
bandwidth 1024
full-duplex
speed 100
no keepalive
no cdp enable
!
ip sla monitor 1
type echo protocol ipIcmpEcho 4.2.2.2
timeout 1000
frequency 3
threshold 2
ip sla monitor schedule 1 life forever start-time now
track 5 rtr 1 reachability
!
ip route 0.0.0.0 0.0.0.0 186.x.x.x track 5
ip route 0.0.0.0 0.0.0.0 201.y.y.y 254
The object tracking feature is functioning but once it fails over to the secondary link, the NAT table remains with the IP pool of the primary link. For some reason it never clears the NAT table. The only way it starts to NAT with secondary pool is to remove " ip nat inside source route-map PRIMARY-LINK pool CWP-INTERNET-4M overload" command.
Let me know if you have experience the same scenario and what is the solution.
Thanks.
Regards.
06-13-2011 04:15 PM
I found the solution through the Cisco Forum. Below is the link.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide