08-30-2017 01:22 PM - edited 03-08-2019 11:53 AM
take a look at the configuration below on one of my 2nd edge router:
=================================================================
access-list 10 remark Offset list
access-list 10 permit 0.0.0.0 255.255.255.255
router eigrp 100
default-metric 100000 100 255 1 1500
network x.x.x.x x.x.x.x
offset-list 10 out 55 FastEthernet0/0
redistribute bgp 123456 route-map L3_BGP_DEFAULT_ROUTE_CME_CERT
=================================================================
Assuming my offset-list ACL is correct (match everything), will this offset-list add a cost of 55 to everything that is advertised downstream per the route-map? Furthermore, if I wanted to ONLY add a cost to the default route in the route-map, would I change my offset-list ACL to '0.0.0.0 0.0.0.0' instead, to only match a default route?
OR, can you call out a prefix list in the offset-list command? See below:
ip prefix-list DEFAULT_ROUTE_PL seq 5 permit 0.0.0.0/0
router eigrp 100
default-metric 100000 100 255 1 1500
network x.x.x.x x.x.x.x
offset-list DEFAULT_ROUTE_PL out 55 FastEthernet0/0
redistribute bgp 123456 route-map L3_BGP_DEFAULT_ROUTE_CME_CERT
08-30-2017 05:51 PM
Hi Shawn,
Assuming my offset-list ACL is correct (match everything), will this offset-list add a cost of 55 to everything that is advertised downstream per the route-map?
That is correct. The offset-list will apply to any route advertised out your Fa0/0 interface, whether internal or external (redistributed). The actual increase in the metric might be somewhat different from the value you have specified due to the complex nature and rounding of the EIGRP composite metric. Also note that the "0.0.0.0 255.255.255.255" in your ACL will be automatically be replaced with the "any" keyword.
if I wanted to ONLY add a cost to the default route in the route-map, would I change my offset-list ACL to '0.0.0.0 0.0.0.0' instead, to only match a default route?
That is also correct. Such an ACL used in an offset-list would only increase the metric of the default route as advertised out Fa0/0, keeping all other metrics unchanged.
OR, can you call out a prefix list in the offset-list command?
You cannot, but you can do a trick with the distribute-list command that allows you to reference a route-map which can then perform a fine-grained modification of the advertised route attributes:
ip prefix-list DefRoute permit 0.0.0.0/0 ! route-map TuneMetrics permit 10 match ip address prefix-list DefRoute set metric 100000 200 255 1 1500 ! route-map TuneMetrics permit 20 ! router eigrp 1 distribute-list route-map TuneMetrics out FastEthernet0/0
You would use this instead of the offset-list you intended to use earlier.
Best regards,
Peter
08-30-2017 06:27 PM
Peter,
Thanks so much for your post. I will either do a match all or match only the default, using the 255.255.255.255, or 0.0.0.0, respectivley. I did have a quick question on method #3, using the prefix list to set a metric. I see that in your reference, you removed the default-metric command from the router config, and placed it under the 'permit 10' statement for the default router, but didn't put anything under the 'permit 20' line. Wouldn't you need to in order to redistribute the networks that fall under this line?
08-31-2017 02:52 AM
Hi Shawn,
Actually, I posted only the "difference" to your current config but I admit that it was kind of confusing. You would in fact have two route-maps; one route-map would be used in the redistribute command to control what networks would be redistributed. The other route-map called TuneMetrics would be used for the distribute-list to modify the metrics of selected routes once they have been injected into EIGRP.
The empty section "route-map TuneMetrics permit 20" is there to allow all other networks to be advertised out Fa0/0 without any change. If this empty section was missing, and my TuneMetrics route-map only had the section 10, then the effect would be different: The default route would have its metrics changed when advertised out Fa0/0, and no other networks would be advertised out that interface at all. That is likely something you do not intend.
As for the "default-metric" command, I just skipped it, but I did not intend to remove it completely.
The complete configuration would be like this:
ip prefix-list DefRoute permit 0.0.0.0/0 ! route-map TuneMetrics permit 10 match ip address prefix-list DefRoute set metric 100000 200 255 1 1500 ! route-map TuneMetrics permit 20 ! router eigrp 100 default-metric 100000 100 255 1 1500 network x.x.x.x x.x.x.x distribute-list route-map TuneMetrics out FastEthernet0/0 redistribute bgp 123456 route-map L3_BGP_DEFAULT_ROUTE_CME_CERT
Would this make more sense? Please feel welcome to ask further!
Best regards,
Peter
08-31-2017 05:49 AM
Fantastic, Peter. Thank you very much for this response. One last question for you. If my ASR 1 config has the same "default-metric" as my ASR 2 config, would I simply only need to increase the value of the default-metric on ASR 2 so my downstream device prefers ASR 1?
Quick example:
ASR1:
router eigrp 100 default-metric 100000 100 255 1 1500 network x.x.x.x x.x.x.x redistribute bgp 123456 route-map L3_BGP_DEFAULT_ROUTE_CME_CERT
ASR2:
router eigrp 100 default-metric 100000 150 255 1 1500 network x.x.x.x x.x.x.x redistribute bgp 123456 route-map L3_BGP_DEFAULT_ROUTE_CME_CERT
Would this configuration work, and allow me to not even have to use an offset-list? I simply changed the second value (delay?) in the default-metric command on ASR2, which should force the downstream device to prefer the routes from ASR1.
And just to confirm, this default-metric command in the router eigrp 100 configuration will add the appropriate metrics to the redistributed subnets, correct?
08-31-2017 09:15 AM
Hi Shawn,
If my ASR 1 config has the same "default-metric" as my ASR 2 config, would I simply only need to increase the value of the default-metric on ASR 2 so my downstream device prefers ASR 1?
Yes, that should work. In the end, the lowest metric for a given route wins. Therefore, if ASR 2 uses a default-metric that results in a consistently higher composite metric for redistributed routes than what ASR 1 advertises, each router should prefer paths through ASR 1.
You might need to play with the metrics on ASR 2 a little to see what increase in the delay produces a sufficient increase in the composite metric to make your entire network converge through ASR 1 by default. Perhaps you should consider making the delay advertised from ASR 2 considerably larger than from ASR 1 - let's use delay of 1 on ASR 1, and delay of 1000 on ASR 2.
By the way, changing the delay factor is the correct way of influencing the route metric in EIGRP - you are doing it right.
Would this configuration work, and allow me to not even have to use an offset-list?
As I do not know your exact network topology, it is a blind shot, but in general, yes, this should do the trick - your ASR 2 will redistribute the routes with a higher metric than ASR 1, making the rest of the network to prefer ASR 1. The cost of paths from ASR 1 and ASR 2 to every other router in the network might still play some role, as this cost will ultimately be added to the initial metric of the redistributed routes, but that is why I suggested making ASR 2 advertise the same set of redistributed routes with a significantly higher metric.
And just to confirm, this default-metric command in the router eigrp 100 configuration will add the appropriate metrics to the redistributed subnets, correct?
That is correct. The default-metric command specifies the redistribution metric for all networks where the redistribution metric was not specified directly in the redistribute command or an associated route-map (if there is any).
As always, feel welcome to ask further!
Best regards,
Peter
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide