Showing results for 
Search instead for 
Did you mean: 
Join Customer Connection to register!

Pix running config problems/questions

Hi, having a problem w/ being able to erase a flashfile on a pixp[ver 6.31]. Basically my problem is that I'm trying to get rid of the "running-config" which is supposed to be deleted upon a reset so I'm a little confused if the "write mem" is working correctly. Basically when I do a "write mem" start-up is getting erased but when I do a "show runn" it's still there which is ok. But when I perform a "reload" or cold boot the running config isn't getting cleared out. Now from what the book says about cisco flashfs for this version, the start-up config(emty) should be over righting the running config during reboot and for some reason it isn't happening. When I do "show run" after reboot it has the same config from b/f reboot.

here I'm pressing enter here and after a while it comes back but I'm not getting a confirmation at this point.

When I do a "show start" I'm getting the startup config as being gone. When I do a "show run" I'm getting the config file that I'm trying to get rid of. When I do a "reload" and confirm and the routerw has rebooted and still has the unwanted config when I "show runn". I've tried to do a copy start run but syntax on 6.31 doesn't allow for it. If I reset this to factory defaults will this solve the problem? Aslo is there a way to do it from the flash memory file systems somehow? I looked in the book and talks about how this version of Pix515 w/ ver. 6.31 doesn't have file-system names but the pix itself will actually assign abitrary #'s such as 1 for startup config gets copied to the running config upon bootup but this isn't happening in the instance for some reason. I've tried this both on the Pri pix and Sec pix just to cofirm this isn't a hardwear problem and getting same results on each hardwear platform. mainly I'm trying to track down the way to clear the "file 1" out of the "flash" I know there is a way just having problems with the syntax below indexing the individual flash files. If anyone knows a better way to do this I would apprceciate the input. This is my first time on Pix's and I'm a little gunshy. Thanks.

Write Erase

Erase PIX configuration in flash memory? [confirm]

pressing enter hear. Takes command. No other prompts.

Flash FS


1-startup config and is copied into running config when this boots.

Usage: [no|clear|show] flashfs [downgrade 4.X|5.1|5.0]

Cisco Employee


Use the write erase to delete the flash memory configuration.

From the prompt just type it and you will get a confirmation message, check below:

write erase

Erase PIX configuration in Flash memory? [confirm] y


Proceed with reload? [confirm] y

The clear flash command does not affect the configuration stored in flash memory.

HOpe it helps,

Franco Zamora


Thanks for your reponse, I'm getting the same thing as I was before. For some reason. Should I upgrade or would a reset to defaults fix this? From the Cisco documentation it says that the reload should cause the start up config to be copied to the running conig upon boot but for some reason it isn't. I'm kinda at my wit's end on this. Thanks again.