10-26-2015 01:59 PM - edited 03-08-2019 02:27 AM
Hello All,
we are trying to connect either a 2960 or stack of 3750 to nexus 7000 switches.
apart from having a port channel , is there anything else that needs to be done on both sides for this to work.
are there any restrictions for this ?
thanks in advance.
Solved! Go to Solution.
10-28-2015 03:20 PM
VPC 11 is just an ID. It can range from 1 to 4096. VPC ID does not have to be the same as the port channel number, but has to be the same in both switches.You need to configure VPC ID to tell your switch that these ports are VPC members.
And with ID you are specifying which ports are being bundled toward a downstream switch. How your switch understands which ports are bundled while one part of port channel is on 7k1 and another one is on 7k2? With VPC ID.
Just to mention, you need to configure both 7ks.
7k1
interface port-channel11
switchport
switchport mode trunk
vpc 11
interface Ethernet1/21
switchport
switchport mode trunk
channel-group 11 mode active
no shutdown
7k2
interface port-channel11
switchport
switchport mode trunk
vpc 11
interface Ethernet1/22
switchport
switchport mode trunk
channel-group 11 mode active
no shutdown
Masoud
10-26-2015 04:15 PM
Hello,
Your 2960 and 3750 see the VPC peers as a single switch so you need to configure only port channels on them. Even ip base IOSs support port channel. Since access switches see the VPC switches as a single switch, spanning tree does not block the links, but you should consider it.
Please check the link below for 3750 and nexus configuration.
http://www.fryguy.net/2010/09/13/lacp-configuration-and-multi-chassis-etherchannel-on-nexus-7000-with-vpc-part-2-of-2/
Spaning-tree check-list
http://www.cisco.com/c/dam/en/us/products/collateral/switches/nexus-7000-series-switches/C07-572834-00_STDG_NX-OS_vPC_DG.pdf
10-26-2015 07:21 PM
Thanks Reza & Masoud.
The two 7k's are in vpc together.
Assuming its a stack of four 3750's being connected to the two 7k's, plan is to connect two connections each from 3750's ( switch 1 & Switch 4) to one connection each on the 7k's.
So it will look like this:-
3750-1 (port x/y/z) ------> 7k-1 (port a/b/c)
3750-2 (port x/y/z) ------> 7k-2 (port a/b/c)
& these together will form a port channel interface.
Is this the correct way? Please help on this.
10-26-2015 07:30 PM
Hi,
Yes, having 2 ports from the first switch and 2 ports from the last switch will work fine. You can also use one port from each switch (4 ports) and VPC to both 7ks.
HTH
10-26-2015 07:45 PM
Thanks Reza.
So we will be using one 2 ports from two 3750 stack members & connect them to two ports(one each) on the 7k's.
Will port-channel on both ends ( involving the ports ) be fine or should it be needing some vpc type configurations?
10-26-2015 08:02 PM
My suggesion is connecting 2 ports from switch 3750-1 to 7k1 and 7k2 and two ports from 3750-2 to 7k1 and 7k2. Totally 4 links. Since 3750s are stack and 7ks are stack too, you only need one port channel including 4 ports.
You do not need any VPC configuration on 3750, but you need on 7ks. Just one VPC command.
10-27-2015 06:21 PM
Thanks both again.
Its a stack of four 3750's with the uplinks from switch-1 & switch-2 being used as interconnects to N7k's.
3750-1 (port 1/1/1) ------> 7k-1 (port 1/21)
3750-2 (port 2/1/1) ------> 7k-2 (port 1/22)
On the 3750 end, both ports 1/1/1 & 2/1/1 will be together in Po11, similarly on the 7k's both the ports 1/21 & 1/22 will be in Po11.
Sorry, i am not understanding the vPC requirement on the 7k end. why do we need that on 7k's for these connections.
Appreciate some inputs so i get a good grasp of this & it will be really helpful if i can get a sample configuration for achieving this using above example. Thanks in advance.
10-27-2015 06:34 PM
Hello,
Here is a sample configuration.
On 3750
************************************************
interface GigabitEthernet 1/1/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 11 mode active
interface GigabitEthernet2/1/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 11 mode active
interface Port-channel11
switchport trunk encapsulation dot1q
switchport mode trunk
***************************************************
On 7k
******************************************************
interface Ethernet1/21
switchport
switchport mode trunk
channel-group 11 mode active
no shutdown
interface Ethernet1/22
switchport
switchport mode trunk
channel-group 11 mode active
no shutdown
interface port-channel11
switchport
switchport mode trunk
vpc 11
sh int port-channel 11
************************************************************
Hope it helps,
Masoud
10-28-2015 02:25 PM
Thanks again.
Pardon me, but i am just trying to grasp an understanding of vpc on the po11 at 7k end.
what happens if that vpc11 is not included in Po11 at 7K. appreciate inputs.
10-28-2015 02:55 PM
what happens if that vpc11 is not included in Po11 at 7K
Since the config above is showing one 3750 is connecting to ONE 7k, the "vpc 11" command under po11 does not do anything. If you ware to connect the same 3750 to TWO different 7ks, you would need to have the VPC command.
VPC is needed when you are connecting a device (3560, 3750, FEX, etc) to 2 different Nexus switches and the 2 switches are VPCed together, if not you just need a simple Portchannel.
HTH
10-28-2015 03:20 PM
VPC 11 is just an ID. It can range from 1 to 4096. VPC ID does not have to be the same as the port channel number, but has to be the same in both switches.You need to configure VPC ID to tell your switch that these ports are VPC members.
And with ID you are specifying which ports are being bundled toward a downstream switch. How your switch understands which ports are bundled while one part of port channel is on 7k1 and another one is on 7k2? With VPC ID.
Just to mention, you need to configure both 7ks.
7k1
interface port-channel11
switchport
switchport mode trunk
vpc 11
interface Ethernet1/21
switchport
switchport mode trunk
channel-group 11 mode active
no shutdown
7k2
interface port-channel11
switchport
switchport mode trunk
vpc 11
interface Ethernet1/22
switchport
switchport mode trunk
channel-group 11 mode active
no shutdown
Masoud
10-26-2015 04:40 PM
Hi,
If you are connecting the 2960 or the 3750 to 2 Nexus 7000 switches and the 7ks are VPCed together, you would need to configure the 7ks with VPC. If you are connecting them to only one 7k, than all you need is a Portchannel.
HTH
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide